HighFix available
libxml2 — security advisory
In libxml2 before 2.15.4, xmlURIEscapeStr in uri.c has an integer overflow.
- Products
- libxml2
- Affected versions
- 2.14.5+dfsg-0.2, 2.14.5+dfsg-0.2build1, 2.15.1+dfsg-0.3, 2.15.1+dfsg-0.4, 2.15.1+dfsg-1, 2.15.1+dfsg-2, 2.15.1+dfsg-2ubuntu1, 2.15.1+dfsg-2ubuntu2, 2.15.2+dfsg-0.1, 2.15.2+dfsg-0.1ubuntu0.1, 2.15.2+dfsg-0.1ubuntu0.2
- Fixed versions
- 2.15.2+dfsg-0.1ubuntu0.3
- CVEs
- CVE-2026-86139
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 28 Oct 2026, 10:44 UTC · Revision 1
Source evidence
In libxml2 before 2.15.4, xmlURIEscapeStr in uri.c has an integer overflow.
osv:UBUNTU-CVE-2026-86139
libxml2
Fixed versions: 2.15.2+dfsg-0.1ubuntu0.3
Complete source record
{
"id": "a210726ddb2c1a0fdbad5f1a79851398e46f9080a98dd2c244c16dc0a783ef1b",
"url": "https://osv.dev/vulnerability/UBUNTU-CVE-2026-86139",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "UBUNTU-CVE-2026-86139",
"summary": "In libxml2 before 2.15.4, xmlURIEscapeStr in uri.c has an integer overflow.",
"evidence": "osv:UBUNTU-CVE-2026-86139",
"products": [
{
"name": {
"value": "libxml2",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "2.15.2+dfsg-0.1ubuntu0.3",
"evidence": "/affected/0/ranges"
}
],
"affected_versions": [
{
"value": "2.14.5+dfsg-0.2",
"evidence": "/affected/0/versions"
},
{
"value": "2.14.5+dfsg-0.2build1",
"evidence": "/affected/0/versions"
},
{
"value": "2.15.1+dfsg-0.3",
"evidence": "/affected/0/versions"
},
{
"value": "2.15.1+dfsg-0.4",
"evidence": "/affected/0/versions"
},
{
"value": "2.15.1+dfsg-1",
"evidence": "/affected/0/versions"
},
{
"value": "2.15.1+dfsg-2",
"evidence": "/affected/0/versions"
},
{
"value": "2.15.1+dfsg-2ubuntu1",
"evidence": "/affected/0/versions"
},
{
"value": "2.15.1+dfsg-2ubuntu2",
"evidence": "/affected/0/versions"
},
{
"value": "2.15.2+dfsg-0.1",
"evidence": "/affected/0/versions"
},
{
"value": "2.15.2+dfsg-0.1ubuntu0.1",
"evidence": "/affected/0/versions"
},
{
"value": "2.15.2+dfsg-0.1ubuntu0.2",
"evidence": "/affected/0/versions"
}
]
}
],
"severity": "high",
"structured": {
"id": "UBUNTU-CVE-2026-86139",
"aliases": [
"UBUNTU-CVE-2026-86139"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:L"
},
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H"
},
{
"type": "Ubuntu",
"score": "medium"
}
],
"affected": [
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "2.15.2+dfsg-0.1ubuntu0.3"
}
]
}
],
"package": {
"name": "libxml2",
"purl": "pkg:deb/ubuntu/libxml2?arch=source&distro=resolute",
"ecosystem": "Ubuntu:26.04:LTS"
},
"versions": [
"2.14.5+dfsg-0.2",
"2.14.5+dfsg-0.2build1",
"2.15.1+dfsg-0.3",
"2.15.1+dfsg-0.4",
"2.15.1+dfsg-1",
"2.15.1+dfsg-2",
"2.15.1+dfsg-2ubuntu1",
"2.15.1+dfsg-2ubuntu2",
"2.15.2+dfsg-0.1",
"2.15.2+dfsg-0.1ubuntu0.1",
"2.15.2+dfsg-0.1ubuntu0.2"
],
"database_specific": {
"source": "https://github.com/canonical/ubuntu-security-notices/blob/main/osv/cve/2026/UBUNTU-CVE-2026-86139.json"
},
"ecosystem_specific": {
"binaries": [
{
"binary_name": "libxml2-16",
"binary_version": "2.15.2+dfsg-0.1ubuntu0.3"
},
{
"binary_name": "libxml2-source",
"binary_version": "2.15.2+dfsg-0.1ubuntu0.3"
},
{
"binary_name": "libxml2-utils",
"binary_version": "2.15.2+dfsg-0.1ubuntu0.3"
},
{
"binary_name": "python3-libxml2",
"binary_version": "2.15.2+dfsg-0.1ubuntu0.3"
}
],
"availability": "No subscription required"
}
}
],
"modified": "2026-10-09T07:45:02.903457059Z",
"provider": "osv",
"upstream": [
"CVE-2026-86139"
],
"references": [
"https://ubuntu.com/security/CVE-2026-86139",
"https://www.cve.org/CVERecord?id=CVE-2026-86139",
"https://ubuntu.com/security/notices/USN-8910-1"
]
},
"related_cves": [
{
"value": "CVE-2026-86139",
"evidence": "/upstream"
}
],
"security_relevant": true,
"severity_evidence": "/severity/1/score"
},
"source_id": "core-osv",
"document_id": 108946,
"published_at": "2026-09-05T05:17:00+00:00"
}