Unsafe deserialization of user data in yiisoft/yii
Yii is an open source PHP web framework. yiisoft/yii before version 1.1.29 are vulnerable to Remote Code Execution (RCE) if the application calls `unserialize()` on arbitrary user input. An attacker may leverage this vulnerability to compromise the host system. A fix has been developed for the 1.1.29 release. Users are advised to upgrade. There are no known workarounds for this vulnerability.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2023-47130
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 7 Nov 2026, 21:00 UTC · Revision 1
Source evidence
Unsafe deserialization of user data in yiisoft/yii
core-osv · Original sourcePublished 14 Nov 2023, 20:30 UTC
Yii is an open source PHP web framework. yiisoft/yii before version 1.1.29 are vulnerable to Remote Code Execution (RCE) if the application calls `unserialize()` on arbitrary user input. An attacker may leverage this vulnerability to compromise the host system. A fix has been developed for the 1.1.29 release. Users are advised to upgrade. There are no known workarounds for this vulnerability.
osv:CVE-2023-47130
Complete source record
{
"id": "ce77f1d6f5ae2bb6df823e53ca1705e7cf34df93935f47192d4254d384379d67",
"url": "https://osv.dev/vulnerability/CVE-2023-47130",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "Unsafe deserialization of user data in yiisoft/yii",
"summary": "Yii is an open source PHP web framework. yiisoft/yii before version 1.1.29 are vulnerable to Remote Code Execution (RCE) if the application calls `unserialize()` on arbitrary user input. An attacker may leverage this vulnerability to compromise the host system. A fix has been developed for the 1.1.29 release. Users are advised to upgrade. There are no known workarounds for this vulnerability.",
"evidence": "osv:CVE-2023-47130",
"products": [],
"severity": "high",
"structured": {
"id": "CVE-2023-47130",
"aliases": [
"CVE-2023-47130",
"GHSA-mw2w-2hj2-fg8q"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/yiisoft/yii",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "f89b76ecca1d342e346ebb9bfc1e2c589f696345"
},
{
"fixed": "37142be4dc5831114a375392e86d6450d4951c06"
}
],
"database_specific": {
"extracted_events": [
{
"range": [
{
"introduced": "0"
},
{
"fixed": "1.1.29"
}
],
"source": "AFFECTED_FIELD",
"strategy": "StringRangeExpression"
},
{
"range": [
{
"fixed": "37142be4dc5831114a375392e86d6450d4951c06"
}
],
"source": "REFERENCES_COMMIT"
}
]
}
}
],
"versions": [
"1.1.28",
"1.1.27",
"1.1.26",
"1.1.25",
"1.1.24",
"1.1.23",
"1.1.22",
"1.1.21",
"1.1.20",
"1.1.19",
"1.1.18",
"1.1.17",
"1.1.14",
"1.1.14-rc",
"1.1.13",
"1.1.13-RC",
"1.1.12",
"1.1.11",
"1.1.10",
"1.1.9",
"1.1.8",
"1.1.7",
"1.1.4",
"1.1.3",
"1.1.0",
"1.1rc",
"1.1b",
"1.0rc",
"1.0a"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2023-47130.json"
}
}
],
"modified": "2026-10-28T02:30:51.516604757Z",
"provider": "osv",
"references": [
"https://owasp.org/www-community/vulnerabilities/PHP_Object_Injection",
"https://github.com/CVEProject/cvelistV5/tree/main/cves/2023/47xxx/CVE-2023-47130.json",
"https://github.com/yiisoft/yii/security/advisories/GHSA-mw2w-2hj2-fg8q",
"https://nvd.nist.gov/vuln/detail/CVE-2023-47130",
"https://github.com/yiisoft/yii/commit/37142be4dc5831114a375392e86d6450d4951c06"
],
"provider_metadata": {
"cwe_ids": [
"CWE-502"
],
"cna_assigner": "GitHub_M",
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2023/47xxx/CVE-2023-47130.json"
}
},
"related_cves": [
{
"value": "CVE-2023-47130",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 520397,
"published_at": "2023-11-14T20:30:16.393+00:00"
}