Unrated
Kanban Boards for WordPress < 2.5.21 - Admin+ Stored XSS
Type: advisorySources: OSV
The Kanban Boards for WordPress plugin before 2.5.21 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup)
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2023-0873
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 5 Nov 2026, 04:13 UTC · Revision 1
Source evidence
Kanban Boards for WordPress < 2.5.21 - Admin+ Stored XSS
core-osv · Original sourcePublished 27 Jun 2023, 13:17 UTC
The Kanban Boards for WordPress plugin before 2.5.21 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup)
osv:CVE-2023-0873
Complete source record
{
"id": "efa69e2890900e9d29430d4c46bd4977098b0b81cc9f821443604c069a0a487a",
"url": "https://osv.dev/vulnerability/CVE-2023-0873",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "Kanban Boards for WordPress < 2.5.21 - Admin+ Stored XSS",
"summary": "The Kanban Boards for WordPress plugin before 2.5.21 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup)",
"evidence": "osv:CVE-2023-0873",
"products": [],
"severity": "unknown",
"structured": {
"id": "CVE-2023-0873",
"aliases": [
"CVE-2023-0873"
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/kanbanwp/kanban",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "33afed199ac0c8408904060348259eb8723d8178"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:kanbanwp:kanban_boards_for_wordpress:*:*:*:*:*:wordpress:*:*",
"range": [
{
"introduced": "0"
},
{
"fixed": "2.5.21"
}
],
"source": "CPE_RANGE"
}
]
}
}
],
"versions": [
"2.5.20",
"2.5.19",
"2.5.15",
"2.5.12",
"2.5.11",
"2.5.10",
"2.5.9",
"2.5.8",
"2.5.7",
"2.5.6",
"2.5.5",
"2.5.4",
"2.5.3",
"2.5.2",
"2.5.0",
"2.4.10",
"2.4.9",
"2.4.8",
"2.4.7",
"2.4.6",
"2.4.5",
"2.4.4",
"2.4.3",
"2.4.2",
"2.4.1",
"2.4.0",
"2.3.11",
"2.3.10",
"2.3.9",
"2.3.8",
"2.3.7",
"2.3.6",
"2.3.5",
"2.3.4",
"2.3.3",
"2.3.2",
"2.3.1",
"2.3.0",
"2.2.8",
"2.2.7",
"2.2.6",
"2.2.5",
"2.2.4",
"2.2.3",
"2.2.2",
"2.2.1",
"2.2.0",
"2.1.10",
"2.1.9",
"2.1.8",
"2.1.7",
"2.1.6",
"2.1.5",
"2.1.4",
"2.1.3",
"2.1.2",
"2.1.1",
"2.1.0",
"2.0.11",
"2.0.10",
"2.0.9",
"2.0.8",
"2.0.7",
"2.0.6",
"2.0.5",
"2.0.4",
"2.0.3",
"2.0.2",
"2.0.1",
"2.0",
"1.2.18",
"1.2.17",
"1.2.16",
"1.2.15",
"1.2.14",
"1.2.13",
"1.2.12",
"1.2.11",
"1.2.10",
"1.2.9",
"1.2.8",
"1.2.7",
"1.2.6",
"1.2.5",
"1.2.4",
"1.2.2",
"1.2.1",
"1.2.0",
"1.1.2",
"1.1.1",
"1.1.0",
"1.0.0"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2023-0873.json"
}
}
],
"modified": "2026-10-28T02:30:42.442193248Z",
"provider": "osv",
"references": [
"https://wordpress.org/plugins",
"https://github.com/CVEProject/cvelistV5/tree/main/cves/2023/0xxx/CVE-2023-0873.json",
"https://nvd.nist.gov/vuln/detail/CVE-2023-0873",
"https://wpscan.com/vulnerability/8816d4c1-9e8e-4b6f-a36a-10a98a7ccfcd"
],
"provider_metadata": {
"cna_assigner": "WPScan",
"unresolved_ranges": [
{
"extracted_events": [
{
"range": [
{
"fixed": "2.5.21"
}
],
"source": "AFFECTED_FIELD",
"strategy": "StandardRange"
}
]
}
],
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2023/0xxx/CVE-2023-0873.json"
}
},
"related_cves": [
{
"value": "CVE-2023-0873",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": null
},
"source_id": "core-osv",
"document_id": 510182,
"published_at": "2023-06-27T13:17:15.735+00:00"
}