UnratedFix available
ckeditor, ckeditor3 — security advisory
Cross-site scripting (XSS) vulnerability in the Preview plugin before 4.4.3 in CKEditor allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.
- Products
- ckeditor, ckeditor3
- Affected versions
- 3.6.6.1+dfsg-7
- Fixed versions
- 4.4.4+dfsg1-1
- CVEs
- CVE-2014-5191
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 31 Oct 2026, 21:37 UTC · Revision 1
Source evidence
Cross-site scripting (XSS) vulnerability in the Preview plugin before 4.4.3 in CKEditor allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.
osv:DEBIAN-CVE-2014-5191
ckeditor
Fixed versions: 4.4.4+dfsg1-1
ckeditor3
Fixed versions: Not specified
Complete source record
{
"id": "7801272e8ccc42b53cc0dd60d6cd6028adec8eef3dd679a43a2d45a4b9d137a3",
"url": "https://osv.dev/vulnerability/DEBIAN-CVE-2014-5191",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "DEBIAN-CVE-2014-5191",
"summary": "Cross-site scripting (XSS) vulnerability in the Preview plugin before 4.4.3 in CKEditor allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.",
"evidence": "osv:DEBIAN-CVE-2014-5191",
"products": [
{
"name": {
"value": "ckeditor",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "4.4.4+dfsg1-1",
"evidence": "/affected/0/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "ckeditor3",
"evidence": "/affected/1/package/name"
},
"prerequisites": [],
"fixed_versions": [],
"affected_versions": [
{
"value": "3.6.6.1+dfsg-7",
"evidence": "/affected/1/versions"
}
]
}
],
"severity": "unknown",
"structured": {
"id": "DEBIAN-CVE-2014-5191",
"aliases": [
"DEBIAN-CVE-2014-5191"
],
"affected": [
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "4.4.4+dfsg1-1"
}
]
}
],
"package": {
"name": "ckeditor",
"purl": "pkg:deb/debian/ckeditor?arch=source&distro=bookworm",
"ecosystem": "Debian:12"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2014-5191.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
}
]
}
],
"package": {
"name": "ckeditor3",
"purl": "pkg:deb/debian/ckeditor3?arch=source&distro=bookworm",
"ecosystem": "Debian:12"
},
"versions": [
"3.6.6.1+dfsg-7"
],
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2014-5191.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
}
],
"modified": "2026-10-23T15:47:25.262940173Z",
"provider": "osv",
"upstream": [
"CVE-2014-5191"
],
"references": [
"https://security-tracker.debian.org/tracker/CVE-2014-5191"
]
},
"related_cves": [
{
"value": "CVE-2014-5191",
"evidence": "/upstream"
}
],
"security_relevant": true,
"severity_evidence": null
},
"source_id": "core-osv",
"document_id": 413832,
"published_at": "2014-08-07T11:13:37.063+00:00"
}