gobgp — security advisory
A vulnerability was determined in osrg GoBGP up to 4.3.0. Affected by this vulnerability is the function parseRibEntry of the file pkg/packet/mrt/mrt.go. Executing a manipulation can lead to integer underflow. It is possible to launch the attack remotely. Upgrading to version 4.4.0 addresses this issue. This patch is called 76d911046344a3923cbe573364197aa081944592. It is suggested to upgrade the affected component.
- Products
- gobgp
- Affected versions
- 3.10.0-1, 3.16.0-1, 3.19.0-1, 3.21.0-1, 3.23.0-1, 3.25.0-1, 3.27.0-1, 3.28.0-1, 3.29.0-1, 3.30.0-1, 3.31.0-1, 3.32.0-1, 3.33.0-1, 3.35.0-1, 3.36.0-1, 3.36.0-2, 4.3.0-1, 4.4.0-1, 4.5.0-1, 4.5.0-1~bpo13+1, 4.6.0-1, 4.6.0-2, 4.6.0-2~bpo13+1, 4.7.0-1, 4.7.0-1~bpo13+1, 4.8.0-1, 4.8.0-1~bpo13+1, 4.8.0-2~exp1
- Fixed versions
- 4.4.0-1
- CVEs
- CVE-2026-7736
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 1 Nov 2026, 17:53 UTC · Revision 2
Source evidence
A vulnerability was determined in osrg GoBGP up to 4.3.0. Affected by this vulnerability is the function parseRibEntry of the file pkg/packet/mrt/mrt.go. Executing a manipulation can lead to integer underflow. It is possible to launch the attack remotely. Upgrading to version 4.4.0 addresses this issue. This patch is called 76d911046344a3923cbe573364197aa081944592. It is suggested to upgrade the affected component.
osv:DEBIAN-CVE-2026-7736
gobgp
Fixed versions: Not specified
gobgp
Fixed versions: Not specified
gobgp
Fixed versions: 4.4.0-1
Complete source record
{
"id": "e1010d73af722a9f7d47985fe911807fa05cc2d7189c3f1246aef1c402cf2323",
"url": "https://osv.dev/vulnerability/DEBIAN-CVE-2026-7736",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "DEBIAN-CVE-2026-7736",
"summary": "A vulnerability was determined in osrg GoBGP up to 4.3.0. Affected by this vulnerability is the function parseRibEntry of the file pkg/packet/mrt/mrt.go. Executing a manipulation can lead to integer underflow. It is possible to launch the attack remotely. Upgrading to version 4.4.0 addresses this issue. This patch is called 76d911046344a3923cbe573364197aa081944592. It is suggested to upgrade the affected component.",
"evidence": "osv:DEBIAN-CVE-2026-7736",
"products": [
{
"name": {
"value": "gobgp",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [],
"affected_versions": [
{
"value": "3.10.0-1",
"evidence": "/affected/0/versions"
},
{
"value": "3.16.0-1",
"evidence": "/affected/0/versions"
},
{
"value": "3.19.0-1",
"evidence": "/affected/0/versions"
},
{
"value": "3.21.0-1",
"evidence": "/affected/0/versions"
},
{
"value": "3.23.0-1",
"evidence": "/affected/0/versions"
},
{
"value": "3.25.0-1",
"evidence": "/affected/0/versions"
},
{
"value": "3.27.0-1",
"evidence": "/affected/0/versions"
},
{
"value": "3.28.0-1",
"evidence": "/affected/0/versions"
},
{
"value": "3.29.0-1",
"evidence": "/affected/0/versions"
},
{
"value": "3.30.0-1",
"evidence": "/affected/0/versions"
},
{
"value": "3.31.0-1",
"evidence": "/affected/0/versions"
},
{
"value": "3.32.0-1",
"evidence": "/affected/0/versions"
},
{
"value": "3.33.0-1",
"evidence": "/affected/0/versions"
},
{
"value": "3.35.0-1",
"evidence": "/affected/0/versions"
},
{
"value": "3.36.0-1",
"evidence": "/affected/0/versions"
},
{
"value": "3.36.0-2",
"evidence": "/affected/0/versions"
},
{
"value": "4.3.0-1",
"evidence": "/affected/0/versions"
},
{
"value": "4.4.0-1",
"evidence": "/affected/0/versions"
},
{
"value": "4.5.0-1",
"evidence": "/affected/0/versions"
},
{
"value": "4.5.0-1~bpo13+1",
"evidence": "/affected/0/versions"
},
{
"value": "4.6.0-1",
"evidence": "/affected/0/versions"
},
{
"value": "4.6.0-2",
"evidence": "/affected/0/versions"
},
{
"value": "4.6.0-2~bpo13+1",
"evidence": "/affected/0/versions"
},
{
"value": "4.7.0-1",
"evidence": "/affected/0/versions"
},
{
"value": "4.7.0-1~bpo13+1",
"evidence": "/affected/0/versions"
},
{
"value": "4.8.0-1",
"evidence": "/affected/0/versions"
},
{
"value": "4.8.0-1~bpo13+1",
"evidence": "/affected/0/versions"
},
{
"value": "4.8.0-2~exp1",
"evidence": "/affected/0/versions"
}
]
},
{
"name": {
"value": "gobgp",
"evidence": "/affected/1/package/name"
},
"prerequisites": [],
"fixed_versions": [],
"affected_versions": [
{
"value": "3.36.0-2",
"evidence": "/affected/1/versions"
},
{
"value": "4.3.0-1",
"evidence": "/affected/1/versions"
},
{
"value": "4.4.0-1",
"evidence": "/affected/1/versions"
},
{
"value": "4.5.0-1",
"evidence": "/affected/1/versions"
},
{
"value": "4.5.0-1~bpo13+1",
"evidence": "/affected/1/versions"
},
{
"value": "4.6.0-1",
"evidence": "/affected/1/versions"
},
{
"value": "4.6.0-2",
"evidence": "/affected/1/versions"
},
{
"value": "4.6.0-2~bpo13+1",
"evidence": "/affected/1/versions"
},
{
"value": "4.7.0-1",
"evidence": "/affected/1/versions"
},
{
"value": "4.7.0-1~bpo13+1",
"evidence": "/affected/1/versions"
},
{
"value": "4.8.0-1",
"evidence": "/affected/1/versions"
},
{
"value": "4.8.0-1~bpo13+1",
"evidence": "/affected/1/versions"
},
{
"value": "4.8.0-2~exp1",
"evidence": "/affected/1/versions"
}
]
},
{
"name": {
"value": "gobgp",
"evidence": "/affected/2/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "4.4.0-1",
"evidence": "/affected/2/ranges"
}
],
"affected_versions": [
{
"value": "3.36.0-2",
"evidence": "/affected/2/versions"
},
{
"value": "4.3.0-1",
"evidence": "/affected/2/versions"
}
]
}
],
"severity": "high",
"structured": {
"id": "DEBIAN-CVE-2026-7736",
"aliases": [
"DEBIAN-CVE-2026-7736"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H"
}
],
"affected": [
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
}
]
}
],
"package": {
"name": "gobgp",
"purl": "pkg:deb/debian/gobgp?arch=source&distro=bookworm",
"ecosystem": "Debian:12"
},
"versions": [
"3.10.0-1",
"3.16.0-1",
"3.19.0-1",
"3.21.0-1",
"3.23.0-1",
"3.25.0-1",
"3.27.0-1",
"3.28.0-1",
"3.29.0-1",
"3.30.0-1",
"3.31.0-1",
"3.32.0-1",
"3.33.0-1",
"3.35.0-1",
"3.36.0-1",
"3.36.0-2",
"4.3.0-1",
"4.4.0-1",
"4.5.0-1",
"4.5.0-1~bpo13+1",
"4.6.0-1",
"4.6.0-2",
"4.6.0-2~bpo13+1",
"4.7.0-1",
"4.7.0-1~bpo13+1",
"4.8.0-1",
"4.8.0-1~bpo13+1",
"4.8.0-2~exp1"
],
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2026-7736.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
}
]
}
],
"package": {
"name": "gobgp",
"purl": "pkg:deb/debian/gobgp?arch=source&distro=trixie",
"ecosystem": "Debian:13"
},
"versions": [
"3.36.0-2",
"4.3.0-1",
"4.4.0-1",
"4.5.0-1",
"4.5.0-1~bpo13+1",
"4.6.0-1",
"4.6.0-2",
"4.6.0-2~bpo13+1",
"4.7.0-1",
"4.7.0-1~bpo13+1",
"4.8.0-1",
"4.8.0-1~bpo13+1",
"4.8.0-2~exp1"
],
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2026-7736.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "4.4.0-1"
}
]
}
],
"package": {
"name": "gobgp",
"purl": "pkg:deb/debian/gobgp?arch=source&distro=forky",
"ecosystem": "Debian:14"
},
"versions": [
"3.36.0-2",
"4.3.0-1"
],
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2026-7736.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
}
],
"modified": "2026-10-27T10:02:16.154028093Z",
"provider": "osv",
"upstream": [
"CVE-2026-7736"
],
"references": [
"https://security-tracker.debian.org/tracker/CVE-2026-7736"
]
},
"related_cves": [
{
"value": "CVE-2026-7736",
"evidence": "/upstream"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 461430,
"published_at": "2026-05-04T07:16:01.517+00:00"
}