Indico may disclose unauthorized user details access via legacy API
Indico is an event management system that uses Flask-Multipass, a multi-backend authentication system for Flask. Prior to version 3.3.8, a legacy API to retrieve user details could be misused to retrieve profile details of other users without having admin permissions due to a broken access check. Users should to update to Indico 3.3.8 as soon as possible. As a workaround, it is possible to restrict access to the affected API (e.g. in the webserver config).
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2025-59034
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 2 Nov 2026, 23:50 UTC · Revision 1
Source evidence
Indico may disclose unauthorized user details access via legacy API
core-osv · Original sourcePublished 10 Sept 2025, 16:01 UTC
Indico is an event management system that uses Flask-Multipass, a multi-backend authentication system for Flask. Prior to version 3.3.8, a legacy API to retrieve user details could be misused to retrieve profile details of other users without having admin permissions due to a broken access check. Users should to update to Indico 3.3.8 as soon as possible. As a workaround, it is possible to restrict access to the affected API (e.g. in the webserver config).
osv:CVE-2025-59034
Complete source record
{
"id": "721a7abec951b7f58bc74d520e9e473ed80d78d18df385ea2b0b5e94a6beb0d1",
"url": "https://osv.dev/vulnerability/CVE-2025-59034",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "Indico may disclose unauthorized user details access via legacy API",
"summary": "Indico is an event management system that uses Flask-Multipass, a multi-backend authentication system for Flask. Prior to version 3.3.8, a legacy API to retrieve user details could be misused to retrieve profile details of other users without having admin permissions due to a broken access check. Users should to update to Indico 3.3.8 as soon as possible. As a workaround, it is possible to restrict access to the affected API (e.g. in the webserver config).",
"evidence": "osv:CVE-2025-59034",
"products": [],
"severity": "medium",
"structured": {
"id": "CVE-2025-59034",
"aliases": [
"CVE-2025-59034",
"GHSA-4269-mcfh-cp7q",
"PYSEC-2026-1460"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/indico/indico",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "12652ce3d8a9e0c52b81c49087f31e631ba645cb"
}
],
"database_specific": {
"extracted_events": [
{
"range": [
{
"introduced": "0"
},
{
"fixed": "3.3.8"
}
],
"source": "AFFECTED_FIELD",
"strategy": "StringRangeExpression"
},
{
"range": [
{
"fixed": "12652ce3d8a9e0c52b81c49087f31e631ba645cb"
}
],
"source": "REFERENCES_TAG",
"original_tag": "v3.3.8"
},
{
"cpe": "cpe:2.3:a:cern:indico:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "0"
},
{
"fixed": "3.3.8"
}
],
"source": "CPE_RANGE"
}
]
}
}
],
"versions": [
"v3.3.7",
"v3.3.6",
"v3.3.5",
"v3.3.4",
"v3.3.3",
"v3.3.2",
"v3.3.1",
"v3.3",
"v3.2.6+docs",
"v3.2.6",
"v3.2.5",
"v3.2.4",
"v3.2.3",
"v3.2.2",
"v3.2.1",
"v3.2",
"v3.0",
"v3.0rc2",
"v3.0rc1",
"v2.3.1",
"v2.3",
"v2.2",
"v2.1",
"v2.1rc6",
"v2.1rc5",
"v2.1rc4",
"v2.1rc3",
"v2.1rc2",
"v2.1rc1",
"v2.1b1",
"v2.1a3",
"v2.1a2",
"v2.1a1",
"v2.0rc1",
"v2.0a1",
"v1.9.11.dev9",
"v1.9.11.dev8",
"v1.9.11.dev7",
"v1.9.11.dev6",
"v1.9.11.dev3",
"v1.9.9",
"v0.97b2",
"v0.97b"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2025-59034.json"
}
}
],
"modified": "2026-10-28T02:30:24.282602527Z",
"provider": "osv",
"references": [
"https://github.com/indico/indico/releases/tag/v3.3.8",
"https://github.com/CVEProject/cvelistV5/tree/main/cves/2025/59xxx/CVE-2025-59034.json",
"https://github.com/indico/indico/security/advisories/GHSA-4269-mcfh-cp7q",
"https://nvd.nist.gov/vuln/detail/CVE-2025-59034"
],
"provider_metadata": {
"cwe_ids": [
"CWE-639"
],
"cna_assigner": "GitHub_M",
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2025/59xxx/CVE-2025-59034.json"
}
},
"related_cves": [
{
"value": "CVE-2025-59034",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 490989,
"published_at": "2025-09-10T16:01:09.96+00:00"
}