Formie has a XSS vulnerability for importing forms
Formie is a Craft CMS plugin for creating forms. Prior to 2.1.44, when importing a form from JSON, if the field label or handle contained malicious content, the output wasn't correctly escaped when viewing a preview of what was to be imported. As imports are undertaking primarily by users who have themselves exported the form from one environment to another, and would require direct manipulation of the JSON export, this is marked as moderate. This vulnerability will not occur unless someone deliberately tampers with the export. This vulnerability is fixed in 2.1.44.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2025-32427
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 3 Nov 2026, 02:33 UTC · Revision 1
Source evidence
Formie has a XSS vulnerability for importing forms
core-osv · Original sourcePublished 11 Apr 2025, 13:42 UTC
Formie is a Craft CMS plugin for creating forms. Prior to 2.1.44, when importing a form from JSON, if the field label or handle contained malicious content, the output wasn't correctly escaped when viewing a preview of what was to be imported. As imports are undertaking primarily by users who have themselves exported the form from one environment to another, and would require direct manipulation of the JSON export, this is marked as moderate. This vulnerability will not occur unless someone deliberately tampers with the export. This vulnerability is fixed in 2.1.44.
osv:CVE-2025-32427
Complete source record
{
"id": "7f2c8f6a361132aa46a20ee9535807575175ae943edf8d19e0e82054a64963d5",
"url": "https://osv.dev/vulnerability/CVE-2025-32427",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "Formie has a XSS vulnerability for importing forms",
"summary": "Formie is a Craft CMS plugin for creating forms. Prior to 2.1.44, when importing a form from JSON, if the field label or handle contained malicious content, the output wasn't correctly escaped when viewing a preview of what was to be imported. As imports are undertaking primarily by users who have themselves exported the form from one environment to another, and would require direct manipulation of the JSON export, this is marked as moderate. This vulnerability will not occur unless someone deliberately tampers with the export. This vulnerability is fixed in 2.1.44.",
"evidence": "osv:CVE-2025-32427",
"products": [],
"severity": "medium",
"structured": {
"id": "CVE-2025-32427",
"aliases": [
"CVE-2025-32427",
"GHSA-p9hh-mh5x-wvx3"
],
"metrics": [
{
"type": "CVSS_V4",
"score": "CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/verbb/formie",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "994bfaa22bfa5e3c0f0864bbb8d0b4c6eb2686a8"
}
],
"database_specific": {
"extracted_events": [
{
"range": [
{
"introduced": "0"
},
{
"fixed": "2.1.44"
}
],
"source": "AFFECTED_FIELD",
"strategy": "StringRangeExpression"
},
{
"cpe": "cpe:2.3:a:verbb:formie:*:*:*:*:*:craft_cms:*:*",
"range": [
{
"introduced": "0"
},
{
"fixed": "2.1.44"
}
],
"source": "CPE_RANGE"
}
]
}
}
],
"versions": [
"2.1.43",
"2.1.42",
"2.1.41",
"2.1.40",
"2.1.39",
"2.1.38",
"2.1.37",
"2.1.36",
"2.1.35",
"2.1.34",
"2.1.33",
"2.1.32",
"2.1.31",
"2.1.30",
"2.1.29",
"2.1.28",
"2.1.27",
"2.1.26",
"2.1.25",
"2.1.24",
"2.1.23",
"2.1.22",
"2.1.21",
"2.1.20",
"2.1.19",
"2.1.18",
"2.1.17",
"2.1.16",
"2.1.15",
"2.1.14",
"2.1.13",
"2.1.12",
"2.1.11",
"2.1.10",
"2.1.9",
"2.1.8",
"2.1.7",
"2.1.6",
"2.1.5",
"2.1.4",
"2.1.3",
"2.1.2",
"2.1.1",
"2.1.0",
"2.0.44.1",
"2.0.44",
"2.0.43",
"2.0.42",
"2.0.41",
"2.0.40",
"2.0.39",
"2.0.38",
"2.0.37",
"2.0.36",
"2.0.35",
"2.0.34.1",
"2.0.34",
"2.0.33",
"2.0.32",
"2.0.31",
"2.0.30",
"2.0.29",
"2.0.28",
"2.0.27.1",
"2.0.27",
"2.0.26",
"2.0.25.1",
"2.0.25",
"2.0.24",
"2.0.23.1",
"2.0.23",
"2.0.22",
"2.0.21",
"2.0.20",
"2.0.19",
"2.0.17",
"2.0.16",
"2.0.15",
"2.0.14",
"2.0.13",
"2.0.12",
"2.0.11",
"2.0.10",
"2.0.9",
"2.0.8",
"2.0.7",
"2.0.6",
"2.0.5",
"2.0.4",
"2.0.3",
"2.0.2",
"2.0.1",
"2.0.0",
"2.0.0-beta.16",
"2.0.0-beta.15",
"2.0.0-beta.14",
"2.0.0-beta.13",
"2.0.0-beta.9",
"2.0.0-beta.8",
"2.0.0-beta.6",
"2.0.0-beta.5",
"2.0.0-beta.4",
"2.0.0-beta.3",
"2.0.0-beta.2",
"2.0.0-beta.1",
"1.5.10",
"1.5.9",
"1.5.8",
"1.5.7",
"1.5.6",
"1.5.5",
"1.5.4",
"1.5.3",
"1.5.2",
"1.5.1",
"1.5.0",
"1.4.22",
"1.4.21.1",
"1.4.21",
"1.4.20",
"1.4.19",
"1.4.18",
"1.4.17",
"1.4.16",
"1.4.15",
"1.4.14",
"1.4.13",
"1.4.12",
"1.4.11",
"1.4.10",
"1.4.9",
"1.4.8",
"1.4.7",
"1.4.6",
"1.4.5",
"1.4.4",
"1.4.3",
"1.4.2",
"1.4.1",
"1.4.0.1",
"1.4.0",
"1.2.25",
"1.2.24",
"1.2.23.1",
"1.2.23",
"1.2.22",
"1.2.21",
"1.2.20",
"1.2.19",
"1.2.18",
"1.2.17",
"1.2.16",
"1.2.15",
"1.2.14",
"1.2.13",
"1.2.12",
"1.2.11",
"1.2.10",
"1.2.9",
"1.2.8",
"1.2.7.1",
"1.2.7",
"1.2.6",
"1.2.5",
"1.2.4",
"1.2.3",
"1.2.2",
"1.2.1",
"1.2.0",
"1.1.1.1",
"1.1.1",
"1.1.0",
"1.0.9.1",
"1.0.9",
"1.0.8",
"1.0.7",
"1.0.6",
"1.0.5",
"1.0.4",
"1.0.2",
"1.0.1"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2025-32427.json"
}
}
],
"modified": "2026-10-28T02:30:25.365097627Z",
"provider": "osv",
"references": [
"https://github.com/CVEProject/cvelistV5/tree/main/cves/2025/32xxx/CVE-2025-32427.json",
"https://github.com/verbb/formie/security/advisories/GHSA-p9hh-mh5x-wvx3",
"https://nvd.nist.gov/vuln/detail/CVE-2025-32427"
],
"provider_metadata": {
"cwe_ids": [
"CWE-79"
],
"cna_assigner": "GitHub_M",
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2025/32xxx/CVE-2025-32427.json"
}
},
"related_cves": [
{
"value": "CVE-2025-32427",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 491913,
"published_at": "2025-04-11T13:42:13.854+00:00"
}