apprise — security advisory
Apprise is an open source library which allows you to send a notification to almost all of the most popular notification services available. Prior to 1.11.0, Apprise HTTP-based notification plugins and HTTP attachment and config loaders in apprise/attachment/http.py and apprise/config/http.py follow HTTP redirects by default and resend user-configured auth headers and query parameters on the redirected request, allowing a compromised trusted destination or on-path attacker to receive secrets such as Authorization headers, bearer tokens, custom headers, and service keys. This issue is fixed in version 1.11.0.
- Products
- apprise
- Affected versions
- 1.10.0-1, 1.11.0-1, 1.13.0-1, 1.2.0-1, 1.4.0-1, 1.4.0-2, 1.4.5-1, 1.5.0-1, 1.6.0-1, 1.7.1-1, 1.7.2-1, 1.7.4-1, 1.7.5-1, 1.7.6-1, 1.8.0-1, 1.8.0-1~bpo11+1, 1.8.0-2, 1.8.0-3, 1.8.1-1, 1.9.0-1, 1.9.1-1, 1.9.2-1, 1.9.3-1, 1.9.9-1, 2.0.0-1
- Fixed versions
- 1.11.0-1
- CVEs
- CVE-2026-59180
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 1 Nov 2026, 12:17 UTC · Revision 2
Source evidence
Apprise is an open source library which allows you to send a notification to almost all of the most popular notification services available. Prior to 1.11.0, Apprise HTTP-based notification plugins and HTTP attachment and config loaders in apprise/attachment/http.py and apprise/config/http.py follow HTTP redirects by default and resend user-configured auth headers and query parameters on the redirected request, allowing a compromised trusted destination or on-path attacker to receive secrets such as Authorization headers, bearer tokens, custom headers, and service keys. This issue is fixed in version 1.11.0.
osv:DEBIAN-CVE-2026-59180
apprise
Fixed versions: Not specified
apprise
Fixed versions: Not specified
apprise
Fixed versions: 1.11.0-1
Complete source record
{
"id": "f9bb13fd4cccc48fb010103a76933a7a78aa6101f7c764361c44c268089d9ae8",
"url": "https://osv.dev/vulnerability/DEBIAN-CVE-2026-59180",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "DEBIAN-CVE-2026-59180",
"summary": "Apprise is an open source library which allows you to send a notification to almost all of the most popular notification services available. Prior to 1.11.0, Apprise HTTP-based notification plugins and HTTP attachment and config loaders in apprise/attachment/http.py and apprise/config/http.py follow HTTP redirects by default and resend user-configured auth headers and query parameters on the redirected request, allowing a compromised trusted destination or on-path attacker to receive secrets such as Authorization headers, bearer tokens, custom headers, and service keys. This issue is fixed in version 1.11.0.",
"evidence": "osv:DEBIAN-CVE-2026-59180",
"products": [
{
"name": {
"value": "apprise",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [],
"affected_versions": [
{
"value": "1.10.0-1",
"evidence": "/affected/0/versions"
},
{
"value": "1.11.0-1",
"evidence": "/affected/0/versions"
},
{
"value": "1.13.0-1",
"evidence": "/affected/0/versions"
},
{
"value": "1.2.0-1",
"evidence": "/affected/0/versions"
},
{
"value": "1.4.0-1",
"evidence": "/affected/0/versions"
},
{
"value": "1.4.0-2",
"evidence": "/affected/0/versions"
},
{
"value": "1.4.5-1",
"evidence": "/affected/0/versions"
},
{
"value": "1.5.0-1",
"evidence": "/affected/0/versions"
},
{
"value": "1.6.0-1",
"evidence": "/affected/0/versions"
},
{
"value": "1.7.1-1",
"evidence": "/affected/0/versions"
},
{
"value": "1.7.2-1",
"evidence": "/affected/0/versions"
},
{
"value": "1.7.4-1",
"evidence": "/affected/0/versions"
},
{
"value": "1.7.5-1",
"evidence": "/affected/0/versions"
},
{
"value": "1.7.6-1",
"evidence": "/affected/0/versions"
},
{
"value": "1.8.0-1",
"evidence": "/affected/0/versions"
},
{
"value": "1.8.0-1~bpo11+1",
"evidence": "/affected/0/versions"
},
{
"value": "1.8.0-2",
"evidence": "/affected/0/versions"
},
{
"value": "1.8.0-3",
"evidence": "/affected/0/versions"
},
{
"value": "1.8.1-1",
"evidence": "/affected/0/versions"
},
{
"value": "1.9.0-1",
"evidence": "/affected/0/versions"
},
{
"value": "1.9.1-1",
"evidence": "/affected/0/versions"
},
{
"value": "1.9.2-1",
"evidence": "/affected/0/versions"
},
{
"value": "1.9.3-1",
"evidence": "/affected/0/versions"
},
{
"value": "1.9.9-1",
"evidence": "/affected/0/versions"
},
{
"value": "2.0.0-1",
"evidence": "/affected/0/versions"
}
]
},
{
"name": {
"value": "apprise",
"evidence": "/affected/1/package/name"
},
"prerequisites": [],
"fixed_versions": [],
"affected_versions": [
{
"value": "1.10.0-1",
"evidence": "/affected/1/versions"
},
{
"value": "1.11.0-1",
"evidence": "/affected/1/versions"
},
{
"value": "1.13.0-1",
"evidence": "/affected/1/versions"
},
{
"value": "1.9.3-1",
"evidence": "/affected/1/versions"
},
{
"value": "1.9.9-1",
"evidence": "/affected/1/versions"
},
{
"value": "2.0.0-1",
"evidence": "/affected/1/versions"
}
]
},
{
"name": {
"value": "apprise",
"evidence": "/affected/2/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "1.11.0-1",
"evidence": "/affected/2/ranges"
}
],
"affected_versions": [
{
"value": "1.10.0-1",
"evidence": "/affected/2/versions"
},
{
"value": "1.9.3-1",
"evidence": "/affected/2/versions"
},
{
"value": "1.9.9-1",
"evidence": "/affected/2/versions"
}
]
}
],
"severity": "low",
"structured": {
"id": "DEBIAN-CVE-2026-59180",
"aliases": [
"DEBIAN-CVE-2026-59180"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:L/I:N/A:N"
}
],
"affected": [
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
}
]
}
],
"package": {
"name": "apprise",
"purl": "pkg:deb/debian/apprise?arch=source&distro=bookworm",
"ecosystem": "Debian:12"
},
"versions": [
"1.10.0-1",
"1.11.0-1",
"1.13.0-1",
"1.2.0-1",
"1.4.0-1",
"1.4.0-2",
"1.4.5-1",
"1.5.0-1",
"1.6.0-1",
"1.7.1-1",
"1.7.2-1",
"1.7.4-1",
"1.7.5-1",
"1.7.6-1",
"1.8.0-1",
"1.8.0-1~bpo11+1",
"1.8.0-2",
"1.8.0-3",
"1.8.1-1",
"1.9.0-1",
"1.9.1-1",
"1.9.2-1",
"1.9.3-1",
"1.9.9-1",
"2.0.0-1"
],
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2026-59180.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
}
]
}
],
"package": {
"name": "apprise",
"purl": "pkg:deb/debian/apprise?arch=source&distro=trixie",
"ecosystem": "Debian:13"
},
"versions": [
"1.10.0-1",
"1.11.0-1",
"1.13.0-1",
"1.9.3-1",
"1.9.9-1",
"2.0.0-1"
],
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2026-59180.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "1.11.0-1"
}
]
}
],
"package": {
"name": "apprise",
"purl": "pkg:deb/debian/apprise?arch=source&distro=forky",
"ecosystem": "Debian:14"
},
"versions": [
"1.10.0-1",
"1.9.3-1",
"1.9.9-1"
],
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2026-59180.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
}
],
"modified": "2026-10-26T11:47:28.236029258Z",
"provider": "osv",
"upstream": [
"CVE-2026-59180"
],
"references": [
"https://security-tracker.debian.org/tracker/CVE-2026-59180"
]
},
"related_cves": [
{
"value": "CVE-2026-59180",
"evidence": "/upstream"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 450775,
"published_at": "2026-07-10T17:17:02.503+00:00"
}