Skip to content
Heist/ feed
Back to feed
Critical

passport-wsfed-saml2 Has SAML Authentication Bypass via Signature Wrapping

Type: advisorySources: OSV

passport-wsfed-saml2 provides passport strategy for both WS-fed and SAML2 protocol. A vulnerability present starting in version 3.0.5 up to and including version 4.6.3 allows an attacker to impersonate any user during SAML authentication by crafting a SAMLResponse. This can be done by using a valid SAML object that was signed by the configured IdP. Users are affected specifically when the service provider is using passport-wsfed-saml2 and a valid SAML document signed by the Identity Provider can be obtained. Version 4.6.4 contains a fix for the vulnerability.

Products
Not specified
Affected versions
Not specified
Fixed versions
Not specified
CVEs
CVE-2025-46572
Confirmed fixed CVEs
Not specified
Updated in this feed
7 Nov 2026, 03:52 UTC · Revision 1

Source evidence

passport-wsfed-saml2 Has SAML Authentication Bypass via Signature Wrapping

core-osv · Original source

Published 6 May 2025, 20:18 UTC

passport-wsfed-saml2 provides passport strategy for both WS-fed and SAML2 protocol. A vulnerability present starting in version 3.0.5 up to and including version 4.6.3 allows an attacker to impersonate any user during SAML authentication by crafting a SAMLResponse. This can be done by using a valid SAML object that was signed by the configured IdP. Users are affected specifically when the service provider is using passport-wsfed-saml2 and a valid SAML document signed by the Identity Provider can be obtained. Version 4.6.4 contains a fix for the vulnerability.

osv:CVE-2025-46572
Complete source record
{
  "id": "78246e97becadb75c743caa73b598b62a42913228910a14d914273b369b95d8e",
  "url": "https://osv.dev/vulnerability/CVE-2025-46572",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "passport-wsfed-saml2 Has SAML Authentication Bypass via Signature Wrapping",
    "summary": "passport-wsfed-saml2 provides passport strategy for both WS-fed and SAML2 protocol. A vulnerability present starting in version 3.0.5 up to and including version 4.6.3 allows an attacker to impersonate any user during SAML authentication by crafting a SAMLResponse. This can be done by using a valid SAML object that was signed by the configured IdP. Users are affected specifically when the service provider is using passport-wsfed-saml2 and a valid SAML document signed by the Identity Provider can be obtained. Version 4.6.4 contains a fix for the vulnerability.",
    "evidence": "osv:CVE-2025-46572",
    "products": [],
    "severity": "critical",
    "structured": {
      "id": "CVE-2025-46572",
      "aliases": [
        "CVE-2025-46572",
        "GHSA-wjmp-wphq-jvqf"
      ],
      "metrics": [
        {
          "type": "CVSS_V4",
          "score": "CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N"
        }
      ],
      "affected": [
        {
          "ranges": [
            {
              "repo": "https://github.com/auth0/passport-wsfed-saml2",
              "type": "GIT",
              "events": [
                {
                  "introduced": "cc8d85e2dba45218e6d6afed9948c577f3669503"
                },
                {
                  "fixed": "e5cf3cc2a53748207f7a81bfba9195c8efa94181"
                }
              ],
              "database_specific": {
                "extracted_events": [
                  {
                    "range": [
                      {
                        "introduced": "3.0.5"
                      },
                      {
                        "fixed": "4.6.4"
                      }
                    ],
                    "source": "AFFECTED_FIELD",
                    "strategy": "StringRangeExpression"
                  },
                  {
                    "range": [
                      {
                        "fixed": "e5cf3cc2a53748207f7a81bfba9195c8efa94181"
                      }
                    ],
                    "source": "REFERENCES_COMMIT"
                  }
                ]
              }
            }
          ],
          "versions": [
            "v4.5.1",
            "v4.5.0",
            "v4.4.0",
            "v4.3.0",
            "v4.2.0",
            "v4.0.0",
            "v3.0.12",
            "v3.0.11",
            "v3.0.10",
            "v3.0.9",
            "v3.0.8",
            "v3.0.7",
            "v3.0.6",
            "v3.0.5"
          ],
          "database_specific": {
            "source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2025-46572.json"
          }
        }
      ],
      "modified": "2026-10-28T02:30:49.670301512Z",
      "provider": "osv",
      "references": [
        "https://github.com/CVEProject/cvelistV5/tree/main/cves/2025/46xxx/CVE-2025-46572.json",
        "https://github.com/auth0/passport-wsfed-saml2/security/advisories/GHSA-wjmp-wphq-jvqf",
        "https://nvd.nist.gov/vuln/detail/CVE-2025-46572",
        "https://github.com/auth0/passport-wsfed-saml2/commit/e5cf3cc2a53748207f7a81bfba9195c8efa94181"
      ],
      "provider_metadata": {
        "cwe_ids": [
          "CWE-287"
        ],
        "cna_assigner": "GitHub_M",
        "osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2025/46xxx/CVE-2025-46572.json"
      }
    },
    "related_cves": [
      {
        "value": "CVE-2025-46572",
        "evidence": "/id"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/severity/0/score"
  },
  "source_id": "core-osv",
  "document_id": 517907,
  "published_at": "2025-05-06T20:18:26.379+00:00"
}