php8.2, php8.4 — security advisory
In PHP versions 8.1.* before 8.1.34, 8.2.* before 8.2.30, 8.3.* before 8.3.29, 8.4.* before 8.4.16, 8.5.* before 8.5.1 when using the PDO PostgreSQL driver with PDO::ATTR_EMULATE_PREPARES enabled, an invalid character sequence (such as \x99) in a prepared statement parameter may cause the quoting function PQescapeStringConn to return NULL, leading to a null pointer dereference in pdo_parse_params() function. This may lead to crashes (segmentation fault) and affect the availability of the target server.
- Products
- php8.2, php8.4
- Affected versions
- 8.2.10-1, 8.2.10-2, 8.2.12-1, 8.2.16-1, 8.2.16-2, 8.2.17-1, 8.2.18-1, 8.2.18-1~deb12u1, 8.2.20-1~deb12u1, 8.2.20-2, 8.2.20-3, 8.2.21-1, 8.2.23-1, 8.2.24-1, 8.2.24-1~deb12u1, 8.2.26-1~deb12u1, 8.2.26-4, 8.2.27-1, 8.2.28-1~deb12u1, 8.2.29-1~deb12u1, 8.2.5-2, 8.2.7-1, 8.2.7-1.1, 8.2.7-1.2, 8.2.7-1~deb12u1, 8.4.11-1, 8.4.16-1~deb13u1
- Fixed versions
- 8.2.30-1~deb12u1, 8.4.16-1, 8.4.16-1~deb13u1
- CVEs
- CVE-2025-14180
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 30 Oct 2026, 11:48 UTC · Revision 1
Source evidence
In PHP versions 8.1.* before 8.1.34, 8.2.* before 8.2.30, 8.3.* before 8.3.29, 8.4.* before 8.4.16, 8.5.* before 8.5.1 when using the PDO PostgreSQL driver with PDO::ATTR_EMULATE_PREPARES enabled, an invalid character sequence (such as \x99) in a prepared statement parameter may cause the quoting function PQescapeStringConn to return NULL, leading to a null pointer dereference in pdo_parse_params() function. This may lead to crashes (segmentation fault) and affect the availability of the target server.
osv:DEBIAN-CVE-2025-14180
php8.2
Fixed versions: 8.2.30-1~deb12u1
php8.4
Fixed versions: 8.4.16-1~deb13u1
php8.4
Fixed versions: 8.4.16-1
Complete source record
{
"id": "9a43478c542d266a01c88a27f3acb8e3347139d9c00e788bbceec8e8d67c191d",
"url": "https://osv.dev/vulnerability/DEBIAN-CVE-2025-14180",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "DEBIAN-CVE-2025-14180",
"summary": "In PHP versions 8.1.* before 8.1.34, 8.2.* before 8.2.30, 8.3.* before 8.3.29, 8.4.* before 8.4.16, 8.5.* before 8.5.1 when using the PDO PostgreSQL driver with PDO::ATTR_EMULATE_PREPARES enabled, an invalid character sequence (such as \\x99) in a prepared statement parameter may cause the quoting function PQescapeStringConn to return NULL, leading to a null pointer dereference in pdo_parse_params() function. This may lead to crashes (segmentation fault) and affect the availability of the target server.",
"evidence": "osv:DEBIAN-CVE-2025-14180",
"products": [
{
"name": {
"value": "php8.2",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "8.2.30-1~deb12u1",
"evidence": "/affected/0/ranges"
}
],
"affected_versions": [
{
"value": "8.2.10-1",
"evidence": "/affected/0/versions"
},
{
"value": "8.2.10-2",
"evidence": "/affected/0/versions"
},
{
"value": "8.2.12-1",
"evidence": "/affected/0/versions"
},
{
"value": "8.2.16-1",
"evidence": "/affected/0/versions"
},
{
"value": "8.2.16-2",
"evidence": "/affected/0/versions"
},
{
"value": "8.2.17-1",
"evidence": "/affected/0/versions"
},
{
"value": "8.2.18-1",
"evidence": "/affected/0/versions"
},
{
"value": "8.2.18-1~deb12u1",
"evidence": "/affected/0/versions"
},
{
"value": "8.2.20-1~deb12u1",
"evidence": "/affected/0/versions"
},
{
"value": "8.2.20-2",
"evidence": "/affected/0/versions"
},
{
"value": "8.2.20-3",
"evidence": "/affected/0/versions"
},
{
"value": "8.2.21-1",
"evidence": "/affected/0/versions"
},
{
"value": "8.2.23-1",
"evidence": "/affected/0/versions"
},
{
"value": "8.2.24-1",
"evidence": "/affected/0/versions"
},
{
"value": "8.2.24-1~deb12u1",
"evidence": "/affected/0/versions"
},
{
"value": "8.2.26-1~deb12u1",
"evidence": "/affected/0/versions"
},
{
"value": "8.2.26-4",
"evidence": "/affected/0/versions"
},
{
"value": "8.2.27-1",
"evidence": "/affected/0/versions"
},
{
"value": "8.2.28-1~deb12u1",
"evidence": "/affected/0/versions"
},
{
"value": "8.2.29-1~deb12u1",
"evidence": "/affected/0/versions"
},
{
"value": "8.2.5-2",
"evidence": "/affected/0/versions"
},
{
"value": "8.2.7-1",
"evidence": "/affected/0/versions"
},
{
"value": "8.2.7-1.1",
"evidence": "/affected/0/versions"
},
{
"value": "8.2.7-1.2",
"evidence": "/affected/0/versions"
},
{
"value": "8.2.7-1~deb12u1",
"evidence": "/affected/0/versions"
}
]
},
{
"name": {
"value": "php8.4",
"evidence": "/affected/1/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "8.4.16-1~deb13u1",
"evidence": "/affected/1/ranges"
}
],
"affected_versions": [
{
"value": "8.4.11-1",
"evidence": "/affected/1/versions"
}
]
},
{
"name": {
"value": "php8.4",
"evidence": "/affected/2/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "8.4.16-1",
"evidence": "/affected/2/ranges"
}
],
"affected_versions": [
{
"value": "8.4.11-1",
"evidence": "/affected/2/versions"
},
{
"value": "8.4.16-1~deb13u1",
"evidence": "/affected/2/versions"
}
]
}
],
"severity": "high",
"structured": {
"id": "DEBIAN-CVE-2025-14180",
"aliases": [
"DEBIAN-CVE-2025-14180"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H"
}
],
"affected": [
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "8.2.30-1~deb12u1"
}
]
}
],
"package": {
"name": "php8.2",
"purl": "pkg:deb/debian/php8.2?arch=source&distro=bookworm",
"ecosystem": "Debian:12"
},
"versions": [
"8.2.10-1",
"8.2.10-2",
"8.2.12-1",
"8.2.16-1",
"8.2.16-2",
"8.2.17-1",
"8.2.18-1",
"8.2.18-1~deb12u1",
"8.2.20-1~deb12u1",
"8.2.20-2",
"8.2.20-3",
"8.2.21-1",
"8.2.23-1",
"8.2.24-1",
"8.2.24-1~deb12u1",
"8.2.26-1~deb12u1",
"8.2.26-4",
"8.2.27-1",
"8.2.28-1~deb12u1",
"8.2.29-1~deb12u1",
"8.2.5-2",
"8.2.7-1",
"8.2.7-1.1",
"8.2.7-1.2",
"8.2.7-1~deb12u1"
],
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2025-14180.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "8.4.16-1~deb13u1"
}
]
}
],
"package": {
"name": "php8.4",
"purl": "pkg:deb/debian/php8.4?arch=source&distro=trixie",
"ecosystem": "Debian:13"
},
"versions": [
"8.4.11-1"
],
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2025-14180.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "8.4.16-1"
}
]
}
],
"package": {
"name": "php8.4",
"purl": "pkg:deb/debian/php8.4?arch=source&distro=forky",
"ecosystem": "Debian:14"
},
"versions": [
"8.4.11-1",
"8.4.16-1~deb13u1"
],
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2025-14180.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
}
],
"modified": "2026-10-14T09:47:31.281301519Z",
"provider": "osv",
"upstream": [
"CVE-2025-14180"
],
"references": [
"https://security-tracker.debian.org/tracker/CVE-2025-14180"
]
},
"related_cves": [
{
"value": "CVE-2025-14180",
"evidence": "/upstream"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 315343,
"published_at": "2025-12-27T20:15:40.717+00:00"
}