libvirt — security advisory
A double free memory issue was found to occur in the libvirt API, in versions before 6.8.0, responsible for requesting information about network interfaces of a running QEMU domain. This flaw affects the polkit access control driver. Specifically, clients connecting to the read-write socket with limited ACL permissions could use this flaw to crash the libvirt daemon, resulting in a denial of service, or potentially escalate their privileges on the system. The highest threat from this vulnerability is to data confidentiality and integrity as well as system availability.
- Products
- libvirt
- Affected versions
- Not specified
- Fixed versions
- 6.6.0-r3
- CVEs
- CVE-2020-25637
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 1 Nov 2026, 12:08 UTC · Revision 1
Source evidence
A double free memory issue was found to occur in the libvirt API, in versions before 6.8.0, responsible for requesting information about network interfaces of a running QEMU domain. This flaw affects the polkit access control driver. Specifically, clients connecting to the read-write socket with limited ACL permissions could use this flaw to crash the libvirt daemon, resulting in a denial of service, or potentially escalate their privileges on the system. The highest threat from this vulnerability is to data confidentiality and integrity as well as system availability.
osv:ALPINE-CVE-2020-25637
libvirt
Fixed versions: 6.6.0-r3
Complete source record
{
"id": "07f593bb4a2de065adee056fb6ec56723248848bbcc7b8893b267f31fb82eaf3",
"url": "https://osv.dev/vulnerability/ALPINE-CVE-2020-25637",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "ALPINE-CVE-2020-25637",
"summary": "A double free memory issue was found to occur in the libvirt API, in versions before 6.8.0, responsible for requesting information about network interfaces of a running QEMU domain. This flaw affects the polkit access control driver. Specifically, clients connecting to the read-write socket with limited ACL permissions could use this flaw to crash the libvirt daemon, resulting in a denial of service, or potentially escalate their privileges on the system. The highest threat from this vulnerability is to data confidentiality and integrity as well as system availability.",
"evidence": "osv:ALPINE-CVE-2020-25637",
"products": [
{
"name": {
"value": "libvirt",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "6.6.0-r3",
"evidence": "/affected/0/ranges"
}
],
"affected_versions": []
}
],
"severity": "medium",
"structured": {
"id": "ALPINE-CVE-2020-25637",
"aliases": [
"ALPINE-CVE-2020-25637"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:L/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H"
}
],
"affected": [
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "6.6.0-r3"
}
]
}
],
"package": {
"name": "libvirt",
"purl": "pkg:apk/alpine/libvirt?arch=source",
"ecosystem": "Alpine:v3.12"
},
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/alpine/ALPINE-CVE-2020-25637.json"
},
"ecosystem_specific": {}
}
],
"modified": "2026-10-26T11:17:55.154384818Z",
"provider": "osv",
"upstream": [
"CVE-2020-25637"
],
"references": [
"https://security.alpinelinux.org/vuln/CVE-2020-25637"
]
},
"related_cves": [
{
"value": "CVE-2020-25637",
"evidence": "/upstream"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 450542,
"published_at": "2020-10-06T14:15:12.527+00:00"
}