Unrated
Image optimization & Lazy Load < 3.3.2 - Admin+ Stored Cross-Site Scripting
Type: advisorySources: OSV
The Image optimization & Lazy Load by Optimole WordPress plugin before 3.3.2 does not sanitise and escape its "Lazyload background images for selectors" settings, which could allow high privilege users such as admin to perform Cross-Site scripting attacks even when the unfiltered_html capability is disallowed.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2022-0969
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 4 Nov 2026, 16:40 UTC · Revision 1
Source evidence
Image optimization & Lazy Load < 3.3.2 - Admin+ Stored Cross-Site Scripting
core-osv · Original sourcePublished 11 Apr 2022, 14:41 UTC
The Image optimization & Lazy Load by Optimole WordPress plugin before 3.3.2 does not sanitise and escape its "Lazyload background images for selectors" settings, which could allow high privilege users such as admin to perform Cross-Site scripting attacks even when the unfiltered_html capability is disallowed.
osv:CVE-2022-0969
Complete source record
{
"id": "1b3230da1053f3f335f1d1f531d2e9fed5b80eb27002c0dac0824b6e75af4999",
"url": "https://osv.dev/vulnerability/CVE-2022-0969",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "Image optimization & Lazy Load < 3.3.2 - Admin+ Stored Cross-Site Scripting",
"summary": "The Image optimization & Lazy Load by Optimole WordPress plugin before 3.3.2 does not sanitise and escape its \"Lazyload background images for selectors\" settings, which could allow high privilege users such as admin to perform Cross-Site scripting attacks even when the unfiltered_html capability is disallowed.",
"evidence": "osv:CVE-2022-0969",
"products": [],
"severity": "unknown",
"structured": {
"id": "CVE-2022-0969",
"aliases": [
"CVE-2022-0969"
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/codeinwp/optimole-wp",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "2cd3accae6bc53365a42a81f594a024f799162cf"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:vertistudio:image_optimization_\\&_lazy_load_by_optimole:*:*:*:*:*:wordpress:*:*",
"range": [
{
"introduced": "0"
},
{
"fixed": "3.3.2"
}
],
"source": "CPE_RANGE"
}
]
}
}
],
"versions": [
"v3.3.1",
"v3.3.0",
"v3.2.1",
"v3.2.0",
"v3.1.3",
"v3.1.2",
"v3.1.1",
"v3.1.0",
"v3.0.1",
"v3.0.0",
"v2.5.7",
"v2.5.6",
"v2.5.5",
"v2.5.4",
"v2.5.3",
"v2.5.2",
"v2.5.1",
"v2.5.0",
"v2.4.2",
"v2.4.1",
"v2.4.0",
"v2.3.1",
"v2.3.0",
"v2.2.9",
"v2.2.8",
"v2.2.6",
"v2.2.7",
"v2.2.5",
"v2.2.4",
"v2.2.3",
"v2.2.2",
"v2.2.1",
"v2.2.0",
"v2.1.2",
"v2.1.1",
"v2.1.0",
"v2.0.7",
"v2.0.6",
"v2.0.5",
"v2.0.4",
"v2.0.3",
"v2.0.2",
"v2.0.1",
"v2.0.0",
"v1.1.2",
"v1.1.1",
"v1.1.0",
"v1.0.5",
"v1.0.4",
"v1.0.3",
"v1.0.0"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2022-0969.json"
}
}
],
"modified": "2026-10-28T02:30:37.306169754Z",
"provider": "osv",
"references": [
"https://plugins.trac.wordpress.org/changeset/2695242",
"https://wpscan.com/vulnerability/59a7a441-7384-4006-89b4-15345f70fabf",
"https://github.com/CVEProject/cvelistV5/tree/main/cves/2022/0xxx/CVE-2022-0969.json",
"https://nvd.nist.gov/vuln/detail/CVE-2022-0969"
],
"provider_metadata": {
"cwe_ids": [
"CWE-79"
],
"cna_assigner": "WPScan",
"unresolved_ranges": [
{
"extracted_events": [
{
"range": [
{
"introduced": "3.3.2"
},
{
"last_affected": "3.3.2"
}
],
"source": "AFFECTED_FIELD",
"strategy": "StandaloneSingleVersion"
}
]
}
],
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2022/0xxx/CVE-2022-0969.json"
}
},
"related_cves": [
{
"value": "CVE-2022-0969",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": null
},
"source_id": "core-osv",
"document_id": 504834,
"published_at": "2022-04-11T14:41:01+00:00"
}