Skip to content
Heist/ feed
Back to feed
HighFix available

sqlite3 — security advisory

Type: advisorySources: OSVAdvisory ID: DEBIAN-CVE-2025-29087

In SQLite 3.44.0 through 3.49.0 before 3.49.1, the concat_ws() SQL function can cause memory to be written beyond the end of a malloc-allocated buffer. If the separator argument is attacker-controlled and has a large string (e.g., 2MB or more), an integer overflow occurs in calculating the size of the result buffer, and thus malloc may not allocate enough memory.

Products
sqlite3
Affected versions
Not specified
Fixed versions
3.46.1-3
CVEs
CVE-2025-29087
Confirmed fixed CVEs
Not specified
Updated in this feed
30 Oct 2026, 16:53 UTC · Revision 1

Source evidence

DEBIAN-CVE-2025-29087

core-osv · Original source

Published 7 Apr 2025, 20:15 UTC

In SQLite 3.44.0 through 3.49.0 before 3.49.1, the concat_ws() SQL function can cause memory to be written beyond the end of a malloc-allocated buffer. If the separator argument is attacker-controlled and has a large string (e.g., 2MB or more), an integer overflow occurs in calculating the size of the result buffer, and thus malloc may not allocate enough memory.

osv:DEBIAN-CVE-2025-29087

sqlite3

Fixed versions: 3.46.1-3

sqlite3

Fixed versions: 3.46.1-3

Complete source record
{
  "id": "5d1cb0211790835f1bcb8c0b976c0555090a7b3b915bd209c900e376417386bd",
  "url": "https://osv.dev/vulnerability/DEBIAN-CVE-2025-29087",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "DEBIAN-CVE-2025-29087",
    "summary": "In SQLite 3.44.0 through 3.49.0 before 3.49.1, the concat_ws() SQL function can cause memory to be written beyond the end of a malloc-allocated buffer. If the separator argument is attacker-controlled and has a large string (e.g., 2MB or more), an integer overflow occurs in calculating the size of the result buffer, and thus malloc may not allocate enough memory.",
    "evidence": "osv:DEBIAN-CVE-2025-29087",
    "products": [
      {
        "name": {
          "value": "sqlite3",
          "evidence": "/affected/0/package/name"
        },
        "prerequisites": [],
        "fixed_versions": [
          {
            "value": "3.46.1-3",
            "evidence": "/affected/0/ranges"
          }
        ],
        "affected_versions": []
      },
      {
        "name": {
          "value": "sqlite3",
          "evidence": "/affected/1/package/name"
        },
        "prerequisites": [],
        "fixed_versions": [
          {
            "value": "3.46.1-3",
            "evidence": "/affected/1/ranges"
          }
        ],
        "affected_versions": []
      }
    ],
    "severity": "high",
    "structured": {
      "id": "DEBIAN-CVE-2025-29087",
      "aliases": [
        "DEBIAN-CVE-2025-29087"
      ],
      "metrics": [
        {
          "type": "CVSS_V3",
          "score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H"
        }
      ],
      "affected": [
        {
          "ranges": [
            {
              "type": "ECOSYSTEM",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "3.46.1-3"
                }
              ]
            }
          ],
          "package": {
            "name": "sqlite3",
            "purl": "pkg:deb/debian/sqlite3?arch=source&distro=trixie",
            "ecosystem": "Debian:13"
          },
          "database_specific": {
            "source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2025-29087.json"
          },
          "ecosystem_specific": {
            "urgency": "not yet assigned"
          }
        },
        {
          "ranges": [
            {
              "type": "ECOSYSTEM",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "3.46.1-3"
                }
              ]
            }
          ],
          "package": {
            "name": "sqlite3",
            "purl": "pkg:deb/debian/sqlite3?arch=source&distro=forky",
            "ecosystem": "Debian:14"
          },
          "database_specific": {
            "source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2025-29087.json"
          },
          "ecosystem_specific": {
            "urgency": "not yet assigned"
          }
        }
      ],
      "modified": "2026-10-15T09:47:43.289230840Z",
      "provider": "osv",
      "upstream": [
        "CVE-2025-29087"
      ],
      "references": [
        "https://security-tracker.debian.org/tracker/CVE-2025-29087"
      ]
    },
    "related_cves": [
      {
        "value": "CVE-2025-29087",
        "evidence": "/upstream"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/severity/0/score"
  },
  "source_id": "core-osv",
  "document_id": 328503,
  "published_at": "2025-04-07T20:15:20.253+00:00"
}