High
Insufficient Session Expiration in alf.io
Type: advisorySources: OSV
Alf.io is a free and open source event attendance management system. In versions prior to 2.0-M4-2402 users can access the admin area even after being invalidated/deleted. This issue has been addressed in version 2.0-M4-2402. All users are advised to upgrade. There are no known workarounds for this vulnerability.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2024-25628
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 5 Nov 2026, 03:34 UTC · Revision 1
Source evidence
Alf.io is a free and open source event attendance management system. In versions prior to 2.0-M4-2402 users can access the admin area even after being invalidated/deleted. This issue has been addressed in version 2.0-M4-2402. All users are advised to upgrade. There are no known workarounds for this vulnerability.
osv:CVE-2024-25628
Complete source record
{
"id": "e7bd2d75b9981e67d53fa6f214bfcbdebf5c173cc65284235f2fe01d96f8ecc9",
"url": "https://osv.dev/vulnerability/CVE-2024-25628",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "Insufficient Session Expiration in alf.io",
"summary": "Alf.io is a free and open source event attendance management system. In versions prior to 2.0-M4-2402 users can access the admin area even after being invalidated/deleted. This issue has been addressed in version 2.0-M4-2402. All users are advised to upgrade. There are no known workarounds for this vulnerability.",
"evidence": "osv:CVE-2024-25628",
"products": [],
"severity": "high",
"structured": {
"id": "CVE-2024-25628",
"aliases": [
"CVE-2024-25628",
"GHSA-8p6m-mm22-q893"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:H"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/alfio-event/alf.io",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "d510c22f613bee0a2b7db51eab0f4d520826d8c0"
}
],
"database_specific": {
"extracted_events": [
{
"range": [
{
"introduced": "0"
},
{
"fixed": "2.0-M4-2402"
}
],
"source": "AFFECTED_FIELD",
"strategy": "StringRangeExpression"
},
{
"cpe": "cpe:2.3:a:alf:alf:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "0"
},
{
"fixed": "2.0-m4-2402"
}
],
"source": "CPE_RANGE"
}
]
}
}
],
"versions": [
"2.0-M4-2304",
"2.0-M4-2301",
"2.0-M4-2204",
"2.0-M4",
"2.0-M4.RC4",
"2.0-M4.RC3",
"2.0-M4.RC2",
"2.0-M4.RC1",
"2.0-M3",
"2.0-M2",
"2.0-M1-1906",
"2.0-M1-1906.1",
"2.0-M1",
"2.0-M0",
"1.14.1",
"1.14",
"1.14-RC2",
"1.14-RC1",
"1.13",
"1.13-RC3",
"1.13-RC2",
"1.13-RC1",
"1.12",
"1.12-RC4",
"1.12-RC3",
"1.12-RC2",
"1.12-RC1",
"1.11",
"1.10.1",
"1.10",
"1.10-RC2",
"1.10-RC1",
"1.9.1",
"1.9",
"1.8",
"1.8-RC2",
"1.8-RC1",
"1.7",
"1.6",
"1.5",
"1.4.1",
"1.4",
"1.4-RC2",
"alfio-1.3.1",
"alfio-1.3",
"alfio-1.3-beta1",
"alfio-1.2",
"alfio-1.1",
"v1.0-pre-rename-v2",
"v1.0-pre-rename"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2024-25628.json"
}
}
],
"modified": "2026-10-28T02:30:42.296582659Z",
"provider": "osv",
"references": [
"https://github.com/CVEProject/cvelistV5/tree/main/cves/2024/25xxx/CVE-2024-25628.json",
"https://github.com/alfio-event/alf.io/security/advisories/GHSA-8p6m-mm22-q893",
"https://nvd.nist.gov/vuln/detail/CVE-2024-25628"
],
"provider_metadata": {
"cwe_ids": [
"CWE-613"
],
"cna_assigner": "GitHub_M",
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2024/25xxx/CVE-2024-25628.json"
}
},
"related_cves": [
{
"value": "CVE-2024-25628",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 509899,
"published_at": "2024-02-16T20:23:44.693+00:00"
}