nats-server — security advisory
NATS Server is a high-performance server for NATS.io, the cloud and edge native messaging system. Prior to 2.14.3 and 2.12.12, a client could be registered as the configured no_auth_user through a parser path used when the first client operation was not CONNECT, bypassing user-level connection restrictions such as allowed_connection_types or proxy_required that normal authentication would apply. This issue is fixed in versions 2.14.3 and 2.12.12.
- Products
- nats-server
- Affected versions
- 2.10.24-1, 2.10.27-1, 2.10.27-1build1, 2.10.27-1ubuntu0.26.04.1~esm1, 2.10.3-1, 2.10.4-1, 2.10.7-1, 2.10.7-1ubuntu0.1, 2.10.7-1ubuntu0.2, 2.10.7-1ubuntu0.3, 2.14.1-1, 2.14.3-1, 2.9.19-1build1
- Fixed versions
- Not specified
- CVEs
- CVE-2026-58211
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 31 Oct 2026, 02:48 UTC · Revision 1
Source evidence
NATS Server is a high-performance server for NATS.io, the cloud and edge native messaging system. Prior to 2.14.3 and 2.12.12, a client could be registered as the configured no_auth_user through a parser path used when the first client operation was not CONNECT, bypassing user-level connection restrictions such as allowed_connection_types or proxy_required that normal authentication would apply. This issue is fixed in versions 2.14.3 and 2.12.12.
osv:UBUNTU-CVE-2026-58211
nats-server
Fixed versions: Not specified
nats-server
Fixed versions: Not specified
nats-server
Fixed versions: Not specified
nats-server
Fixed versions: Not specified
Complete source record
{
"id": "6278b6bd64c8cff1f28e05569fd5ca495f3a2bfc97af49b51935ab2ea5b8f7b5",
"url": "https://osv.dev/vulnerability/UBUNTU-CVE-2026-58211",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "UBUNTU-CVE-2026-58211",
"summary": "NATS Server is a high-performance server for NATS.io, the cloud and edge native messaging system. Prior to 2.14.3 and 2.12.12, a client could be registered as the configured no_auth_user through a parser path used when the first client operation was not CONNECT, bypassing user-level connection restrictions such as allowed_connection_types or proxy_required that normal authentication would apply. This issue is fixed in versions 2.14.3 and 2.12.12.",
"evidence": "osv:UBUNTU-CVE-2026-58211",
"products": [
{
"name": {
"value": "nats-server",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [],
"affected_versions": [
{
"value": "2.9.19-1build1",
"evidence": "/affected/0/versions"
},
{
"value": "2.10.3-1",
"evidence": "/affected/0/versions"
},
{
"value": "2.10.4-1",
"evidence": "/affected/0/versions"
},
{
"value": "2.10.7-1",
"evidence": "/affected/0/versions"
},
{
"value": "2.10.7-1ubuntu0.1",
"evidence": "/affected/0/versions"
},
{
"value": "2.10.7-1ubuntu0.2",
"evidence": "/affected/0/versions"
},
{
"value": "2.10.7-1ubuntu0.3",
"evidence": "/affected/0/versions"
}
]
},
{
"name": {
"value": "nats-server",
"evidence": "/affected/1/package/name"
},
"prerequisites": [],
"fixed_versions": [],
"affected_versions": [
{
"value": "2.10.24-1",
"evidence": "/affected/1/versions"
},
{
"value": "2.10.27-1",
"evidence": "/affected/1/versions"
}
]
},
{
"name": {
"value": "nats-server",
"evidence": "/affected/2/package/name"
},
"prerequisites": [],
"fixed_versions": [],
"affected_versions": [
{
"value": "2.10.27-1build1",
"evidence": "/affected/2/versions"
},
{
"value": "2.14.1-1",
"evidence": "/affected/2/versions"
},
{
"value": "2.14.3-1",
"evidence": "/affected/2/versions"
}
]
},
{
"name": {
"value": "nats-server",
"evidence": "/affected/3/package/name"
},
"prerequisites": [],
"fixed_versions": [],
"affected_versions": [
{
"value": "2.10.27-1",
"evidence": "/affected/3/versions"
},
{
"value": "2.10.27-1build1",
"evidence": "/affected/3/versions"
},
{
"value": "2.10.27-1ubuntu0.26.04.1~esm1",
"evidence": "/affected/3/versions"
}
]
}
],
"severity": "medium",
"structured": {
"id": "UBUNTU-CVE-2026-58211",
"aliases": [
"UBUNTU-CVE-2026-58211"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N"
},
{
"type": "Ubuntu",
"score": "medium"
}
],
"affected": [
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
}
]
}
],
"package": {
"name": "nats-server",
"purl": "pkg:deb/ubuntu/nats-server?arch=source&distro=noble",
"ecosystem": "Ubuntu:24.04:LTS"
},
"versions": [
"2.9.19-1build1",
"2.10.3-1",
"2.10.4-1",
"2.10.7-1",
"2.10.7-1ubuntu0.1",
"2.10.7-1ubuntu0.2",
"2.10.7-1ubuntu0.3"
],
"database_specific": {
"source": "https://github.com/canonical/ubuntu-security-notices/blob/main/osv/cve/2026/UBUNTU-CVE-2026-58211.json"
},
"ecosystem_specific": {
"binaries": [
{
"binary_name": "golang-github-nats-io-nats-server-dev",
"binary_version": "2.10.7-1ubuntu0.3"
},
{
"binary_name": "nats-server",
"binary_version": "2.10.7-1ubuntu0.3"
}
]
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
}
]
}
],
"package": {
"name": "nats-server",
"purl": "pkg:deb/ubuntu/nats-server?arch=source&distro=questing",
"ecosystem": "Ubuntu:25.10"
},
"versions": [
"2.10.24-1",
"2.10.27-1"
],
"database_specific": {
"source": "https://github.com/canonical/ubuntu-security-notices/blob/main/osv/cve/2026/UBUNTU-CVE-2026-58211.json"
},
"ecosystem_specific": {
"binaries": [
{
"binary_name": "golang-github-nats-io-nats-server-dev",
"binary_version": "2.10.27-1"
},
{
"binary_name": "nats-server",
"binary_version": "2.10.27-1"
}
]
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
}
]
}
],
"package": {
"name": "nats-server",
"purl": "pkg:deb/ubuntu/nats-server?arch=source&distro=stonking",
"ecosystem": "Ubuntu:26.10"
},
"versions": [
"2.10.27-1build1",
"2.14.1-1",
"2.14.3-1"
],
"database_specific": {
"source": "https://github.com/canonical/ubuntu-security-notices/blob/main/osv/cve/2026/UBUNTU-CVE-2026-58211.json"
},
"ecosystem_specific": {
"binaries": [
{
"binary_name": "golang-github-nats-io-nats-server-dev",
"binary_version": "2.14.3-1"
},
{
"binary_name": "nats-server",
"binary_version": "2.14.3-1"
}
]
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
}
]
}
],
"package": {
"name": "nats-server",
"purl": "pkg:deb/ubuntu/nats-server?arch=source&distro=esm-apps%2Fresolute",
"ecosystem": "Ubuntu:Pro:26.04:LTS"
},
"versions": [
"2.10.27-1",
"2.10.27-1build1",
"2.10.27-1ubuntu0.26.04.1~esm1"
],
"database_specific": {
"source": "https://github.com/canonical/ubuntu-security-notices/blob/main/osv/cve/2026/UBUNTU-CVE-2026-58211.json"
},
"ecosystem_specific": {
"binaries": [
{
"binary_name": "golang-github-nats-io-nats-server-dev",
"binary_version": "2.10.27-1ubuntu0.26.04.1~esm1"
},
{
"binary_name": "nats-server",
"binary_version": "2.10.27-1ubuntu0.26.04.1~esm1"
}
]
}
}
],
"modified": "2026-10-17T12:59:13.538024814Z",
"provider": "osv",
"upstream": [
"CVE-2026-58211"
],
"references": [
"https://ubuntu.com/security/CVE-2026-58211",
"https://www.cve.org/CVERecord?id=CVE-2026-58211",
"https://github.com/nats-io/nats-server/security/advisories/GHSA-hmmp-q8cx-v964"
]
},
"related_cves": [
{
"value": "CVE-2026-58211",
"evidence": "/upstream"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 359477,
"published_at": "2026-07-08T21:16:00+00:00"
}