HighFix available
modsecurity — security advisory
Trustwave ModSecurity 3.0.5 through 3.0.8 before 3.0.9 allows a denial of service (worker crash and unresponsiveness) because some inputs cause a segfault in the Transaction class for some configurations.
- Products
- modsecurity
- Affected versions
- Not specified
- Fixed versions
- 3.0.9-1
- CVEs
- CVE-2023-28882
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 1 Nov 2026, 15:46 UTC · Revision 1
Source evidence
Trustwave ModSecurity 3.0.5 through 3.0.8 before 3.0.9 allows a denial of service (worker crash and unresponsiveness) because some inputs cause a segfault in the Transaction class for some configurations.
osv:DEBIAN-CVE-2023-28882
modsecurity
Fixed versions: 3.0.9-1
modsecurity
Fixed versions: 3.0.9-1
modsecurity
Fixed versions: 3.0.9-1
Complete source record
{
"id": "4d144e24b29ff7e2bed041984bdb08e9240d30c19bfa8e31817898754f60dd98",
"url": "https://osv.dev/vulnerability/DEBIAN-CVE-2023-28882",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "DEBIAN-CVE-2023-28882",
"summary": "Trustwave ModSecurity 3.0.5 through 3.0.8 before 3.0.9 allows a denial of service (worker crash and unresponsiveness) because some inputs cause a segfault in the Transaction class for some configurations.",
"evidence": "osv:DEBIAN-CVE-2023-28882",
"products": [
{
"name": {
"value": "modsecurity",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "3.0.9-1",
"evidence": "/affected/0/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "modsecurity",
"evidence": "/affected/1/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "3.0.9-1",
"evidence": "/affected/1/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "modsecurity",
"evidence": "/affected/2/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "3.0.9-1",
"evidence": "/affected/2/ranges"
}
],
"affected_versions": []
}
],
"severity": "high",
"structured": {
"id": "DEBIAN-CVE-2023-28882",
"aliases": [
"DEBIAN-CVE-2023-28882"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H"
}
],
"affected": [
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "3.0.9-1"
}
]
}
],
"package": {
"name": "modsecurity",
"purl": "pkg:deb/debian/modsecurity?arch=source&distro=bookworm",
"ecosystem": "Debian:12"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2023-28882.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "3.0.9-1"
}
]
}
],
"package": {
"name": "modsecurity",
"purl": "pkg:deb/debian/modsecurity?arch=source&distro=trixie",
"ecosystem": "Debian:13"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2023-28882.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "3.0.9-1"
}
]
}
],
"package": {
"name": "modsecurity",
"purl": "pkg:deb/debian/modsecurity?arch=source&distro=forky",
"ecosystem": "Debian:14"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2023-28882.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
}
],
"modified": "2026-10-26T18:01:40.292291580Z",
"provider": "osv",
"upstream": [
"CVE-2023-28882"
],
"references": [
"https://security-tracker.debian.org/tracker/CVE-2023-28882"
]
},
"related_cves": [
{
"value": "CVE-2023-28882",
"evidence": "/upstream"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 455626,
"published_at": "2023-04-28T04:15:38.017+00:00"
}