Skip to content
Heist/ feed
Back to feed
Medium

Security advisory

Type: advisorySources: OSVCVE: CVE-2020-15177

In GLPI before version 9.5.2, the `install/install.php` endpoint insecurely stores user input into the database as `url_base` and `url_base_api`. These settings are referenced throughout the application and allow for vulnerabilities like Cross-Site Scripting and Insecure Redirection Since authentication is not required to perform these changes,anyone could point these fields at malicious websites or form input in a way to trigger XSS. Leveraging JavaScript it's possible to steal cookies, perform actions as the user, etc. The issue is patched in version 9.5.2.

Products
Not specified
Affected versions
Not specified
Fixed versions
Not specified
CVEs
CVE-2020-15177
Confirmed fixed CVEs
Not specified
Updated in this feed
31 Oct 2026, 10:52 UTC · Revision 1

Source evidence

CVE-2020-15177

core-osv · Original source

Published 7 Oct 2020, 19:15 UTC

In GLPI before version 9.5.2, the `install/install.php` endpoint insecurely stores user input into the database as `url_base` and `url_base_api`. These settings are referenced throughout the application and allow for vulnerabilities like Cross-Site Scripting and Insecure Redirection Since authentication is not required to perform these changes,anyone could point these fields at malicious websites or form input in a way to trigger XSS. Leveraging JavaScript it's possible to steal cookies, perform actions as the user, etc. The issue is patched in version 9.5.2.

osv:CVE-2020-15177
Complete source record
{
  "id": "b380adf0e739365604dc86392002bfc6fbf6caec2f59784ed30f5dd4301daa43",
  "url": "https://osv.dev/vulnerability/CVE-2020-15177",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "CVE-2020-15177",
    "summary": "In GLPI before version 9.5.2, the `install/install.php` endpoint insecurely stores user input into the database as `url_base` and `url_base_api`. These settings are referenced throughout the application and allow for vulnerabilities like Cross-Site Scripting and Insecure Redirection Since authentication is not required to perform these changes,anyone could point these fields at malicious websites or form input in a way to trigger XSS. Leveraging JavaScript it's possible to steal cookies, perform actions as the user, etc. The issue is patched in version 9.5.2.",
    "evidence": "osv:CVE-2020-15177",
    "products": [],
    "severity": "medium",
    "structured": {
      "id": "CVE-2020-15177",
      "aliases": [
        "CVE-2020-15177",
        "GHSA-prvh-9m4h-4m79"
      ],
      "metrics": [
        {
          "type": "CVSS_V3",
          "score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N"
        }
      ],
      "affected": [
        {
          "ranges": [
            {
              "repo": "https://github.com/glpi-project/glpi",
              "type": "GIT",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "677b4b87af935e23b4aa95c4eff07c1bd87ce8ab"
                },
                {
                  "fixed": "a8109d4ee970a222faf48cf48fae2d2f06465796"
                }
              ],
              "database_specific": {
                "extracted_events": [
                  {
                    "cpe": "cpe:2.3:a:glpi-project:glpi:*:*:*:*:*:*:*:*",
                    "range": [
                      {
                        "introduced": "0"
                      },
                      {
                        "fixed": "9.5.2"
                      }
                    ],
                    "source": "CPE_RANGE"
                  },
                  {
                    "range": [
                      {
                        "fixed": "a8109d4ee970a222faf48cf48fae2d2f06465796"
                      }
                    ],
                    "source": "REFERENCES_COMMIT"
                  }
                ]
              }
            }
          ],
          "versions": [
            "9.5.1",
            "9.5.0",
            "9.5.0-rc2",
            "9.5.0-rc1",
            "9.4.1.1",
            "9.4.1",
            "9.4.0",
            "9.4.0-rc2",
            "9.4.0-rc1",
            "9.4.0-beta",
            "9.3-beta",
            "9.1",
            "9.1-RC2",
            "9.1-RC1",
            "0.90",
            "0.90-RC2",
            "0.90-RC1",
            "0.90-beta2",
            "0.90-beta1"
          ],
          "database_specific": {
            "source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2020-15177.json"
          }
        }
      ],
      "modified": "2026-10-20T10:51:52.574160387Z",
      "provider": "osv",
      "references": [
        "https://github.com/glpi-project/glpi/security/advisories/GHSA-prvh-9m4h-4m79",
        "https://github.com/glpi-project/glpi/commit/a8109d4ee970a222faf48cf48fae2d2f06465796"
      ],
      "provider_metadata": {}
    },
    "related_cves": [
      {
        "value": "CVE-2020-15177",
        "evidence": "/id"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/severity/0/score"
  },
  "source_id": "core-osv",
  "document_id": 383064,
  "published_at": "2020-10-07T19:15:12.797+00:00"
}