libapache2-mod-auth-openidc — security advisory
mod_auth_openidc is an OpenID Certified authentication and authorization module for the Apache 2.x HTTP server that implements the OpenID Connect Relying Party functionality. Prior to 2.4.19.4, an out-of-bounds read and a one-byte out-of-bounds write exist in the state-cookie parser of `mod_auth_openidc`. The issue is fixed in version 2.4.19.4 by stopping the scan at the string terminator so a value-less token is rejected. No in-product workarounds are available. As a stop-gap, an upstream reverse proxy or WAF that rejects or normalizes malformed `Cookie` headers (tokens lacking `=`) can reduce exposure, but upgrading is the recommended remediation.
- Products
- libapache2-mod-auth-openidc
- Affected versions
- 2.4.12.3-2, 2.4.12.3-2+deb12u1, 2.4.12.3-2+deb12u2, 2.4.12.3-2+deb12u3, 2.4.12.3-2+deb12u4, 2.4.17-1, 2.4.17.2-1, 2.4.18-1, 2.4.18.1-1, 2.4.19-1, 2.4.19.1-1, 2.4.19.1-2, 2.4.19.2-1, 2.4.19.2-2, 2.4.19.2-3
- Fixed versions
- 2.4.12.3-2+deb12u5, 2.4.17-1+deb13u1, 2.4.19.4-1
- CVEs
- CVE-2026-54789
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 30 Oct 2026, 19:55 UTC · Revision 1
Source evidence
mod_auth_openidc is an OpenID Certified authentication and authorization module for the Apache 2.x HTTP server that implements the OpenID Connect Relying Party functionality. Prior to 2.4.19.4, an out-of-bounds read and a one-byte out-of-bounds write exist in the state-cookie parser of `mod_auth_openidc`. The issue is fixed in version 2.4.19.4 by stopping the scan at the string terminator so a value-less token is rejected. No in-product workarounds are available. As a stop-gap, an upstream reverse proxy or WAF that rejects or normalizes malformed `Cookie` headers (tokens lacking `=`) can reduce exposure, but upgrading is the recommended remediation.
osv:DEBIAN-CVE-2026-54789
libapache2-mod-auth-openidc
Fixed versions: 2.4.12.3-2+deb12u5
libapache2-mod-auth-openidc
Fixed versions: 2.4.17-1+deb13u1
libapache2-mod-auth-openidc
Fixed versions: 2.4.19.4-1
Complete source record
{
"id": "a559c165302f945ec370de4341beecfa67950671846ae74aec17667cf3a2bfdb",
"url": "https://osv.dev/vulnerability/DEBIAN-CVE-2026-54789",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "DEBIAN-CVE-2026-54789",
"summary": "mod_auth_openidc is an OpenID Certified authentication and authorization module for the Apache 2.x HTTP server that implements the OpenID Connect Relying Party functionality. Prior to 2.4.19.4, an out-of-bounds read and a one-byte out-of-bounds write exist in the state-cookie parser of `mod_auth_openidc`. The issue is fixed in version 2.4.19.4 by stopping the scan at the string terminator so a value-less token is rejected. No in-product workarounds are available. As a stop-gap, an upstream reverse proxy or WAF that rejects or normalizes malformed `Cookie` headers (tokens lacking `=`) can reduce exposure, but upgrading is the recommended remediation.",
"evidence": "osv:DEBIAN-CVE-2026-54789",
"products": [
{
"name": {
"value": "libapache2-mod-auth-openidc",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "2.4.12.3-2+deb12u5",
"evidence": "/affected/0/ranges"
}
],
"affected_versions": [
{
"value": "2.4.12.3-2",
"evidence": "/affected/0/versions"
},
{
"value": "2.4.12.3-2+deb12u1",
"evidence": "/affected/0/versions"
},
{
"value": "2.4.12.3-2+deb12u2",
"evidence": "/affected/0/versions"
},
{
"value": "2.4.12.3-2+deb12u3",
"evidence": "/affected/0/versions"
},
{
"value": "2.4.12.3-2+deb12u4",
"evidence": "/affected/0/versions"
}
]
},
{
"name": {
"value": "libapache2-mod-auth-openidc",
"evidence": "/affected/1/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "2.4.17-1+deb13u1",
"evidence": "/affected/1/ranges"
}
],
"affected_versions": [
{
"value": "2.4.17-1",
"evidence": "/affected/1/versions"
}
]
},
{
"name": {
"value": "libapache2-mod-auth-openidc",
"evidence": "/affected/2/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "2.4.19.4-1",
"evidence": "/affected/2/ranges"
}
],
"affected_versions": [
{
"value": "2.4.17-1",
"evidence": "/affected/2/versions"
},
{
"value": "2.4.17.2-1",
"evidence": "/affected/2/versions"
},
{
"value": "2.4.18-1",
"evidence": "/affected/2/versions"
},
{
"value": "2.4.18.1-1",
"evidence": "/affected/2/versions"
},
{
"value": "2.4.19-1",
"evidence": "/affected/2/versions"
},
{
"value": "2.4.19.1-1",
"evidence": "/affected/2/versions"
},
{
"value": "2.4.19.1-2",
"evidence": "/affected/2/versions"
},
{
"value": "2.4.19.2-1",
"evidence": "/affected/2/versions"
},
{
"value": "2.4.19.2-2",
"evidence": "/affected/2/versions"
},
{
"value": "2.4.19.2-3",
"evidence": "/affected/2/versions"
}
]
}
],
"severity": "high",
"structured": {
"id": "DEBIAN-CVE-2026-54789",
"aliases": [
"DEBIAN-CVE-2026-54789"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H"
}
],
"affected": [
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "2.4.12.3-2+deb12u5"
}
]
}
],
"package": {
"name": "libapache2-mod-auth-openidc",
"purl": "pkg:deb/debian/libapache2-mod-auth-openidc?arch=source&distro=bookworm",
"ecosystem": "Debian:12"
},
"versions": [
"2.4.12.3-2",
"2.4.12.3-2+deb12u1",
"2.4.12.3-2+deb12u2",
"2.4.12.3-2+deb12u3",
"2.4.12.3-2+deb12u4"
],
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2026-54789.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "2.4.17-1+deb13u1"
}
]
}
],
"package": {
"name": "libapache2-mod-auth-openidc",
"purl": "pkg:deb/debian/libapache2-mod-auth-openidc?arch=source&distro=trixie",
"ecosystem": "Debian:13"
},
"versions": [
"2.4.17-1"
],
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2026-54789.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "2.4.19.4-1"
}
]
}
],
"package": {
"name": "libapache2-mod-auth-openidc",
"purl": "pkg:deb/debian/libapache2-mod-auth-openidc?arch=source&distro=forky",
"ecosystem": "Debian:14"
},
"versions": [
"2.4.17-1",
"2.4.17.2-1",
"2.4.18-1",
"2.4.18.1-1",
"2.4.19-1",
"2.4.19.1-1",
"2.4.19.1-2",
"2.4.19.2-1",
"2.4.19.2-2",
"2.4.19.2-3"
],
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2026-54789.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
}
],
"modified": "2026-10-16T09:47:23.184558424Z",
"provider": "osv",
"upstream": [
"CVE-2026-54789"
],
"references": [
"https://security-tracker.debian.org/tracker/CVE-2026-54789"
]
},
"related_cves": [
{
"value": "CVE-2026-54789",
"evidence": "/upstream"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 338543,
"published_at": "2026-08-21T16:17:19+00:00"
}