Parse Server has a protected fields bypass via logical query operators
Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to 9.5.2-alpha.6 and 8.6.19, the validation for protected fields only checks top-level query keys. By wrapping a query constraint on a protected field inside a logical operator, the check is bypassed entirely. This allows any authenticated user to query on protected fields to extract field values. All Parse Server deployments have default protected fields and are vulnerable. This vulnerability is fixed in 9.5.2-alpha.6 and 8.6.19.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2026-30962
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 5 Nov 2026, 03:47 UTC · Revision 1
Source evidence
Parse Server has a protected fields bypass via logical query operators
core-osv · Original sourcePublished 10 Mar 2026, 20:42 UTC
Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to 9.5.2-alpha.6 and 8.6.19, the validation for protected fields only checks top-level query keys. By wrapping a query constraint on a protected field inside a logical operator, the check is bypassed entirely. This allows any authenticated user to query on protected fields to extract field values. All Parse Server deployments have default protected fields and are vulnerable. This vulnerability is fixed in 9.5.2-alpha.6 and 8.6.19.
osv:CVE-2026-30962
Complete source record
{
"id": "0f22253a89011eb6fc4c08fcedb5e502ce99ec5d095f200777291e6357466243",
"url": "https://osv.dev/vulnerability/CVE-2026-30962",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "Parse Server has a protected fields bypass via logical query operators",
"summary": "Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to 9.5.2-alpha.6 and 8.6.19, the validation for protected fields only checks top-level query keys. By wrapping a query constraint on a protected field inside a logical operator, the check is bypassed entirely. This allows any authenticated user to query on protected fields to extract field values. All Parse Server deployments have default protected fields and are vulnerable. This vulnerability is fixed in 9.5.2-alpha.6 and 8.6.19.",
"evidence": "osv:CVE-2026-30962",
"products": [],
"severity": "high",
"structured": {
"id": "CVE-2026-30962",
"aliases": [
"BIT-parse-2026-30962",
"CVE-2026-30962",
"GHSA-72hp-qff8-4pvv"
],
"metrics": [
{
"type": "CVSS_V4",
"score": "CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/parse-community/parse-server",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "efb6cfefc388db1fa908cf6c7589e1b29b3cfbc3"
},
{
"fixed": "189f15e6919acfad370da7b36cf4fc82f2c1ffdc"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:parseplatform:parse-server:*:*:*:*:*:node.js:*:*",
"range": [
{
"introduced": "0"
},
{
"fixed": "8.6.19"
}
],
"source": "CPE_RANGE"
},
{
"range": [
{
"fixed": "efb6cfefc388db1fa908cf6c7589e1b29b3cfbc3"
}
],
"source": "REFERENCES_TAG",
"original_tag": "8.6.19"
},
{
"range": [
{
"fixed": "189f15e6919acfad370da7b36cf4fc82f2c1ffdc"
}
],
"source": "REFERENCES_TAG",
"original_tag": "9.5.2-alpha.6"
}
]
}
}
],
"versions": [
"9.5.1",
"8.6.18",
"9.5.2-alpha.5",
"8.6.17",
"9.5.2-alpha.4",
"8.6.16",
"9.5.2-alpha.3",
"8.6.15",
"9.5.2-alpha.2",
"9.5.2-alpha.1",
"8.6.14",
"8.6.13",
"9.5.0",
"8.6.12",
"8.6.11",
"9.4.1",
"8.6.10",
"8.6.9",
"8.6.8",
"8.6.7",
"8.6.6",
"8.6.5",
"8.6.4",
"9.4.0",
"8.6.3",
"9.3.1",
"9.3.0",
"8.6.2",
"9.2.0",
"9.1.1",
"9.1.0",
"8.6.1",
"9.0.0",
"8.6.0",
"8.5.0",
"8.4.0",
"8.3.0",
"8.2.5",
"8.2.4",
"8.2.3",
"8.2.2",
"8.2.1",
"8.2.0",
"8.1.0",
"8.0.2",
"8.0.1",
"8.0.0",
"7.4.0",
"7.3.0",
"7.2.0",
"7.1.0",
"7.0.0",
"6.4.0",
"6.3.1",
"6.3.0",
"6.2.2",
"6.2.1",
"6.2.0",
"6.1.0",
"6.0.0",
"5.4.0",
"5.3.3",
"5.3.2",
"5.3.1",
"5.3.0",
"5.2.8",
"5.2.7",
"5.2.6",
"5.2.5",
"5.2.4",
"5.2.3",
"5.2.2",
"5.2.1",
"5.2.0",
"5.1.1",
"5.1.0",
"5.0.0",
"5.0.0-alpha.1",
"4.5.0",
"4.4.0",
"4.3.0",
"4.2.0",
"4.1.0",
"4.0.2",
"4.0.1",
"4.0.0",
"3.10.0",
"3.9.0",
"3.8.0",
"3.7.2",
"3.7.1",
"3.7.0",
"3.6.0",
"3.5.0",
"3.4.0",
"3.4.1",
"3.3.0",
"3.2.3",
"3.2.2",
"3.2.1",
"3.2.0",
"3.1.3",
"3.1.2",
"3.1.1",
"3.1.0",
"3.0.0",
"2.8.2",
"2.8.0",
"2.7.4",
"2.7.3",
"2.7.2",
"2.7.1",
"2.7.0",
"2.6.5",
"2.6.4",
"2.6.3",
"2.6.2",
"2.6.1",
"2.6.0",
"2.5.3",
"2.5.2",
"2.5.1",
"2.5.0",
"2.4.2",
"2.4.1",
"2.4.0",
"2.3.8",
"2.3.7",
"2.3.6",
"2.3.5",
"2.3.4",
"2.3.3",
"2.3.2",
"2.3.1",
"2.2.25",
"2.2.25-beta.1",
"2.2.24",
"2.2.23",
"2.2.22",
"2.2.21",
"2.2.20",
"2.2.19",
"2.2.18",
"2.2.17",
"2.2.16",
"2.2.15",
"2.2.14",
"2.2.13",
"2.2.12",
"2.2.11",
"2.2.10",
"2.2.9",
"2.2.8",
"2.2.7",
"2.2.6",
"2.2.5",
"2.2.4",
"2.2.3",
"2.2.2",
"2.2.1",
"2.2.0",
"2.1.6",
"2.1.5",
"2.1.4",
"2.1.3",
"2.1.2",
"2.1.1",
"2.1.0",
"2.0.8",
"2.0.7",
"2.0.3",
"2.0.6",
"2.0.5",
"2.0.4",
"2.0.2",
"2.0.1",
"2.0.0"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2026-30962.json"
}
}
],
"modified": "2026-10-28T02:30:42.099161420Z",
"provider": "osv",
"references": [
"https://github.com/parse-community/parse-server/releases/tag/8.6.19",
"https://github.com/parse-community/parse-server/releases/tag/9.5.2-alpha.6",
"https://github.com/CVEProject/cvelistV5/tree/main/cves/2026/30xxx/CVE-2026-30962.json",
"https://github.com/parse-community/parse-server/security/advisories/GHSA-72hp-qff8-4pvv",
"https://nvd.nist.gov/vuln/detail/CVE-2026-30962"
],
"provider_metadata": {
"cwe_ids": [
"CWE-284"
],
"cna_assigner": "GitHub_M",
"unresolved_ranges": [
{
"extracted_events": [
{
"range": [
{
"introduced": ">= 9.0.0 < 9.5.2-alpha.6"
},
{
"last_affected": ">= 9.0.0 < 9.5.2-alpha.6"
}
],
"source": "AFFECTED_FIELD",
"strategy": "StandaloneSingleVersion"
}
]
}
],
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2026/30xxx/CVE-2026-30962.json"
}
},
"related_cves": [
{
"value": "CVE-2026-30962",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 509957,
"published_at": "2026-03-10T20:42:22.827+00:00"
}