ruby-loofah — security advisory
Loofah is a general library for manipulating and transforming HTML/XML documents and fragments, built on top of Nokogiri. Loofah >= 2.2.0, < 2.19.1 uses recursion for sanitizing CDATA sections, making it susceptible to stack exhaustion and raising a SystemStackError exception. This may lead to a denial of service through CPU resource consumption. This issue is patched in version 2.19.1. Users who are unable to upgrade may be able to mitigate this vulnerability by limiting the length of the strings that are sanitized.
- Products
- ruby-loofah
- Affected versions
- Not specified
- Fixed versions
- 2.19.1-1
- CVEs
- CVE-2022-23516
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 30 Oct 2026, 15:00 UTC · Revision 1
Source evidence
Loofah is a general library for manipulating and transforming HTML/XML documents and fragments, built on top of Nokogiri. Loofah >= 2.2.0, < 2.19.1 uses recursion for sanitizing CDATA sections, making it susceptible to stack exhaustion and raising a SystemStackError exception. This may lead to a denial of service through CPU resource consumption. This issue is patched in version 2.19.1. Users who are unable to upgrade may be able to mitigate this vulnerability by limiting the length of the strings that are sanitized.
osv:DEBIAN-CVE-2022-23516
ruby-loofah
Fixed versions: 2.19.1-1
ruby-loofah
Fixed versions: 2.19.1-1
ruby-loofah
Fixed versions: 2.19.1-1
Complete source record
{
"id": "48a02b0e78fc1abd2adc9eb06360ad265ff6e2b4a935734b6f0e840cc12560ad",
"url": "https://osv.dev/vulnerability/DEBIAN-CVE-2022-23516",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "DEBIAN-CVE-2022-23516",
"summary": "Loofah is a general library for manipulating and transforming HTML/XML documents and fragments, built on top of Nokogiri. Loofah >= 2.2.0, < 2.19.1 uses recursion for sanitizing CDATA sections, making it susceptible to stack exhaustion and raising a SystemStackError exception. This may lead to a denial of service through CPU resource consumption. This issue is patched in version 2.19.1. Users who are unable to upgrade may be able to mitigate this vulnerability by limiting the length of the strings that are sanitized.",
"evidence": "osv:DEBIAN-CVE-2022-23516",
"products": [
{
"name": {
"value": "ruby-loofah",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "2.19.1-1",
"evidence": "/affected/0/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "ruby-loofah",
"evidence": "/affected/1/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "2.19.1-1",
"evidence": "/affected/1/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "ruby-loofah",
"evidence": "/affected/2/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "2.19.1-1",
"evidence": "/affected/2/ranges"
}
],
"affected_versions": []
}
],
"severity": "high",
"structured": {
"id": "DEBIAN-CVE-2022-23516",
"aliases": [
"DEBIAN-CVE-2022-23516"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H"
}
],
"affected": [
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "2.19.1-1"
}
]
}
],
"package": {
"name": "ruby-loofah",
"purl": "pkg:deb/debian/ruby-loofah?arch=source&distro=bookworm",
"ecosystem": "Debian:12"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2022-23516.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "2.19.1-1"
}
]
}
],
"package": {
"name": "ruby-loofah",
"purl": "pkg:deb/debian/ruby-loofah?arch=source&distro=trixie",
"ecosystem": "Debian:13"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2022-23516.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "2.19.1-1"
}
]
}
],
"package": {
"name": "ruby-loofah",
"purl": "pkg:deb/debian/ruby-loofah?arch=source&distro=forky",
"ecosystem": "Debian:14"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2022-23516.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
}
],
"modified": "2026-10-15T08:02:42.938237304Z",
"provider": "osv",
"upstream": [
"CVE-2022-23516"
],
"references": [
"https://security-tracker.debian.org/tracker/CVE-2022-23516"
]
},
"related_cves": [
{
"value": "CVE-2022-23516",
"evidence": "/upstream"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 324029,
"published_at": "2022-12-14T14:15:10.627+00:00"
}