Skip to content
Heist/ feed
Back to feed
Medium

Security advisory

Type: advisorySources: OSVCVE: CVE-2019-12397

Policy import functionality in Apache Ranger 0.7.0 to 1.2.0 is vulnerable to a cross-site scripting issue. Upgrade to 2.0.0 or later version of Apache Ranger with the fix.

Products
Not specified
Affected versions
Not specified
Fixed versions
Not specified
CVEs
CVE-2019-12397
Confirmed fixed CVEs
Not specified
Updated in this feed
1 Nov 2026, 04:31 UTC · Revision 1

Source evidence

CVE-2019-12397

core-osv · Original source

Published 8 Aug 2019, 18:15 UTC

Policy import functionality in Apache Ranger 0.7.0 to 1.2.0 is vulnerable to a cross-site scripting issue. Upgrade to 2.0.0 or later version of Apache Ranger with the fix.

osv:CVE-2019-12397
Complete source record
{
  "id": "634fa4e90252e7e0bcc70ee4d87897e6b088d8b8c7aa3fd985d1c524fabcdcf9",
  "url": "https://osv.dev/vulnerability/CVE-2019-12397",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "CVE-2019-12397",
    "summary": "Policy import functionality in Apache Ranger 0.7.0 to 1.2.0 is vulnerable to a cross-site scripting issue. Upgrade to 2.0.0 or later version of Apache Ranger with the fix.",
    "evidence": "osv:CVE-2019-12397",
    "products": [],
    "severity": "medium",
    "structured": {
      "id": "CVE-2019-12397",
      "aliases": [
        "CVE-2019-12397",
        "GHSA-fpqp-v323-44xv"
      ],
      "metrics": [
        {
          "type": "CVSS_V3",
          "score": "CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N"
        }
      ],
      "affected": [
        {
          "ranges": [
            {
              "repo": "https://github.com/apache/ranger",
              "type": "GIT",
              "events": [
                {
                  "introduced": "f39e4880082f5579db49b29be735977a341c041b"
                },
                {
                  "last_affected": "39ec5a38913e1d852cffecbdb8688b2370b6318f"
                }
              ],
              "database_specific": {
                "extracted_events": [
                  {
                    "cpe": "cpe:2.3:a:apache:ranger:*:*:*:*:*:*:*:*",
                    "range": [
                      {
                        "introduced": "0.7.0"
                      },
                      {
                        "last_affected": "1.2.0"
                      }
                    ],
                    "source": "CPE_RANGE"
                  }
                ]
              }
            }
          ],
          "database_specific": {
            "source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2019-12397.json"
          }
        }
      ],
      "modified": "2026-10-24T10:30:19.378286694Z",
      "provider": "osv",
      "references": [
        "https://lists.apache.org/thread.html/ab2de1adad96f5dbd19d976b28715dfc60dbe75e82a74f48be8ef695%40%3Cdev.ranger.apache.org%3E",
        "https://lists.apache.org/thread.html/cbc6346708ef2b9ffb2555637311bf6294923c609c029389fa39de8f%40%3Cdev.ranger.apache.org%3E",
        "https://lists.apache.org/thread.html/r04bc435a92911de4b52d2b98f169bd7cf2e8bbeb53b03788df8f932c%40%3Cdev.ranger.apache.org%3E",
        "https://lists.apache.org/thread.html/rd88077a781ef38f7687c100f93992f4dda8aa101925050c4af470998%40%3Cdev.ranger.apache.org%3E",
        "https://cwiki.apache.org/confluence/display/RANGER/Vulnerabilities+found+in+Ranger"
      ],
      "provider_metadata": {}
    },
    "related_cves": [
      {
        "value": "CVE-2019-12397",
        "evidence": "/id"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/severity/0/score"
  },
  "source_id": "core-osv",
  "document_id": 430008,
  "published_at": "2019-08-08T18:15:10.663+00:00"
}