Indico vulnerable to Cross-Site Scripting via LaTeX math code
Indico is an event management system that uses Flask-Multipass, a multi-backend authentication system for Flask. Prior to version 3.3.8, there is a Cross-Site-Scripting vulnerability when rendering LaTeX math code in contribution or abstract descriptions. Users should to update to Indico 3.3.8 as soon as possible. As a workaround, only let trustworthy users create content on Indico. Note that a conference doing a Call for Abstracts actively invites external speakers (who the organizers may not know and thus cannot fully trust) to submit content, hence the need to update to a a fixed version ASAP in particular when using such workflows.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2025-59035
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 3 Nov 2026, 01:08 UTC · Revision 1
Source evidence
Indico vulnerable to Cross-Site Scripting via LaTeX math code
core-osv · Original sourcePublished 10 Sept 2025, 16:03 UTC
Indico is an event management system that uses Flask-Multipass, a multi-backend authentication system for Flask. Prior to version 3.3.8, there is a Cross-Site-Scripting vulnerability when rendering LaTeX math code in contribution or abstract descriptions. Users should to update to Indico 3.3.8 as soon as possible. As a workaround, only let trustworthy users create content on Indico. Note that a conference doing a Call for Abstracts actively invites external speakers (who the organizers may not know and thus cannot fully trust) to submit content, hence the need to update to a a fixed version ASAP in particular when using such workflows.
osv:CVE-2025-59035
Complete source record
{
"id": "bdf95963599c5d6e6ff3f2e02fe1cc6bda6bc193e143a3474dde2cffaa2b22aa",
"url": "https://osv.dev/vulnerability/CVE-2025-59035",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "Indico vulnerable to Cross-Site Scripting via LaTeX math code",
"summary": "Indico is an event management system that uses Flask-Multipass, a multi-backend authentication system for Flask. Prior to version 3.3.8, there is a Cross-Site-Scripting vulnerability when rendering LaTeX math code in contribution or abstract descriptions. Users should to update to Indico 3.3.8 as soon as possible. As a workaround, only let trustworthy users create content on Indico. Note that a conference doing a Call for Abstracts actively invites external speakers (who the organizers may not know and thus cannot fully trust) to submit content, hence the need to update to a a fixed version ASAP in particular when using such workflows.",
"evidence": "osv:CVE-2025-59035",
"products": [],
"severity": "medium",
"structured": {
"id": "CVE-2025-59035",
"aliases": [
"CVE-2025-59035",
"GHSA-7cf7-9wrr-vrf4",
"PYSEC-2026-1461"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:L/I:L/A:N"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/indico/indico",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "12652ce3d8a9e0c52b81c49087f31e631ba645cb"
}
],
"database_specific": {
"extracted_events": [
{
"range": [
{
"introduced": "0"
},
{
"fixed": "3.3.8"
}
],
"source": "AFFECTED_FIELD",
"strategy": "StringRangeExpression"
},
{
"range": [
{
"fixed": "12652ce3d8a9e0c52b81c49087f31e631ba645cb"
}
],
"source": "REFERENCES_TAG",
"original_tag": "v3.3.8"
},
{
"cpe": "cpe:2.3:a:cern:indico:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "0"
},
{
"fixed": "3.3.8"
}
],
"source": "CPE_RANGE"
}
]
}
}
],
"versions": [
"v3.3.7",
"v3.3.6",
"v3.3.5",
"v3.3.4",
"v3.3.3",
"v3.3.2",
"v3.3.1",
"v3.3",
"v3.2.6+docs",
"v3.2.6",
"v3.2.5",
"v3.2.4",
"v3.2.3",
"v3.2.2",
"v3.2.1",
"v3.2",
"v3.0",
"v3.0rc2",
"v3.0rc1",
"v2.3.1",
"v2.3",
"v2.2",
"v2.1",
"v2.1rc6",
"v2.1rc5",
"v2.1rc4",
"v2.1rc3",
"v2.1rc2",
"v2.1rc1",
"v2.1b1",
"v2.1a3",
"v2.1a2",
"v2.1a1",
"v2.0rc1",
"v2.0a1",
"v1.9.11.dev9",
"v1.9.11.dev8",
"v1.9.11.dev7",
"v1.9.11.dev6",
"v1.9.11.dev3",
"v1.9.9",
"v0.97b2",
"v0.97b"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2025-59035.json"
}
}
],
"modified": "2026-10-28T02:30:24.999846899Z",
"provider": "osv",
"references": [
"https://github.com/indico/indico/releases/tag/v3.3.8",
"https://github.com/CVEProject/cvelistV5/tree/main/cves/2025/59xxx/CVE-2025-59035.json",
"https://github.com/indico/indico/security/advisories/GHSA-7cf7-9wrr-vrf4",
"https://nvd.nist.gov/vuln/detail/CVE-2025-59035"
],
"provider_metadata": {
"cwe_ids": [
"CWE-79"
],
"cna_assigner": "GitHub_M",
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2025/59xxx/CVE-2025-59035.json"
}
},
"related_cves": [
{
"value": "CVE-2025-59035",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 491437,
"published_at": "2025-09-10T16:03:36.573+00:00"
}