Skip to content
Heist/ feed
Back to feed
CriticalFix available

ansible — security advisory

Type: advisorySources: OSVAdvisory ID: DEBIAN-CVE-2014-4657

The safe_eval function in Ansible before 1.5.4 does not properly restrict the code subset, which allows remote attackers to execute arbitrary code via crafted instructions.

Products
ansible
Affected versions
Not specified
Fixed versions
1.5.5+dfsg-1
CVEs
CVE-2014-4657
Confirmed fixed CVEs
Not specified
Updated in this feed
31 Oct 2026, 21:50 UTC · Revision 1

Source evidence

DEBIAN-CVE-2014-4657

core-osv · Original source

Published 20 Feb 2020, 15:15 UTC

The safe_eval function in Ansible before 1.5.4 does not properly restrict the code subset, which allows remote attackers to execute arbitrary code via crafted instructions.

osv:DEBIAN-CVE-2014-4657

ansible

Fixed versions: 1.5.5+dfsg-1

ansible

Fixed versions: 1.5.5+dfsg-1

ansible

Fixed versions: 1.5.5+dfsg-1

Complete source record
{
  "id": "7ddac658575191a5a09e8a298fe8af28f10ae0febe5dfb8aab2fdb5ed6e0b0f6",
  "url": "https://osv.dev/vulnerability/DEBIAN-CVE-2014-4657",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "DEBIAN-CVE-2014-4657",
    "summary": "The safe_eval function in Ansible before 1.5.4 does not properly restrict the code subset, which allows remote attackers to execute arbitrary code via crafted instructions.",
    "evidence": "osv:DEBIAN-CVE-2014-4657",
    "products": [
      {
        "name": {
          "value": "ansible",
          "evidence": "/affected/0/package/name"
        },
        "prerequisites": [],
        "fixed_versions": [
          {
            "value": "1.5.5+dfsg-1",
            "evidence": "/affected/0/ranges"
          }
        ],
        "affected_versions": []
      },
      {
        "name": {
          "value": "ansible",
          "evidence": "/affected/1/package/name"
        },
        "prerequisites": [],
        "fixed_versions": [
          {
            "value": "1.5.5+dfsg-1",
            "evidence": "/affected/1/ranges"
          }
        ],
        "affected_versions": []
      },
      {
        "name": {
          "value": "ansible",
          "evidence": "/affected/2/package/name"
        },
        "prerequisites": [],
        "fixed_versions": [
          {
            "value": "1.5.5+dfsg-1",
            "evidence": "/affected/2/ranges"
          }
        ],
        "affected_versions": []
      }
    ],
    "severity": "critical",
    "structured": {
      "id": "DEBIAN-CVE-2014-4657",
      "aliases": [
        "DEBIAN-CVE-2014-4657"
      ],
      "metrics": [
        {
          "type": "CVSS_V3",
          "score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H"
        }
      ],
      "affected": [
        {
          "ranges": [
            {
              "type": "ECOSYSTEM",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "1.5.5+dfsg-1"
                }
              ]
            }
          ],
          "package": {
            "name": "ansible",
            "purl": "pkg:deb/debian/ansible?arch=source&distro=bookworm",
            "ecosystem": "Debian:12"
          },
          "database_specific": {
            "source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2014-4657.json"
          },
          "ecosystem_specific": {
            "urgency": "not yet assigned"
          }
        },
        {
          "ranges": [
            {
              "type": "ECOSYSTEM",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "1.5.5+dfsg-1"
                }
              ]
            }
          ],
          "package": {
            "name": "ansible",
            "purl": "pkg:deb/debian/ansible?arch=source&distro=trixie",
            "ecosystem": "Debian:13"
          },
          "database_specific": {
            "source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2014-4657.json"
          },
          "ecosystem_specific": {
            "urgency": "not yet assigned"
          }
        },
        {
          "ranges": [
            {
              "type": "ECOSYSTEM",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "1.5.5+dfsg-1"
                }
              ]
            }
          ],
          "package": {
            "name": "ansible",
            "purl": "pkg:deb/debian/ansible?arch=source&distro=forky",
            "ecosystem": "Debian:14"
          },
          "database_specific": {
            "source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2014-4657.json"
          },
          "ecosystem_specific": {
            "urgency": "not yet assigned"
          }
        }
      ],
      "modified": "2026-10-23T16:00:36.063504334Z",
      "provider": "osv",
      "upstream": [
        "CVE-2014-4657"
      ],
      "references": [
        "https://security-tracker.debian.org/tracker/CVE-2014-4657"
      ]
    },
    "related_cves": [
      {
        "value": "CVE-2014-4657",
        "evidence": "/upstream"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/severity/0/score"
  },
  "source_id": "core-osv",
  "document_id": 414672,
  "published_at": "2020-02-20T15:15:11.54+00:00"
}