HighFix available
Ghost 2.10.0 before 6.63.0 Staff Enumeration via Content API
Type: advisorySources: OSV
Ghost versions from 2.10.0 before 6.63.0 contain a staff enumeration vulnerability in the content API that allows unauthenticated attackers to leak user data. Attackers can observe discrepancies in API metadata responses to enumerate staff members and extract sensitive information without authentication.
- Products
- ghost
- Affected versions
- Not specified
- Fixed versions
- 6.63.0
- CVEs
- CVE-2026-103272
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 28 Oct 2026, 12:33 UTC · Revision 1
Source evidence
Ghost 2.10.0 before 6.63.0 Staff Enumeration via Content API
core-osv · Original sourcePublished 9 Oct 2026, 10:44 UTC
Ghost versions from 2.10.0 before 6.63.0 contain a staff enumeration vulnerability in the content API that allows unauthenticated attackers to leak user data. Attackers can observe discrepancies in API metadata responses to enumerate staff members and extract sensitive information without authentication.
osv:BIT-ghost-2026-103272
ghost
Fixed versions: 6.63.0
Complete source record
{
"id": "b66425b48efdffe7ff0cfcbb711fe086fa009214859577b08a124ce15fbd35da",
"url": "https://osv.dev/vulnerability/BIT-ghost-2026-103272",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "Ghost 2.10.0 before 6.63.0 Staff Enumeration via Content API",
"summary": "Ghost versions from 2.10.0 before 6.63.0 contain a staff enumeration vulnerability in the content API that allows unauthenticated attackers to leak user data. Attackers can observe discrepancies in API metadata responses to enumerate staff members and extract sensitive information without authentication.",
"evidence": "osv:BIT-ghost-2026-103272",
"products": [
{
"name": {
"value": "ghost",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "6.63.0",
"evidence": "/affected/0/ranges"
}
],
"affected_versions": []
}
],
"severity": "high",
"structured": {
"id": "BIT-ghost-2026-103272",
"aliases": [
"BIT-ghost-2026-103272",
"CVE-2026-103272",
"GHSA-ffmj-3ppp-cj4r"
],
"affected": [
{
"ranges": [
{
"type": "SEMVER",
"events": [
{
"introduced": "2.10.0"
},
{
"fixed": "6.63.0"
}
]
}
],
"package": {
"name": "ghost",
"purl": "pkg:bitnami/ghost",
"ecosystem": "Bitnami"
},
"severity": [
{
"type": "CVSS_V4",
"score": "CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X"
}
],
"database_specific": {
"source": "https://github.com/bitnami/vulndb/tree/main/data/ghost/BIT-ghost-2026-103272.json"
}
}
],
"modified": "2026-10-09T12:11:01.566091707Z",
"provider": "osv",
"references": [
"https://github.com/TryGhost/Ghost/security/advisories/GHSA-ffmj-3ppp-cj4r",
"https://nvd.nist.gov/vuln/detail/CVE-2026-103272",
"https://www.vulncheck.com/advisories/ghost-2.10.0-before-6.63.0-staff-enumeration-via-content-api"
],
"provider_metadata": {
"cpes": [
"cpe:2.3:a:ghost:ghost:*:*:*:*:*:node.js:*:*"
],
"severity": "High"
}
},
"related_cves": [
{
"value": "CVE-2026-103272",
"evidence": "/aliases"
}
],
"security_relevant": true,
"severity_evidence": "/database_specific/severity"
},
"source_id": "core-osv",
"document_id": 120760,
"published_at": "2026-10-09T10:44:50.368+00:00"
}