CriticalFix available
wordpress — security advisory
WordPress 6.9.x before 6.9.5 and 7.0.x before 7.0.2 is affected by a REST API batch endpoint route confusion issue which, combined with the author__not_in WP_Query SQL Injection (CVE-2026-60137), could allow an attacker to perform SQL Injection and achieve Remote Code Execution.
- Products
- wordpress
- Affected versions
- 6.8.1+dfsg1-1, 6.8.3+dfsg1-1, 6.9+dfsg1-1, 6.9.4+dfsg1-1, 7.0+dfsg1-1
- Fixed versions
- 7.0.2+dfsg1-1
- CVEs
- CVE-2026-63030
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 28 Oct 2026, 11:08 UTC · Revision 1
Source evidence
WordPress 6.9.x before 6.9.5 and 7.0.x before 7.0.2 is affected by a REST API batch endpoint route confusion issue which, combined with the author__not_in WP_Query SQL Injection (CVE-2026-60137), could allow an attacker to perform SQL Injection and achieve Remote Code Execution.
osv:DEBIAN-CVE-2026-63030
wordpress
Fixed versions: 7.0.2+dfsg1-1
Complete source record
{
"id": "ef73718d4ee4edd5dc0271f32a7650828280d4cbbe7e99da44311e78039fefce",
"url": "https://osv.dev/vulnerability/DEBIAN-CVE-2026-63030",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "DEBIAN-CVE-2026-63030",
"summary": "WordPress 6.9.x before 6.9.5 and 7.0.x before 7.0.2 is affected by a REST API batch endpoint route confusion issue which, combined with the author__not_in WP_Query SQL Injection (CVE-2026-60137), could allow an attacker to perform SQL Injection and achieve Remote Code Execution.",
"evidence": "osv:DEBIAN-CVE-2026-63030",
"products": [
{
"name": {
"value": "wordpress",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "7.0.2+dfsg1-1",
"evidence": "/affected/0/ranges"
}
],
"affected_versions": [
{
"value": "6.8.1+dfsg1-1",
"evidence": "/affected/0/versions"
},
{
"value": "6.8.3+dfsg1-1",
"evidence": "/affected/0/versions"
},
{
"value": "6.9+dfsg1-1",
"evidence": "/affected/0/versions"
},
{
"value": "6.9.4+dfsg1-1",
"evidence": "/affected/0/versions"
},
{
"value": "7.0+dfsg1-1",
"evidence": "/affected/0/versions"
}
]
}
],
"severity": "critical",
"structured": {
"id": "DEBIAN-CVE-2026-63030",
"aliases": [
"DEBIAN-CVE-2026-63030"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H"
}
],
"affected": [
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "7.0.2+dfsg1-1"
}
]
}
],
"package": {
"name": "wordpress",
"purl": "pkg:deb/debian/wordpress?arch=source&distro=forky",
"ecosystem": "Debian:14"
},
"versions": [
"6.8.1+dfsg1-1",
"6.8.3+dfsg1-1",
"6.9+dfsg1-1",
"6.9.4+dfsg1-1",
"7.0+dfsg1-1"
],
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2026-63030.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
}
],
"modified": "2026-10-09T09:47:32.904170768Z",
"provider": "osv",
"upstream": [
"CVE-2026-63030"
],
"references": [
"https://security-tracker.debian.org/tracker/CVE-2026-63030"
]
},
"related_cves": [
{
"value": "CVE-2026-63030",
"evidence": "/upstream"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 111633,
"published_at": "2026-07-17T20:17:28.49+00:00"
}