Skip to content
Heist/ feed
Back to feed
LowFix available

ruby-json — security advisory

Type: advisorySources: OSVAdvisory ID: DEBIAN-CVE-2026-54696

Ruby JSON is a JSON implementation for Ruby. Versions 2.9.0 through 2.19.8 are vulnerable to heap buffer overflow when the JSON generator is provided with an oversized streamed object. When streaming to an IO JSON.dump(obj, io) and JSON::State#generate(obj, io) can write past the internal JSON generator buffer when a streamed object contains an attacker-controlled string near 16 KB. Exploitation would result in a reliable process crash/denial of service. This issue has been fixed in version 2.19.9.

Products
ruby-json
Affected versions
2.15.2+dfsg-1, 2.18.1+dfsg-1, 2.19.1+dfsg-1, 2.19.2+dfsg-1, 2.19.4+dfsg-1, 2.19.9+dfsg-1, 2.21.1+dfsg-1, 2.21.2+dfsg-1, 2.9.1+dfsg-1, 3.0.2+dfsg-1, 3.1.0+dfsg-1
Fixed versions
2.19.9+dfsg-1
CVEs
CVE-2026-54696
Confirmed fixed CVEs
Not specified
Updated in this feed
1 Nov 2026, 13:59 UTC · Revision 2

Source evidence

DEBIAN-CVE-2026-54696

core-osv · Original source

Published 30 Jun 2026, 23:17 UTC

Ruby JSON is a JSON implementation for Ruby. Versions 2.9.0 through 2.19.8 are vulnerable to heap buffer overflow when the JSON generator is provided with an oversized streamed object. When streaming to an IO JSON.dump(obj, io) and JSON::State#generate(obj, io) can write past the internal JSON generator buffer when a streamed object contains an attacker-controlled string near 16 KB. Exploitation would result in a reliable process crash/denial of service. This issue has been fixed in version 2.19.9.

osv:DEBIAN-CVE-2026-54696

ruby-json

Fixed versions: Not specified

ruby-json

Fixed versions: 2.19.9+dfsg-1

Complete source record
{
  "id": "6d1957d237cc109f00d9c383865c17616b6aca9b0cc31268f3aeebba1764d4e7",
  "url": "https://osv.dev/vulnerability/DEBIAN-CVE-2026-54696",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "DEBIAN-CVE-2026-54696",
    "summary": "Ruby JSON is a JSON implementation for Ruby. Versions 2.9.0 through 2.19.8 are vulnerable to heap buffer overflow when the JSON generator is provided with an oversized streamed object. When streaming to an IO JSON.dump(obj, io) and JSON::State#generate(obj, io) can write past the internal JSON generator buffer when a streamed object contains an attacker-controlled string near 16 KB. Exploitation would result in a reliable process crash/denial of service. This issue has been fixed in version 2.19.9.",
    "evidence": "osv:DEBIAN-CVE-2026-54696",
    "products": [
      {
        "name": {
          "value": "ruby-json",
          "evidence": "/affected/0/package/name"
        },
        "prerequisites": [],
        "fixed_versions": [],
        "affected_versions": [
          {
            "value": "2.15.2+dfsg-1",
            "evidence": "/affected/0/versions"
          },
          {
            "value": "2.18.1+dfsg-1",
            "evidence": "/affected/0/versions"
          },
          {
            "value": "2.19.1+dfsg-1",
            "evidence": "/affected/0/versions"
          },
          {
            "value": "2.19.2+dfsg-1",
            "evidence": "/affected/0/versions"
          },
          {
            "value": "2.19.4+dfsg-1",
            "evidence": "/affected/0/versions"
          },
          {
            "value": "2.19.9+dfsg-1",
            "evidence": "/affected/0/versions"
          },
          {
            "value": "2.21.1+dfsg-1",
            "evidence": "/affected/0/versions"
          },
          {
            "value": "2.21.2+dfsg-1",
            "evidence": "/affected/0/versions"
          },
          {
            "value": "2.9.1+dfsg-1",
            "evidence": "/affected/0/versions"
          },
          {
            "value": "3.0.2+dfsg-1",
            "evidence": "/affected/0/versions"
          },
          {
            "value": "3.1.0+dfsg-1",
            "evidence": "/affected/0/versions"
          }
        ]
      },
      {
        "name": {
          "value": "ruby-json",
          "evidence": "/affected/1/package/name"
        },
        "prerequisites": [],
        "fixed_versions": [
          {
            "value": "2.19.9+dfsg-1",
            "evidence": "/affected/1/ranges"
          }
        ],
        "affected_versions": [
          {
            "value": "2.15.2+dfsg-1",
            "evidence": "/affected/1/versions"
          },
          {
            "value": "2.18.1+dfsg-1",
            "evidence": "/affected/1/versions"
          },
          {
            "value": "2.19.1+dfsg-1",
            "evidence": "/affected/1/versions"
          },
          {
            "value": "2.19.2+dfsg-1",
            "evidence": "/affected/1/versions"
          },
          {
            "value": "2.19.4+dfsg-1",
            "evidence": "/affected/1/versions"
          },
          {
            "value": "2.9.1+dfsg-1",
            "evidence": "/affected/1/versions"
          }
        ]
      }
    ],
    "severity": "low",
    "structured": {
      "id": "DEBIAN-CVE-2026-54696",
      "aliases": [
        "DEBIAN-CVE-2026-54696"
      ],
      "metrics": [
        {
          "type": "CVSS_V3",
          "score": "CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:L"
        }
      ],
      "affected": [
        {
          "ranges": [
            {
              "type": "ECOSYSTEM",
              "events": [
                {
                  "introduced": "0"
                }
              ]
            }
          ],
          "package": {
            "name": "ruby-json",
            "purl": "pkg:deb/debian/ruby-json?arch=source&distro=trixie",
            "ecosystem": "Debian:13"
          },
          "versions": [
            "2.15.2+dfsg-1",
            "2.18.1+dfsg-1",
            "2.19.1+dfsg-1",
            "2.19.2+dfsg-1",
            "2.19.4+dfsg-1",
            "2.19.9+dfsg-1",
            "2.21.1+dfsg-1",
            "2.21.2+dfsg-1",
            "2.9.1+dfsg-1",
            "3.0.2+dfsg-1",
            "3.1.0+dfsg-1"
          ],
          "database_specific": {
            "source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2026-54696.json"
          },
          "ecosystem_specific": {
            "urgency": "not yet assigned"
          }
        },
        {
          "ranges": [
            {
              "type": "ECOSYSTEM",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "2.19.9+dfsg-1"
                }
              ]
            }
          ],
          "package": {
            "name": "ruby-json",
            "purl": "pkg:deb/debian/ruby-json?arch=source&distro=forky",
            "ecosystem": "Debian:14"
          },
          "versions": [
            "2.15.2+dfsg-1",
            "2.18.1+dfsg-1",
            "2.19.1+dfsg-1",
            "2.19.2+dfsg-1",
            "2.19.4+dfsg-1",
            "2.9.1+dfsg-1"
          ],
          "database_specific": {
            "source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2026-54696.json"
          },
          "ecosystem_specific": {
            "urgency": "not yet assigned"
          }
        }
      ],
      "modified": "2026-10-26T12:02:58.256919007Z",
      "provider": "osv",
      "upstream": [
        "CVE-2026-54696"
      ],
      "references": [
        "https://security-tracker.debian.org/tracker/CVE-2026-54696"
      ]
    },
    "related_cves": [
      {
        "value": "CVE-2026-54696",
        "evidence": "/upstream"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/severity/0/score"
  },
  "source_id": "core-osv",
  "document_id": 453023,
  "published_at": "2026-06-30T23:17:28.123+00:00"
}