OPNsense: RCE on user managment
OPNsense is a FreeBSD based firewall and routing platform. Prior to 26.1.8, an authenticated Remote Code Execution (RCE) vulnerability in the OPNsense core allows a user with user-management privileges to execute arbitrary system commands as root. An attacker can bypass input validation by formatting their malicious payload as a compliant email address, allowing shell commands to reach the underlying operating system. The flaw exists in the local user synchronization flow, within core/src/opnsense/scripts/auth/sync_user.php. This vulnerability is fixed in 26.1.8.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2026-44194
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 4 Nov 2026, 15:49 UTC · Revision 1
Source evidence
OPNsense is a FreeBSD based firewall and routing platform. Prior to 26.1.8, an authenticated Remote Code Execution (RCE) vulnerability in the OPNsense core allows a user with user-management privileges to execute arbitrary system commands as root. An attacker can bypass input validation by formatting their malicious payload as a compliant email address, allowing shell commands to reach the underlying operating system. The flaw exists in the local user synchronization flow, within core/src/opnsense/scripts/auth/sync_user.php. This vulnerability is fixed in 26.1.8.
osv:CVE-2026-44194
Complete source record
{
"id": "32fc1af3f3aef6d3fe9876032d5fdb34fd72f30d8ee910a44102ae29d38dabe0",
"url": "https://osv.dev/vulnerability/CVE-2026-44194",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "OPNsense: RCE on user managment",
"summary": "OPNsense is a FreeBSD based firewall and routing platform. Prior to 26.1.8, an authenticated Remote Code Execution (RCE) vulnerability in the OPNsense core allows a user with user-management privileges to execute arbitrary system commands as root. An attacker can bypass input validation by formatting their malicious payload as a compliant email address, allowing shell commands to reach the underlying operating system. The flaw exists in the local user synchronization flow, within core/src/opnsense/scripts/auth/sync_user.php. This vulnerability is fixed in 26.1.8.",
"evidence": "osv:CVE-2026-44194",
"products": [],
"severity": "critical",
"structured": {
"id": "CVE-2026-44194",
"aliases": [
"CVE-2026-44194",
"GHSA-f59w-m967-9rf6"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:H"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/opnsense/core",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "76ed1ef85a4bbcfc9cb1a2331e63a01e4f1e44fd"
}
],
"database_specific": {
"extracted_events": [
{
"range": [
{
"introduced": "0"
},
{
"fixed": "26.1.8"
}
],
"source": "AFFECTED_FIELD",
"strategy": "StringRangeExpression"
},
{
"cpe": "cpe:2.3:a:opnsense:opnsense:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "0"
},
{
"fixed": "26.1.8"
}
],
"source": "CPE_RANGE"
}
]
}
}
],
"versions": [
"26.1.6",
"26.1.7",
"26.1.5",
"26.1.4",
"26.1.3",
"26.1.2",
"26.1.1",
"26.1",
"26.1.r2",
"26.1.r1",
"26.1.r",
"26.1.b",
"26.1.a",
"25.7.r",
"25.7.b",
"25.7.a",
"25.1.r",
"25.1.b",
"25.1.a",
"24.7.r",
"24.7.b",
"24.7.a",
"24.1.r",
"24.1.b",
"24.1.a",
"23.7.r",
"23.7.b",
"23.7.a",
"23.1.r",
"23.1.b",
"23.1.a",
"22.7.r",
"22.7.b",
"22.7.a",
"22.1.r",
"22.1.b",
"22.1.a",
"21.7.r",
"21.7.b",
"21.7.a",
"21.1.r",
"21.1.b",
"21.1.a",
"20.7.r",
"20.7.b",
"20.7.a",
"20.1.r",
"20.1.b",
"20.1.a",
"19.7.r",
"19.7.b",
"19.7.a",
"19.1.r",
"19.1.b",
"19.1.a",
"18.7.r",
"18.7.b",
"18.7.a",
"18.1.r",
"18.1.b",
"18.1.a",
"17.7.r",
"17.7.b",
"17.7.a",
"17.1.r",
"17.1.b",
"17.1.a",
"16.7.r",
"16.7.b",
"16.7.a",
"15.7",
"15.1.12",
"15.1.11.4",
"15.1.11.3",
"15.1.11.2",
"15.1.11.1",
"15.1.11",
"15.1.10.2",
"15.1.10",
"15.1.9.2",
"15.1.9.1",
"15.1.9",
"15.1.8.4",
"15.1.8.3",
"15.1.8.2",
"15.1.8.1",
"15.1.8",
"15.1.7.2",
"15.1.7.1",
"15.1.7",
"15.1.6.1",
"15.1.6",
"15.1.5",
"15.1.4",
"15.1.3",
"15.1.2",
"15.1.1",
"15.1"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2026-44194.json"
}
}
],
"modified": "2026-10-28T02:30:37.183815243Z",
"provider": "osv",
"references": [
"https://github.com/CVEProject/cvelistV5/tree/main/cves/2026/44xxx/CVE-2026-44194.json",
"https://github.com/opnsense/core/security/advisories/GHSA-f59w-m967-9rf6",
"https://nvd.nist.gov/vuln/detail/CVE-2026-44194"
],
"provider_metadata": {
"cwe_ids": [
"CWE-78"
],
"cna_assigner": "GitHub_M",
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2026/44xxx/CVE-2026-44194.json"
}
},
"related_cves": [
{
"value": "CVE-2026-44194",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 504269,
"published_at": "2026-05-13T21:53:27.948+00:00"
}