FreePBX Administration GUI is Vulnerable to Authenticated Command Injection
FreePBX Endpoint Manager is a module for managing telephony endpoints in FreePBX systems. In versions 17.0.2.36 and above before 17.0.3, the filestore module within the Administrative interface is vulnerable to a post-authentication command injection by an authenticated known user via the testconnection -> check_ssh_connect() function. An attacker can leverage this vulnerability to obtain remote access to the system as an asterisk user. This issue is fixed in version 17.0.3.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2025-64328
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 4 Nov 2026, 07:45 UTC · Revision 1
Source evidence
FreePBX Administration GUI is Vulnerable to Authenticated Command Injection
core-osv · Original sourcePublished 7 Nov 2025, 03:32 UTC
FreePBX Endpoint Manager is a module for managing telephony endpoints in FreePBX systems. In versions 17.0.2.36 and above before 17.0.3, the filestore module within the Administrative interface is vulnerable to a post-authentication command injection by an authenticated known user via the testconnection -> check_ssh_connect() function. An attacker can leverage this vulnerability to obtain remote access to the system as an asterisk user. This issue is fixed in version 17.0.3.
osv:CVE-2025-64328
Complete source record
{
"id": "f837bef6fb4d5a0e825f4f1a1705861f274f6213b3ec7c90caa81650a84fe236",
"url": "https://osv.dev/vulnerability/CVE-2025-64328",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "FreePBX Administration GUI is Vulnerable to Authenticated Command Injection",
"summary": "FreePBX Endpoint Manager is a module for managing telephony endpoints in FreePBX systems. In versions 17.0.2.36 and above before 17.0.3, the filestore module within the Administrative interface is vulnerable to a post-authentication command injection by an authenticated known user via the testconnection -> check_ssh_connect() function. An attacker can leverage this vulnerability to obtain remote access to the system as an asterisk user. This issue is fixed in version 17.0.3.",
"evidence": "osv:CVE-2025-64328",
"products": [],
"severity": "high",
"structured": {
"id": "CVE-2025-64328",
"aliases": [
"CVE-2025-64328",
"GHSA-vm9p-46mv-5xvw"
],
"metrics": [
{
"type": "CVSS_V4",
"score": "CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/freepbx/filestore",
"type": "GIT",
"events": [
{
"introduced": "76dcf9d27bc7768025ab435012daf6bca9168bcc"
},
{
"fixed": "e21c0bff27ce8d43d676c738ff1c2c854a65db0c"
}
],
"database_specific": {
"extracted_events": [
{
"range": [
{
"introduced": "17.0.2.36"
},
{
"fixed": "17.0.3"
}
],
"source": "AFFECTED_FIELD",
"strategy": "StringRangeExpression"
},
{
"cpe": "cpe:2.3:a:sangoma:filestore:*:*:*:*:*:freepbx:*:*",
"range": [
{
"introduced": "17.0.2.36"
},
{
"fixed": "17.0.3"
}
],
"source": "CPE_RANGE"
}
]
}
}
],
"versions": [
"release/17.0.2.44",
"release/17.0.2.43",
"release/17.0.2.42",
"release/17.0.2.41",
"release/17.0.2.40",
"release/17.0.2.39",
"release/17.0.2.38",
"release/17.0.2.37",
"release/17.0.2.36"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2025-64328.json"
}
}
],
"modified": "2026-10-28T02:30:33.816092921Z",
"provider": "osv",
"references": [
"https://github.com/FreePBX/filestore/blob/f0e3983059271efd80b483ec823310ef19a59013/drivers/SSH/testconnection.php#L2",
"https://www.cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2025-64328",
"https://www.freepbx.org/watch-what-we-do-with-security-fixes-%f0%9f%91%80",
"https://github.com/CVEProject/cvelistV5/tree/main/cves/2025/64xxx/CVE-2025-64328.json",
"https://github.com/FreePBX/security-reporting/security/advisories/GHSA-vm9p-46mv-5xvw",
"https://nvd.nist.gov/vuln/detail/CVE-2025-64328",
"https://www.fortinet.com/blog/threat-research/unveiling-the-weaponized-web-shell-encystphp"
],
"provider_metadata": {
"cwe_ids": [
"CWE-78"
],
"cna_assigner": "GitHub_M",
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2025/64xxx/CVE-2025-64328.json"
}
},
"related_cves": [
{
"value": "CVE-2025-64328",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 500930,
"published_at": "2025-11-07T03:32:20.67+00:00"
}