Apache Commons Configuration insecure interpolation defaults
Apache Commons Configuration performs variable interpolation, allowing properties to be dynamically evaluated and expanded. The standard format for interpolation is "${prefix:name}", where "prefix" is used to locate an instance of org.apache.commons.configuration2.interpol.Lookup that performs the interpolation. Starting with version 2.4 and continuing through 2.7, the set of default Lookup instances included interpolators that could result in arbitrary code execution or contact with remote servers. These lookups are: - "script" - execute expressions using the JVM script execution engine (javax.script) - "dns" - resolve dns records - "url" - load values from urls, including from remote servers Applications using the interpolation defaults in the affected versions may be vulnerable to remote code execution or unintentional contact with remote servers if untrusted configuration values are used. Users are recommended to upgrade to Apache Commons Configuration 2.8.0, which disables the problematic interpolators by default.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2022-33980
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 2 Nov 2026, 23:05 UTC · Revision 1
Source evidence
Apache Commons Configuration insecure interpolation defaults
core-osv · Original sourcePublished 6 Jul 2022, 00:00 UTC
Apache Commons Configuration performs variable interpolation, allowing properties to be dynamically evaluated and expanded. The standard format for interpolation is "${prefix:name}", where "prefix" is used to locate an instance of org.apache.commons.configuration2.interpol.Lookup that performs the interpolation. Starting with version 2.4 and continuing through 2.7, the set of default Lookup instances included interpolators that could result in arbitrary code execution or contact with remote servers. These lookups are: - "script" - execute expressions using the JVM script execution engine (javax.script) - "dns" - resolve dns records - "url" - load values from urls, including from remote servers Applications using the interpolation defaults in the affected versions may be vulnerable to remote code execution or unintentional contact with remote servers if untrusted configuration values are used. Users are recommended to upgrade to Apache Commons Configuration 2.8.0, which disables the problematic interpolators by default.
osv:CVE-2022-33980
Complete source record
{
"id": "7d758299e743a2975164dad31e31d0bda168b00a5d16f229bd03947e444a7edf",
"url": "https://osv.dev/vulnerability/CVE-2022-33980",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "Apache Commons Configuration insecure interpolation defaults",
"summary": "Apache Commons Configuration performs variable interpolation, allowing properties to be dynamically evaluated and expanded. The standard format for interpolation is \"${prefix:name}\", where \"prefix\" is used to locate an instance of org.apache.commons.configuration2.interpol.Lookup that performs the interpolation. Starting with version 2.4 and continuing through 2.7, the set of default Lookup instances included interpolators that could result in arbitrary code execution or contact with remote servers. These lookups are: - \"script\" - execute expressions using the JVM script execution engine (javax.script) - \"dns\" - resolve dns records - \"url\" - load values from urls, including from remote servers Applications using the interpolation defaults in the affected versions may be vulnerable to remote code execution or unintentional contact with remote servers if untrusted configuration values are used. Users are recommended to upgrade to Apache Commons Configuration 2.8.0, which disables the problematic interpolators by default.",
"evidence": "osv:CVE-2022-33980",
"products": [],
"severity": "unknown",
"structured": {
"id": "CVE-2022-33980",
"aliases": [
"CVE-2022-33980",
"GHSA-xj57-8qj4-c4m6"
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/apache/commons-configuration",
"type": "GIT",
"events": [
{
"introduced": "6543cb0b6c283c0d4331dc0baee269b01db00622"
},
{
"fixed": "59e5152722198526c6ffe5361de7d1a6a87275c7"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:apache:commons_configuration:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "2.4"
},
{
"fixed": "2.8"
}
],
"source": "CPE_RANGE"
}
]
}
}
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2022-33980.json"
}
}
],
"modified": "2026-10-28T02:30:24.142777474Z",
"provider": "osv",
"references": [
"https://lists.apache.org/thread/tdf5n7j80lfxdhs2764vn0xmpfodm87s",
"https://github.com/CVEProject/cvelistV5/tree/main/cves/2022/33xxx/CVE-2022-33980.json",
"https://nvd.nist.gov/vuln/detail/CVE-2022-33980",
"https://security.netapp.com/advisory/ntap-20221028-0015/",
"https://www.debian.org/security/2022/dsa-5290"
],
"provider_metadata": {
"cna_assigner": "apache",
"unresolved_ranges": [
{
"extracted_events": [
{
"range": [
{
"introduced": "Apache Commons Configuration"
},
{
"fixed": "2.8.0"
}
],
"source": "AFFECTED_FIELD",
"strategy": "StandardRange"
}
]
}
],
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2022/33xxx/CVE-2022-33980.json"
}
},
"related_cves": [
{
"value": "CVE-2022-33980",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": null
},
"source_id": "core-osv",
"document_id": 490712,
"published_at": "2022-07-06T00:00:00+00:00"
}