High
Security advisory
Magento-lts is a long-term support alternative to Magento Community Edition (CE). A vulnerability in magento-lts versions before 19.4.13 and 20.0.9 potentially allows an administrator unauthorized access to restricted resources. This is a backport of CVE-2021-21024. The vulnerability is patched in versions 19.4.13 and 20.0.9.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2021-21427
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 1 Nov 2026, 08:45 UTC · Revision 1
Source evidence
Magento-lts is a long-term support alternative to Magento Community Edition (CE). A vulnerability in magento-lts versions before 19.4.13 and 20.0.9 potentially allows an administrator unauthorized access to restricted resources. This is a backport of CVE-2021-21024. The vulnerability is patched in versions 19.4.13 and 20.0.9.
osv:CVE-2021-21427
Complete source record
{
"id": "884cc4900f79e51ffa347ca37b1fd3451aaa4d2f5b50389f06c647d129bc6b5e",
"url": "https://osv.dev/vulnerability/CVE-2021-21427",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "CVE-2021-21427",
"summary": "Magento-lts is a long-term support alternative to Magento Community Edition (CE). A vulnerability in magento-lts versions before 19.4.13 and 20.0.9 potentially allows an administrator unauthorized access to restricted resources. This is a backport of CVE-2021-21024. The vulnerability is patched in versions 19.4.13 and 20.0.9.",
"evidence": "osv:CVE-2021-21427",
"products": [],
"severity": "high",
"structured": {
"id": "CVE-2021-21427",
"aliases": [
"CVE-2021-21427",
"GHSA-fvrf-9428-527m"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/openmage/magento-lts",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "f71321b37a782bd167ef56de0c6e18e67645685d"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:openmage:magento:*:*:*:*:lts:*:*:*",
"range": [
{
"introduced": "0"
},
{
"fixed": "19.4.13"
}
],
"source": "CPE_RANGE"
}
]
}
}
],
"versions": [
"v19.4.12",
"v19.4.11",
"v19.4.10",
"v19.4.9",
"v19.4.8",
"v19.4.7",
"v19.4.6",
"v19.4.5",
"v19.4.4",
"v19.4.3",
"v19.4.2",
"v19.4.1",
"v19.4.0",
"1.9.0.1",
"1.9.1.1",
"1.9.1.0-lts",
"1.9.0.0",
"1.8.1.0",
"1.7.0.2",
"1.7.0.1",
"1.7.0.0",
"1.6.1.0",
"1.6.0.0",
"1.6.0.0-rc2",
"1.6.0.0-rc1",
"1.6.0.0-beta1",
"1.6.0.0-alpha1",
"1.5.1.0",
"1.5.0.1",
"1.5.0.0",
"1.5.0.0-rc2",
"1.5.0.0-rc1",
"1.5.0.0-beta2",
"1.5.0.0-beta1",
"1.5.0.0-alpha2",
"1.5.0.0-alpha1",
"1.4.2.0",
"1.4.1.1",
"1.4.1.0",
"1.4.0.1",
"1.3.2.4",
"1.4.0.0",
"1.4.0.0-rc1",
"1.4.0.0-beta1",
"1.4.0.0-alpha3",
"1.4.0.0-alpha2",
"1.4.0.0-alpha1",
"1.3.2.3",
"1.3.2.2",
"1.3.2.1",
"1.3.2",
"1.3.1.1",
"1.3.1",
"1.3.0",
"1.2.1.2",
"1.2.1",
"1.2.0.3",
"1.2.0.2",
"1.2.0.1",
"1.2.0",
"1.1.8",
"1.1.7",
"1.1.6",
"1.1.5",
"1.1.4",
"1.1.3",
"1.1.2",
"1.1.1"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2021-21427.json"
}
}
],
"modified": "2026-10-24T10:50:04.351279285Z",
"provider": "osv",
"references": [
"https://github.com/OpenMage/magento-lts/security/advisories/GHSA-fvrf-9428-527m"
],
"provider_metadata": {
"unresolved_ranges": [
{
"cpes": [
"cpe:2.3:a:openmage:magento:*:*:*:*:lts:*:*:*"
],
"vendor_product": "openmage:magento",
"extracted_events": [
{
"range": [
{
"fixed": "19.4.13"
},
{
"introduced": "20.0.0"
},
{
"fixed": "20.0.9"
},
{
"introduced": "20.0.0"
},
{
"fixed": "20.0.9"
}
],
"source": "CPE_RANGE"
}
]
}
]
}
},
"related_cves": [
{
"value": "CVE-2021-21427",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 441927,
"published_at": "2021-04-21T21:15:08.007+00:00"
}