Skip to content
Heist/ feed
Back to feed
Medium

Security advisory

Type: advisorySources: OSVCVE: CVE-2018-20153

In WordPress before 4.9.9 and 5.x before 5.0.1, contributors could modify new comments made by users with greater privileges, possibly causing XSS.

Products
Not specified
Affected versions
Not specified
Fixed versions
Not specified
CVEs
CVE-2018-20153
Confirmed fixed CVEs
Not specified
Updated in this feed
1 Nov 2026, 07:19 UTC · Revision 1

Source evidence

CVE-2018-20153

core-osv · Original source

Published 14 Dec 2018, 20:29 UTC

In WordPress before 4.9.9 and 5.x before 5.0.1, contributors could modify new comments made by users with greater privileges, possibly causing XSS.

osv:CVE-2018-20153
Complete source record
{
  "id": "b2166021603ea89931a0b059477c0b151c5397155a2fc89f3ae555a7271d5c25",
  "url": "https://osv.dev/vulnerability/CVE-2018-20153",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "CVE-2018-20153",
    "summary": "In WordPress before 4.9.9 and 5.x before 5.0.1, contributors could modify new comments made by users with greater privileges, possibly causing XSS.",
    "evidence": "osv:CVE-2018-20153",
    "products": [],
    "severity": "medium",
    "structured": {
      "id": "CVE-2018-20153",
      "aliases": [
        "CVE-2018-20153"
      ],
      "metrics": [
        {
          "type": "CVSS_V3",
          "score": "CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N"
        }
      ],
      "affected": [
        {
          "ranges": [
            {
              "repo": "https://github.com/wordpress/wordpress",
              "type": "GIT",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "8d87e4a8b8aa7d66a4f5dd3795b5450fa0b76af0"
                },
                {
                  "introduced": "491c67be12ca8a9fe37ae38307ba7e298c976ec3"
                },
                {
                  "fixed": "3d448538caf519c6355bb32c0c8c21da87692855"
                }
              ],
              "database_specific": {
                "extracted_events": [
                  {
                    "cpe": "cpe:2.3:a:wordpress:wordpress:*:*:*:*:*:*:*:*",
                    "range": [
                      {
                        "introduced": "0"
                      },
                      {
                        "fixed": "4.9.9"
                      }
                    ],
                    "source": "CPE_RANGE"
                  },
                  {
                    "cpe": "cpe:2.3:a:wordpress:wordpress:*:*:*:*:*:*:*:*",
                    "range": [
                      {
                        "introduced": "5.0"
                      },
                      {
                        "fixed": "5.0.1"
                      }
                    ],
                    "source": "CPE_RANGE"
                  }
                ]
              }
            }
          ],
          "versions": [
            "4.9.8"
          ],
          "database_specific": {
            "source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2018-20153.json"
          }
        },
        {
          "ranges": [
            {
              "repo": "https://github.com/wordpress/wordpress-develop",
              "type": "GIT",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "a9ad836e97a736741122210792c64a6b2ed053ba"
                },
                {
                  "introduced": "b3bf6266acd61682bc654845f621b4426645e324"
                },
                {
                  "fixed": "53a3a5792edc4a55cbc81ebf084db08b93398f80"
                }
              ],
              "database_specific": {
                "extracted_events": [
                  {
                    "cpe": "cpe:2.3:a:wordpress:wordpress:*:*:*:*:*:*:*:*",
                    "range": [
                      {
                        "introduced": "0"
                      },
                      {
                        "fixed": "4.9.9"
                      }
                    ],
                    "source": "CPE_RANGE"
                  },
                  {
                    "cpe": "cpe:2.3:a:wordpress:wordpress:*:*:*:*:*:*:*:*",
                    "range": [
                      {
                        "introduced": "5.0"
                      },
                      {
                        "fixed": "5.0.1"
                      }
                    ],
                    "source": "CPE_RANGE"
                  }
                ]
              }
            }
          ],
          "versions": [
            "4.9.8"
          ],
          "database_specific": {
            "source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2018-20153.json"
          }
        }
      ],
      "modified": "2026-10-24T10:30:51.714600012Z",
      "provider": "osv",
      "references": [
        "https://codex.wordpress.org/Version_4.9.9",
        "https://lists.debian.org/debian-lts-announce/2019/02/msg00019.html",
        "https://wordpress.org/news/2018/12/wordpress-5-0-1-security-release/",
        "https://wordpress.org/support/wordpress-version/version-5-0-1/",
        "https://wpvulndb.com/vulnerabilities/9172",
        "https://www.debian.org/security/2019/dsa-4401",
        "https://www.zdnet.com/article/wordpress-plugs-bug-that-led-to-google-indexing-some-user-passwords/"
      ],
      "provider_metadata": {
        "unresolved_ranges": [
          {
            "cpes": [
              "cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:*",
              "cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:*"
            ],
            "vendor_product": "debian:debian_linux",
            "extracted_events": [
              {
                "range": [
                  {
                    "introduced": "8.0"
                  },
                  {
                    "last_affected": "8.0"
                  },
                  {
                    "introduced": "9.0"
                  },
                  {
                    "last_affected": "9.0"
                  }
                ],
                "source": "CPE_STRING"
              }
            ]
          }
        ]
      }
    },
    "related_cves": [
      {
        "value": "CVE-2018-20153",
        "evidence": "/id"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/severity/0/score"
  },
  "source_id": "core-osv",
  "document_id": 437542,
  "published_at": "2018-12-14T20:29:00.593+00:00"
}