Medium
Google Tag Manager for WordPress <= 1.15 - Reflected Cross-Site Scripting via Site Search
Type: advisorySources: OSV
The Google Tag Manager for WordPress plugin for WordPress is vulnerable to reflected Cross-Site Scripting via the s parameter due to the site search populating into the data layer of sites with insufficient sanitization in versions up to an including 1.15. The affected file is ~/public/frontend.php and this could be exploited by unauthenticated attackers.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2022-1707
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 4 Nov 2026, 15:34 UTC · Revision 1
Source evidence
Google Tag Manager for WordPress <= 1.15 - Reflected Cross-Site Scripting via Site Search
core-osv · Original sourcePublished 13 Jun 2022, 12:45 UTC
The Google Tag Manager for WordPress plugin for WordPress is vulnerable to reflected Cross-Site Scripting via the s parameter due to the site search populating into the data layer of sites with insufficient sanitization in versions up to an including 1.15. The affected file is ~/public/frontend.php and this could be exploited by unauthenticated attackers.
osv:CVE-2022-1707
Complete source record
{
"id": "d9a8a003e4b4caf077096237b98c92c48af454d01cd49f934056a44d37970747",
"url": "https://osv.dev/vulnerability/CVE-2022-1707",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "Google Tag Manager for WordPress <= 1.15 - Reflected Cross-Site Scripting via Site Search",
"summary": "The Google Tag Manager for WordPress plugin for WordPress is vulnerable to reflected Cross-Site Scripting via the s parameter due to the site search populating into the data layer of sites with insufficient sanitization in versions up to an including 1.15. The affected file is ~/public/frontend.php and this could be exploited by unauthenticated attackers.",
"evidence": "osv:CVE-2022-1707",
"products": [],
"severity": "medium",
"structured": {
"id": "CVE-2022-1707",
"aliases": [
"CVE-2022-1707"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/duracelltomi/gtm4wp",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "de15527c94af603cc6646b2ef9a36e2519401a37"
}
],
"database_specific": {
"extracted_events": [
{
"range": [
{
"introduced": "0"
},
{
"last_affected": "1.15"
}
],
"source": "AFFECTED_FIELD",
"strategy": "StandardRange"
},
{
"cpe": "cpe:2.3:a:gtm4wp:google_tag_manager:*:*:*:*:*:wordpress:*:*",
"range": [
{
"introduced": "0"
},
{
"fixed": "1.15.1"
}
],
"source": "CPE_RANGE"
}
]
}
}
],
"versions": [
"1.15",
"1.15beta2",
"1.15beta1",
"1.14.2",
"1.14.1",
"1.14",
"1.14beta3",
"1.14beta2",
"1.14beta1",
"1.13.1",
"1.13",
"v1.13beta1",
"1.12.2",
"1.12.1",
"1.12",
"1.12beta1",
"1.11.4",
"1.11.3",
"1.11",
"1.11beta2",
"1.11beta1",
"1.10.1",
"1.10",
"1.10beta1",
"1.9.2",
"1.9.1",
"1.9.1beta",
"1.9",
"1.9beta1",
"1.8.1",
"1.8.1beta2",
"1.8.1beta",
"1.8",
"1.8beta1",
"1.7.2",
"1.7.1",
"1.7",
"1.7rc2",
"1.7rc1",
"1.7beta3",
"1.7beta2",
"v1.7beta1",
"1.6.1",
"1.6.0",
"1.6.0rc",
"1.5.0",
"1.5.0rc",
"1.4.0"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2022-1707.json"
}
}
],
"modified": "2026-10-28T02:30:37.083595352Z",
"provider": "osv",
"references": [
"https://github.com/duracelltomi/gtm4wp/blob/1.15/public/frontend.php#L298",
"https://github.com/duracelltomi/gtm4wp/blob/1.15/public/frontend.php#L782",
"https://www.wordfence.com/threat-intel/vulnerabilities/id/0435ae14-c1fd-4611-acbe-5f3bafd4bb6a?source=cve",
"https://github.com/CVEProject/cvelistV5/tree/main/cves/2022/1xxx/CVE-2022-1707.json",
"https://nvd.nist.gov/vuln/detail/CVE-2022-1707",
"https://www.wordfence.com/vulnerability-advisories/#CVE-2022-1707",
"https://github.com/duracelltomi/gtm4wp/issues/224"
],
"provider_metadata": {
"cwe_ids": [
"CWE-79"
],
"cna_assigner": "Wordfence",
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2022/1xxx/CVE-2022-1707.json"
}
},
"related_cves": [
{
"value": "CVE-2022-1707",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 504178,
"published_at": "2022-06-13T12:45:36+00:00"
}