Apache Tomcat: Servlet role references can bypass declarative role constraints
Improper Authorization vulnerability in Apache Tomcat cause by security-role-ref definitions being incorrectly used as role aliases within the Realm in additional to the correct usage with Request.isUserInRole(). This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.24, from 10.1.0-M1 through 10.1.57, from 9.0.25 through 9.0.120. The following versions were EOL at the time the CVE was created but are known to be affected: from 8.5.46 through 8.5.100, from 7.0.97 through 7.0.109. Other unsupported versions may also be affected. Users are recommended to upgrade to version 11.0.25, 10.1.58 or 9.0.121, which fix the issue.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2026-66422
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 7 Nov 2026, 03:19 UTC · Revision 1
Source evidence
Apache Tomcat: Servlet role references can bypass declarative role constraints
core-osv · Original sourcePublished 25 Aug 2026, 21:55 UTC
Improper Authorization vulnerability in Apache Tomcat cause by security-role-ref definitions being incorrectly used as role aliases within the Realm in additional to the correct usage with Request.isUserInRole(). This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.24, from 10.1.0-M1 through 10.1.57, from 9.0.25 through 9.0.120. The following versions were EOL at the time the CVE was created but are known to be affected: from 8.5.46 through 8.5.100, from 7.0.97 through 7.0.109. Other unsupported versions may also be affected. Users are recommended to upgrade to version 11.0.25, 10.1.58 or 9.0.121, which fix the issue.
osv:CVE-2026-66422
Complete source record
{
"id": "b5e07967c86bcbb3327b627d09753a5ab94c7973d17acea2bf74890f1a176b3b",
"url": "https://osv.dev/vulnerability/CVE-2026-66422",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "Apache Tomcat: Servlet role references can bypass declarative role constraints",
"summary": "Improper Authorization vulnerability in Apache Tomcat cause by security-role-ref definitions being incorrectly used as role aliases within the Realm in additional to the correct usage with Request.isUserInRole(). This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.24, from 10.1.0-M1 through 10.1.57, from 9.0.25 through 9.0.120. The following versions were EOL at the time the CVE was created but are known to be affected: from 8.5.46 through 8.5.100, from 7.0.97 through 7.0.109. Other unsupported versions may also be affected. Users are recommended to upgrade to version 11.0.25, 10.1.58 or 9.0.121, which fix the issue.",
"evidence": "osv:CVE-2026-66422",
"products": [],
"severity": "high",
"structured": {
"id": "CVE-2026-66422",
"aliases": [
"BIT-tomcat-2026-66422",
"CVE-2026-66422"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:H"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/apache/tomcat",
"type": "GIT",
"events": [
{
"introduced": "1cfec207b09fed52965f0d0426059ca989daf3b4"
},
{
"last_affected": "2cdef2c0241cdf70b5edd88d3733a52e6b675047"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:apache:tomcat:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "7.0.97"
},
{
"last_affected": "7.0.109"
}
],
"source": "CPE_RANGE"
}
]
}
}
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2026-66422.json"
}
}
],
"modified": "2026-10-28T02:30:49.338276834Z",
"provider": "osv",
"references": [
"https://github.com/CVEProject/cvelistV5/tree/main/cves/2026/66xxx/CVE-2026-66422.json",
"https://lists.apache.org/thread/j5plylz1b2vhqvbkqn7k58nygxhcpk73",
"https://nvd.nist.gov/vuln/detail/CVE-2026-66422"
],
"provider_metadata": {
"cwe_ids": [
"CWE-285"
],
"cna_assigner": "apache",
"unresolved_ranges": [
{
"extracted_events": [
{
"range": [
{
"introduced": "11.0.0-M1"
},
{
"last_affected": "11.0.24"
},
{
"introduced": "10.1.0-M1"
},
{
"last_affected": "10.1.57"
},
{
"introduced": "9.0.25"
},
{
"last_affected": "9.0.120"
},
{
"introduced": "8.5.46"
},
{
"last_affected": "8.5.100"
},
{
"introduced": "7.0.97"
},
{
"last_affected": "7.0.109"
}
],
"source": "AFFECTED_FIELD",
"strategy": "StandardRange"
}
]
}
],
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2026/66xxx/CVE-2026-66422.json"
}
},
"related_cves": [
{
"value": "CVE-2026-66422",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 517693,
"published_at": "2026-08-25T21:55:16.928+00:00"
}