uap-core — security advisory
uap-core in an open-source npm package which contains the core of BrowserScope's original user agent string parser. In uap-core before version 0.11.0, some regexes are vulnerable to regular expression denial of service (REDoS) due to overlapping capture groups. This allows remote attackers to overload a server by setting the User-Agent header in an HTTP(S) request to maliciously crafted long strings. This is fixed in version 0.11.0. Downstream packages such as uap-python, uap-ruby etc which depend upon uap-core follow different version schemes.
- Products
- uap-core
- Affected versions
- 1:0.12.0-1, 1:0.13.0-1, 1:0.14.0-1, 1:0.15.0-1, 1:0.18.0-1, 1:0.18.0-1build1, 20190213-2
- Fixed versions
- Not specified
- CVEs
- CVE-2021-21317
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 31 Oct 2026, 00:58 UTC · Revision 1
Source evidence
uap-core in an open-source npm package which contains the core of BrowserScope's original user agent string parser. In uap-core before version 0.11.0, some regexes are vulnerable to regular expression denial of service (REDoS) due to overlapping capture groups. This allows remote attackers to overload a server by setting the User-Agent header in an HTTP(S) request to maliciously crafted long strings. This is fixed in version 0.11.0. Downstream packages such as uap-python, uap-ruby etc which depend upon uap-core follow different version schemes.
osv:UBUNTU-CVE-2021-21317
uap-core
Fixed versions: Not specified
uap-core
Fixed versions: Not specified
uap-core
Fixed versions: Not specified
uap-core
Fixed versions: Not specified
uap-core
Fixed versions: Not specified
uap-core
Fixed versions: Not specified
Complete source record
{
"id": "1628bfecd70c93ff36152432010a668692240ab714d6b2ab9d685c8c95d6c279",
"url": "https://osv.dev/vulnerability/UBUNTU-CVE-2021-21317",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "UBUNTU-CVE-2021-21317",
"summary": "uap-core in an open-source npm package which contains the core of BrowserScope's original user agent string parser. In uap-core before version 0.11.0, some regexes are vulnerable to regular expression denial of service (REDoS) due to overlapping capture groups. This allows remote attackers to overload a server by setting the User-Agent header in an HTTP(S) request to maliciously crafted long strings. This is fixed in version 0.11.0. Downstream packages such as uap-python, uap-ruby etc which depend upon uap-core follow different version schemes.",
"evidence": "osv:UBUNTU-CVE-2021-21317",
"products": [
{
"name": {
"value": "uap-core",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [],
"affected_versions": [
{
"value": "20190213-2",
"evidence": "/affected/0/versions"
}
]
},
{
"name": {
"value": "uap-core",
"evidence": "/affected/1/package/name"
},
"prerequisites": [],
"fixed_versions": [],
"affected_versions": [
{
"value": "1:0.12.0-1",
"evidence": "/affected/1/versions"
},
{
"value": "1:0.13.0-1",
"evidence": "/affected/1/versions"
},
{
"value": "1:0.14.0-1",
"evidence": "/affected/1/versions"
},
{
"value": "1:0.15.0-1",
"evidence": "/affected/1/versions"
}
]
},
{
"name": {
"value": "uap-core",
"evidence": "/affected/2/package/name"
},
"prerequisites": [],
"fixed_versions": [],
"affected_versions": [
{
"value": "1:0.18.0-1",
"evidence": "/affected/2/versions"
}
]
},
{
"name": {
"value": "uap-core",
"evidence": "/affected/3/package/name"
},
"prerequisites": [],
"fixed_versions": [],
"affected_versions": [
{
"value": "1:0.18.0-1",
"evidence": "/affected/3/versions"
}
]
},
{
"name": {
"value": "uap-core",
"evidence": "/affected/4/package/name"
},
"prerequisites": [],
"fixed_versions": [],
"affected_versions": [
{
"value": "1:0.18.0-1build1",
"evidence": "/affected/4/versions"
}
]
},
{
"name": {
"value": "uap-core",
"evidence": "/affected/5/package/name"
},
"prerequisites": [],
"fixed_versions": [],
"affected_versions": [
{
"value": "1:0.18.0-1",
"evidence": "/affected/5/versions"
},
{
"value": "1:0.18.0-1build1",
"evidence": "/affected/5/versions"
}
]
}
],
"severity": "medium",
"structured": {
"id": "UBUNTU-CVE-2021-21317",
"aliases": [
"UBUNTU-CVE-2021-21317"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L"
},
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L"
},
{
"type": "Ubuntu",
"score": "medium"
}
],
"affected": [
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
}
]
}
],
"package": {
"name": "uap-core",
"purl": "pkg:deb/ubuntu/uap-core?arch=source&distro=focal",
"ecosystem": "Ubuntu:20.04:LTS"
},
"versions": [
"20190213-2"
],
"database_specific": {
"source": "https://github.com/canonical/ubuntu-security-notices/blob/main/osv/cve/2021/UBUNTU-CVE-2021-21317.json"
},
"ecosystem_specific": {
"binaries": [
{
"binary_name": "uap-core",
"binary_version": "20190213-2"
}
]
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
}
]
}
],
"package": {
"name": "uap-core",
"purl": "pkg:deb/ubuntu/uap-core?arch=source&distro=jammy",
"ecosystem": "Ubuntu:22.04:LTS"
},
"versions": [
"1:0.12.0-1",
"1:0.13.0-1",
"1:0.14.0-1",
"1:0.15.0-1"
],
"database_specific": {
"source": "https://github.com/canonical/ubuntu-security-notices/blob/main/osv/cve/2021/UBUNTU-CVE-2021-21317.json"
},
"ecosystem_specific": {
"binaries": [
{
"binary_name": "uap-core",
"binary_version": "1:0.15.0-1"
}
]
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
}
]
}
],
"package": {
"name": "uap-core",
"purl": "pkg:deb/ubuntu/uap-core?arch=source&distro=noble",
"ecosystem": "Ubuntu:24.04:LTS"
},
"versions": [
"1:0.18.0-1"
],
"database_specific": {
"source": "https://github.com/canonical/ubuntu-security-notices/blob/main/osv/cve/2021/UBUNTU-CVE-2021-21317.json"
},
"ecosystem_specific": {
"binaries": [
{
"binary_name": "uap-core",
"binary_version": "1:0.18.0-1"
}
]
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
}
]
}
],
"package": {
"name": "uap-core",
"purl": "pkg:deb/ubuntu/uap-core?arch=source&distro=questing",
"ecosystem": "Ubuntu:25.10"
},
"versions": [
"1:0.18.0-1"
],
"database_specific": {
"source": "https://github.com/canonical/ubuntu-security-notices/blob/main/osv/cve/2021/UBUNTU-CVE-2021-21317.json"
},
"ecosystem_specific": {
"binaries": [
{
"binary_name": "uap-core",
"binary_version": "1:0.18.0-1"
}
]
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
}
]
}
],
"package": {
"name": "uap-core",
"purl": "pkg:deb/ubuntu/uap-core?arch=source&distro=stonking",
"ecosystem": "Ubuntu:26.10"
},
"versions": [
"1:0.18.0-1build1"
],
"database_specific": {
"source": "https://github.com/canonical/ubuntu-security-notices/blob/main/osv/cve/2021/UBUNTU-CVE-2021-21317.json"
},
"ecosystem_specific": {
"binaries": [
{
"binary_name": "uap-core",
"binary_version": "1:0.18.0-1build1"
}
]
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
}
]
}
],
"package": {
"name": "uap-core",
"purl": "pkg:deb/ubuntu/uap-core?arch=source&distro=resolute",
"ecosystem": "Ubuntu:26.04:LTS"
},
"versions": [
"1:0.18.0-1",
"1:0.18.0-1build1"
],
"database_specific": {
"source": "https://github.com/canonical/ubuntu-security-notices/blob/main/osv/cve/2021/UBUNTU-CVE-2021-21317.json"
},
"ecosystem_specific": {
"binaries": [
{
"binary_name": "uap-core",
"binary_version": "1:0.18.0-1build1"
}
]
}
}
],
"modified": "2026-10-17T12:56:19.365755430Z",
"provider": "osv",
"upstream": [
"CVE-2021-21317"
],
"references": [
"https://ubuntu.com/security/CVE-2021-21317",
"https://github.com/ua-parser/uap-core/security/advisories/GHSA-p4pj-mg4r-x6v4",
"https://www.npmjs.com/package/uap-core",
"https://www.cve.org/CVERecord?id=CVE-2021-21317"
]
},
"related_cves": [
{
"value": "CVE-2021-21317",
"evidence": "/upstream"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 355258,
"published_at": "2021-02-16T18:15:00+00:00"
}