rust-russh — security advisory
Russh is a Rust SSH client & server library. Prior to version 0.60.1, a pre-authentication denial-of-service vulnerability exists in the server's keyboard-interactive authentication handler. A malicious client can crash any russh-based server that implements keyboard-interactive auth (e.g., for 2FA/TOTP) with a single malformed packet, requiring no credentials. This issue has been patched in version 0.60.1.
- Products
- rust-russh
- Affected versions
- 0.57.1-2
- Fixed versions
- Not specified
- CVEs
- CVE-2026-42189
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 31 Oct 2026, 02:44 UTC · Revision 1
Source evidence
Russh is a Rust SSH client & server library. Prior to version 0.60.1, a pre-authentication denial-of-service vulnerability exists in the server's keyboard-interactive authentication handler. A malicious client can crash any russh-based server that implements keyboard-interactive auth (e.g., for 2FA/TOTP) with a single malformed packet, requiring no credentials. This issue has been patched in version 0.60.1.
osv:UBUNTU-CVE-2026-42189
rust-russh
Fixed versions: Not specified
Complete source record
{
"id": "311138b0613551ce8b5c96b64d8e3686672c55a5a3e6b563ca527f13800d5f32",
"url": "https://osv.dev/vulnerability/UBUNTU-CVE-2026-42189",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "UBUNTU-CVE-2026-42189",
"summary": "Russh is a Rust SSH client & server library. Prior to version 0.60.1, a pre-authentication denial-of-service vulnerability exists in the server's keyboard-interactive authentication handler. A malicious client can crash any russh-based server that implements keyboard-interactive auth (e.g., for 2FA/TOTP) with a single malformed packet, requiring no credentials. This issue has been patched in version 0.60.1.",
"evidence": "osv:UBUNTU-CVE-2026-42189",
"products": [
{
"name": {
"value": "rust-russh",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [],
"affected_versions": [
{
"value": "0.57.1-2",
"evidence": "/affected/0/versions"
}
]
}
],
"severity": "high",
"structured": {
"id": "UBUNTU-CVE-2026-42189",
"aliases": [
"UBUNTU-CVE-2026-42189"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H"
},
{
"type": "Ubuntu",
"score": "medium"
}
],
"affected": [
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
}
]
}
],
"package": {
"name": "rust-russh",
"purl": "pkg:deb/ubuntu/rust-russh?arch=source&distro=stonking",
"ecosystem": "Ubuntu:26.10"
},
"versions": [
"0.57.1-2"
],
"database_specific": {
"source": "https://github.com/canonical/ubuntu-security-notices/blob/main/osv/cve/2026/UBUNTU-CVE-2026-42189.json"
},
"ecosystem_specific": {
"binaries": [
{
"binary_name": "librust-russh-dev",
"binary_version": "0.57.1-2"
}
]
}
}
],
"modified": "2026-10-17T12:58:54.478942575Z",
"provider": "osv",
"upstream": [
"CVE-2026-42189"
],
"references": [
"https://ubuntu.com/security/CVE-2026-42189",
"https://www.cve.org/CVERecord?id=CVE-2026-42189",
"https://github.com/Eugeny/russh/security/advisories/GHSA-f5v4-2wr6-hqmg"
]
},
"related_cves": [
{
"value": "CVE-2026-42189",
"evidence": "/upstream"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 359162,
"published_at": "2026-05-08T20:16:00+00:00"
}