Medium
GLPI Inventory Plugin vulnerable to reflective Cross-site Scripting
Type: advisorySources: OSV
The GLPI Inventory Plugin handles various types of tasks for GLPI agents for the GLPI asset and IT management software package. Versions prior to 1.5.0 are vulnerable to reflective cross-site scripting, which may lead to executing javascript code. Version 1.5.0 fixes the issue.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2025-26626
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 2 Nov 2026, 22:26 UTC · Revision 1
Source evidence
GLPI Inventory Plugin vulnerable to reflective Cross-site Scripting
core-osv · Original sourcePublished 14 Mar 2025, 12:47 UTC
The GLPI Inventory Plugin handles various types of tasks for GLPI agents for the GLPI asset and IT management software package. Versions prior to 1.5.0 are vulnerable to reflective cross-site scripting, which may lead to executing javascript code. Version 1.5.0 fixes the issue.
osv:CVE-2025-26626
Complete source record
{
"id": "b34b11b58f78d0161cafc70f07d3fc49563a7987762fae219741fe7feb3d433d",
"url": "https://osv.dev/vulnerability/CVE-2025-26626",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "GLPI Inventory Plugin vulnerable to reflective Cross-site Scripting",
"summary": "The GLPI Inventory Plugin handles various types of tasks for GLPI agents for the GLPI asset and IT management software package. Versions prior to 1.5.0 are vulnerable to reflective cross-site scripting, which may lead to executing javascript code. Version 1.5.0 fixes the issue.",
"evidence": "osv:CVE-2025-26626",
"products": [],
"severity": "medium",
"structured": {
"id": "CVE-2025-26626",
"aliases": [
"CVE-2025-26626",
"GHSA-8p38-r7vf-j6jx"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:N"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/glpi-project/glpi-inventory-plugin",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "100292d0f7d48a0befe5ba04177c0804fe173b61"
}
],
"database_specific": {
"extracted_events": [
{
"range": [
{
"introduced": "0"
},
{
"fixed": "1.5.0"
}
],
"source": "AFFECTED_FIELD",
"strategy": "StringRangeExpression"
},
{
"range": [
{
"introduced": "0"
},
{
"fixed": "1.5.0"
}
],
"source": "DESCRIPTION"
}
]
}
}
],
"versions": [
"1.4.0",
"1.3.5",
"1.3.4",
"1.3.3",
"1.3.2",
"1.3.1",
"1.3.0",
"1.2.3",
"1.2.2",
"1.2.1",
"1.2.0",
"1.1.0",
"1.0.6",
"1.0.5",
"1.0.4",
"1.0.3",
"1.0.2",
"1.0.1",
"1.0.0"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2025-26626.json"
}
}
],
"modified": "2026-10-28T02:30:24.046948429Z",
"provider": "osv",
"references": [
"https://github.com/glpi-project/glpi-inventory-plugin/blob/1.5.0/CHANGELOG.md#150---2025-02-25",
"https://github.com/CVEProject/cvelistV5/tree/main/cves/2025/26xxx/CVE-2025-26626.json",
"https://github.com/glpi-project/glpi-inventory-plugin/security/advisories/GHSA-8p38-r7vf-j6jx",
"https://nvd.nist.gov/vuln/detail/CVE-2025-26626"
],
"provider_metadata": {
"cwe_ids": [
"CWE-79"
],
"cna_assigner": "GitHub_M",
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2025/26xxx/CVE-2025-26626.json"
}
},
"related_cves": [
{
"value": "CVE-2025-26626",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 490485,
"published_at": "2025-03-14T12:47:14.011+00:00"
}