OpenFGA Authorization Bypass
OpenFGA is an authorization/permission engine. OpenFGA versions 1.8.0 through 1.8.12 (corresponding to Helm chart openfga-0.2.16 through openfga-0.2.30 and docker 1.8.0 through 1.8.12) are vulnerable to authorization bypass when certain Check and ListObject calls are executed. Users are affected under four specific conditions: First, calling Check API or ListObjects with an authorization model that has a relationship directly assignable by both type bound public access and userset; second, there are check or list object queries with contextual tuples for the relationship that can be directly assignable by both type bound public access and userset; third, those contextual tuples’s user field is an userset; and finally, type bound public access tuples are not assigned to the relationship. Users should upgrade to version 1.8.13 to receive a patch. The upgrade is backwards compatible.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2025-48371
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 6 Nov 2026, 00:16 UTC · Revision 1
Source evidence
OpenFGA is an authorization/permission engine. OpenFGA versions 1.8.0 through 1.8.12 (corresponding to Helm chart openfga-0.2.16 through openfga-0.2.30 and docker 1.8.0 through 1.8.12) are vulnerable to authorization bypass when certain Check and ListObject calls are executed. Users are affected under four specific conditions: First, calling Check API or ListObjects with an authorization model that has a relationship directly assignable by both type bound public access and userset; second, there are check or list object queries with contextual tuples for the relationship that can be directly assignable by both type bound public access and userset; third, those contextual tuples’s user field is an userset; and finally, type bound public access tuples are not assigned to the relationship. Users should upgrade to version 1.8.13 to receive a patch. The upgrade is backwards compatible.
osv:CVE-2025-48371
Complete source record
{
"id": "89b29fd0d08e6bc2050986690fe97662ae373060b213c4a4f484b22b0ed34564",
"url": "https://osv.dev/vulnerability/CVE-2025-48371",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "OpenFGA Authorization Bypass",
"summary": "OpenFGA is an authorization/permission engine. OpenFGA versions 1.8.0 through 1.8.12 (corresponding to Helm chart openfga-0.2.16 through openfga-0.2.30 and docker 1.8.0 through 1.8.12) are vulnerable to authorization bypass when certain Check and ListObject calls are executed. Users are affected under four specific conditions: First, calling Check API or ListObjects with an authorization model that has a relationship directly assignable by both type bound public access and userset; second, there are check or list object queries with contextual tuples for the relationship that can be directly assignable by both type bound public access and userset; third, those contextual tuples’s user field is an userset; and finally, type bound public access tuples are not assigned to the relationship. Users should upgrade to version 1.8.13 to receive a patch. The upgrade is backwards compatible.",
"evidence": "osv:CVE-2025-48371",
"products": [],
"severity": "medium",
"structured": {
"id": "CVE-2025-48371",
"aliases": [
"CVE-2025-48371",
"GHSA-c72g-53hw-82q7",
"GO-2025-3707"
],
"metrics": [
{
"type": "CVSS_V4",
"score": "CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:N/VI:N/VA:N/SC:H/SI:H/SA:H"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/openfga/helm-charts",
"type": "GIT",
"events": [
{
"introduced": "e55f0301b06433e61335e68e083dbbc07276a793"
},
{
"fixed": "2e15dee5c11d3e502a8669490e517cac6e507c10"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:openfga:helm_charts:*:*:*:*:*:openfga:*:*",
"range": [
{
"introduced": "0.2.16"
},
{
"fixed": "0.2.32"
}
],
"source": "CPE_RANGE"
}
]
}
},
{
"repo": "https://github.com/openfga/openfga",
"type": "GIT",
"events": [
{
"introduced": "0cc569ff4edcfda1f949316dae1e244c5be5e963"
},
{
"fixed": "e5960d4eba92b723de8ff3a5346a07f50c1379ca"
}
],
"database_specific": {
"extracted_events": [
{
"range": [
{
"introduced": "1.8.0"
},
{
"fixed": "1.8.13"
}
],
"source": "AFFECTED_FIELD",
"strategy": "StringRangeExpression"
},
{
"range": [
{
"fixed": "e5960d4eba92b723de8ff3a5346a07f50c1379ca"
}
],
"source": "REFERENCES_COMMIT"
},
{
"cpe": "cpe:2.3:a:openfga:openfga:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "1.8.0"
},
{
"fixed": "1.8.13"
}
],
"source": "CPE_RANGE"
}
]
}
}
],
"versions": [
"openfga-0.2.31",
"openfga-0.2.30",
"openfga-0.2.29",
"openfga-0.2.28",
"openfga-0.2.27",
"openfga-0.2.26",
"openfga-0.2.25",
"openfga-0.2.24",
"openfga-0.2.23",
"openfga-0.2.22",
"openfga-0.2.21",
"openfga-0.2.20",
"openfga-0.2.19",
"openfga-0.2.18",
"openfga-0.2.17",
"openfga-0.2.16",
"v1.8.12",
"v1.8.11",
"v1.8.10",
"v1.8.9",
"v1.8.8",
"v1.8.7",
"v1.8.6",
"v1.8.5",
"v1.8.4",
"v1.8.3",
"v1.8.2",
"v1.8.1",
"v1.8.0"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2025-48371.json"
}
}
],
"modified": "2026-10-28T02:30:45.261190866Z",
"provider": "osv",
"references": [
"https://github.com/CVEProject/cvelistV5/tree/main/cves/2025/48xxx/CVE-2025-48371.json",
"https://github.com/openfga/openfga/security/advisories/GHSA-c72g-53hw-82q7",
"https://nvd.nist.gov/vuln/detail/CVE-2025-48371",
"https://github.com/openfga/openfga/commit/e5960d4eba92b723de8ff3a5346a07f50c1379ca"
],
"provider_metadata": {
"cwe_ids": [
"CWE-285"
],
"cna_assigner": "GitHub_M",
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2025/48xxx/CVE-2025-48371.json"
}
},
"related_cves": [
{
"value": "CVE-2025-48371",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 513400,
"published_at": "2025-05-22T22:20:37.57+00:00"
}