Security advisory
Shopware is an open source eCommerce platform. Versions prior to 6.3.5.1 may leak of information via Store-API. The vulnerability could only be fixed by changing the API system, which involves a non-backward-compatible change. Only consumers of the Store-API should be affected by this change. We recommend to update to the current version 6.3.5.1. You can get the update to 6.3.5.1 regularly via the Auto-Updater or directly via the download overview. https://www.shopware.com/en/download/#shopware-6 The vulnerability could only be fixed by changing the API system, which involves a non-backward-compatible change. Only consumers of the Store-API should be affected by this change. Please check your plugins if you have it in use. Detailed technical information can be found in the upgrade information. https://github.com/shopware/platform/blob/v6.3.5.1/UPGRADE-6.3.md#6351 ### Workarounds For older versions of 6.1 and 6.2, corresponding security measures are also available via a plugin. For the full range of functions, we recommend updating to the latest Shopware version. https://store.shopware.com/en/detail/index/sArticle/518463/number/Swag136939272659 ### For more information https://docs.shopware.com/en/shopware-6-en/security-updates/security-update-02-2021
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2021-32711
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 31 Oct 2026, 11:46 UTC · Revision 1
Source evidence
Shopware is an open source eCommerce platform. Versions prior to 6.3.5.1 may leak of information via Store-API. The vulnerability could only be fixed by changing the API system, which involves a non-backward-compatible change. Only consumers of the Store-API should be affected by this change. We recommend to update to the current version 6.3.5.1. You can get the update to 6.3.5.1 regularly via the Auto-Updater or directly via the download overview. https://www.shopware.com/en/download/#shopware-6 The vulnerability could only be fixed by changing the API system, which involves a non-backward-compatible change. Only consumers of the Store-API should be affected by this change. Please check your plugins if you have it in use. Detailed technical information can be found in the upgrade information. https://github.com/shopware/platform/blob/v6.3.5.1/UPGRADE-6.3.md#6351 ### Workarounds For older versions of 6.1 and 6.2, corresponding security measures are also available via a plugin. For the full range of functions, we recommend updating to the latest Shopware version. https://store.shopware.com/en/detail/index/sArticle/518463/number/Swag136939272659 ### For more information https://docs.shopware.com/en/shopware-6-en/security-updates/security-update-02-2021
osv:CVE-2021-32711
Complete source record
{
"id": "529a76885cddef4095af36798b0774fa9357677c8bb116aba94237809c3db1ba",
"url": "https://osv.dev/vulnerability/CVE-2021-32711",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "CVE-2021-32711",
"summary": "Shopware is an open source eCommerce platform. Versions prior to 6.3.5.1 may leak of information via Store-API. The vulnerability could only be fixed by changing the API system, which involves a non-backward-compatible change. Only consumers of the Store-API should be affected by this change. We recommend to update to the current version 6.3.5.1. You can get the update to 6.3.5.1 regularly via the Auto-Updater or directly via the download overview. https://www.shopware.com/en/download/#shopware-6 The vulnerability could only be fixed by changing the API system, which involves a non-backward-compatible change. Only consumers of the Store-API should be affected by this change. Please check your plugins if you have it in use. Detailed technical information can be found in the upgrade information. https://github.com/shopware/platform/blob/v6.3.5.1/UPGRADE-6.3.md#6351 ### Workarounds For older versions of 6.1 and 6.2, corresponding security measures are also available via a plugin. For the full range of functions, we recommend updating to the latest Shopware version. https://store.shopware.com/en/detail/index/sArticle/518463/number/Swag136939272659 ### For more information https://docs.shopware.com/en/shopware-6-en/security-updates/security-update-02-2021",
"evidence": "osv:CVE-2021-32711",
"products": [],
"severity": "high",
"structured": {
"id": "CVE-2021-32711",
"aliases": [
"CVE-2021-32711",
"GHSA-2p89-5f22-8qvf",
"GHSA-f2vv-h5x4-57gr"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/shopware/shopware",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "5c1ec3911040fab33557c5a98df287f43ded3323"
},
{
"fixed": "157fb84a8b3b4ace4be165a033d559826704829b"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:shopware:shopware:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "0"
},
{
"fixed": "6.3.5.1"
}
],
"source": "CPE_RANGE"
},
{
"range": [
{
"fixed": "157fb84a8b3b4ace4be165a033d559826704829b"
}
],
"source": "REFERENCES_COMMIT"
}
]
}
}
],
"versions": [
"v6.3.5.0"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2021-32711.json"
}
}
],
"modified": "2026-10-20T10:54:42.647056822Z",
"provider": "osv",
"references": [
"https://docs.shopware.com/en/shopware-6-en/security-updates/security-update-02-2021",
"https://github.com/shopware/platform/security/advisories/GHSA-f2vv-h5x4-57gr",
"https://github.com/shopware/platform/commit/157fb84a8b3b4ace4be165a033d559826704829b"
],
"provider_metadata": {}
},
"related_cves": [
{
"value": "CVE-2021-32711",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 385954,
"published_at": "2021-06-24T20:15:09.127+00:00"
}