Security advisory
Doorkeeper version 2.1.0 through 4.2.5 contains a Cross Site Scripting (XSS) vulnerability in web view's OAuth app form, user authorization prompt web view that can result in Stored XSS on the OAuth Client's name will cause users interacting with it will execute payload. This attack appear to be exploitable via The victim must be tricked to click an opaque link to the web view that runs the XSS payload. A malicious version virtually indistinguishable from a normal link.. This vulnerability appears to have been fixed in 4.2.6, 4.3.0.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2018-1000088
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 31 Oct 2026, 10:20 UTC · Revision 1
Source evidence
Doorkeeper version 2.1.0 through 4.2.5 contains a Cross Site Scripting (XSS) vulnerability in web view's OAuth app form, user authorization prompt web view that can result in Stored XSS on the OAuth Client's name will cause users interacting with it will execute payload. This attack appear to be exploitable via The victim must be tricked to click an opaque link to the web view that runs the XSS payload. A malicious version virtually indistinguishable from a normal link.. This vulnerability appears to have been fixed in 4.2.6, 4.3.0.
osv:CVE-2018-1000088
Complete source record
{
"id": "793371d1c2270632719985c969e1cc42d48d8c5e218f0e7f88f0e9413fa31b5e",
"url": "https://osv.dev/vulnerability/CVE-2018-1000088",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "CVE-2018-1000088",
"summary": "Doorkeeper version 2.1.0 through 4.2.5 contains a Cross Site Scripting (XSS) vulnerability in web view's OAuth app form, user authorization prompt web view that can result in Stored XSS on the OAuth Client's name will cause users interacting with it will execute payload. This attack appear to be exploitable via The victim must be tricked to click an opaque link to the web view that runs the XSS payload. A malicious version virtually indistinguishable from a normal link.. This vulnerability appears to have been fixed in 4.2.6, 4.3.0.",
"evidence": "osv:CVE-2018-1000088",
"products": [],
"severity": "medium",
"structured": {
"id": "CVE-2018-1000088",
"aliases": [
"CVE-2018-1000088",
"GHSA-hwhh-2fwm-cfgw"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/doorkeeper-gem/doorkeeper",
"type": "GIT",
"events": [
{
"introduced": "1415013c652009340717d173dcb72bf6d2d119b5"
},
{
"last_affected": "23a02a807cbe6a1bd94aa660a440cb158cad6184"
},
{
"fixed": "644d2ceb41411b9b320a6c8ee769762b37deba01"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:doorkeeper_project:doorkeeper:*:*:*:*:*:ruby:*:*",
"range": [
{
"introduced": "2.1.0"
},
{
"last_affected": "4.2.5"
}
],
"source": "CPE_RANGE"
},
{
"range": [
{
"fixed": "644d2ceb41411b9b320a6c8ee769762b37deba01"
}
],
"source": "REFERENCES_TAG",
"original_tag": "v4.3.0"
}
]
}
}
],
"versions": [
"v4.2.5",
"v4.2.0",
"v4.1.0",
"v4.0.0",
"v4.0.0.rc4",
"v4.0.0.rc3",
"v4.0.0.rc2",
"v4.0.0.rc1",
"v3.0.1",
"v3.0.0",
"v3.0.0.rc2",
"v3.0.0.rc1",
"v2.2.1",
"v2.2.0",
"v2.1.4",
"v2.1.3",
"v2.1.2",
"v2.1.1",
"v2.1.0"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2018-1000088.json"
}
}
],
"modified": "2026-10-20T10:50:14.096041191Z",
"provider": "osv",
"references": [
"https://github.com/doorkeeper-gem/doorkeeper/releases/tag/v4.3.0",
"https://github.com/rubysec/ruby-advisory-db/pull/328/files",
"https://github.com/doorkeeper-gem/doorkeeper/issues/969",
"https://github.com/doorkeeper-gem/doorkeeper/pull/970"
],
"provider_metadata": {}
},
"related_cves": [
{
"value": "CVE-2018-1000088",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 381426,
"published_at": "2018-03-13T15:29:01.3+00:00"
}