UnratedFix available
libapache-poi-java — security advisory
The OPC SAX setup in Apache POI before 3.10.1 allows remote attackers to read arbitrary files via an OpenXML file containing an XML external entity declaration in conjunction with an entity reference, related to an XML External Entity (XXE) issue.
- Products
- libapache-poi-java
- Affected versions
- Not specified
- Fixed versions
- 3.10.1-1
- CVEs
- CVE-2014-3529
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 31 Oct 2026, 21:35 UTC · Revision 1
Source evidence
The OPC SAX setup in Apache POI before 3.10.1 allows remote attackers to read arbitrary files via an OpenXML file containing an XML external entity declaration in conjunction with an entity reference, related to an XML External Entity (XXE) issue.
osv:DEBIAN-CVE-2014-3529
libapache-poi-java
Fixed versions: 3.10.1-1
libapache-poi-java
Fixed versions: 3.10.1-1
libapache-poi-java
Fixed versions: 3.10.1-1
Complete source record
{
"id": "0994504f32e2bdd8cb69a6e924d02c556d054656db705ebcefeb6518087537f8",
"url": "https://osv.dev/vulnerability/DEBIAN-CVE-2014-3529",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "DEBIAN-CVE-2014-3529",
"summary": "The OPC SAX setup in Apache POI before 3.10.1 allows remote attackers to read arbitrary files via an OpenXML file containing an XML external entity declaration in conjunction with an entity reference, related to an XML External Entity (XXE) issue.",
"evidence": "osv:DEBIAN-CVE-2014-3529",
"products": [
{
"name": {
"value": "libapache-poi-java",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "3.10.1-1",
"evidence": "/affected/0/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "libapache-poi-java",
"evidence": "/affected/1/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "3.10.1-1",
"evidence": "/affected/1/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "libapache-poi-java",
"evidence": "/affected/2/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "3.10.1-1",
"evidence": "/affected/2/ranges"
}
],
"affected_versions": []
}
],
"severity": "unknown",
"structured": {
"id": "DEBIAN-CVE-2014-3529",
"aliases": [
"DEBIAN-CVE-2014-3529"
],
"affected": [
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "3.10.1-1"
}
]
}
],
"package": {
"name": "libapache-poi-java",
"purl": "pkg:deb/debian/libapache-poi-java?arch=source&distro=bookworm",
"ecosystem": "Debian:12"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2014-3529.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "3.10.1-1"
}
]
}
],
"package": {
"name": "libapache-poi-java",
"purl": "pkg:deb/debian/libapache-poi-java?arch=source&distro=trixie",
"ecosystem": "Debian:13"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2014-3529.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "3.10.1-1"
}
]
}
],
"package": {
"name": "libapache-poi-java",
"purl": "pkg:deb/debian/libapache-poi-java?arch=source&distro=forky",
"ecosystem": "Debian:14"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2014-3529.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
}
],
"modified": "2026-10-23T15:47:23.328185381Z",
"provider": "osv",
"upstream": [
"CVE-2014-3529"
],
"references": [
"https://security-tracker.debian.org/tracker/CVE-2014-3529"
]
},
"related_cves": [
{
"value": "CVE-2014-3529",
"evidence": "/upstream"
}
],
"security_relevant": true,
"severity_evidence": null
},
"source_id": "core-osv",
"document_id": 413743,
"published_at": "2014-09-04T17:55:05.623+00:00"
}