Ultimate Member Plugin Template class-shortcodes.php load_template pathname traversal
A vulnerability, which was classified as critical, has been found in Ultimate Member Plugin up to 2.5.0. This issue affects the function load_template of the file includes/core/class-shortcodes.php of the component Template Handler. The manipulation of the argument tpl leads to pathname traversal. The attack may be initiated remotely. Upgrading to version 2.5.1 is able to address this issue. The name of the patch is e1bc94c1100f02a129721ba4be5fbc44c3d78ec4. It is recommended to upgrade the affected component. The identifier VDB-213545 was assigned to this vulnerability.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2022-3966
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 5 Nov 2026, 02:10 UTC · Revision 1
Source evidence
Ultimate Member Plugin Template class-shortcodes.php load_template pathname traversal
core-osv · Original sourcePublished 13 Nov 2022, 00:00 UTC
A vulnerability, which was classified as critical, has been found in Ultimate Member Plugin up to 2.5.0. This issue affects the function load_template of the file includes/core/class-shortcodes.php of the component Template Handler. The manipulation of the argument tpl leads to pathname traversal. The attack may be initiated remotely. Upgrading to version 2.5.1 is able to address this issue. The name of the patch is e1bc94c1100f02a129721ba4be5fbc44c3d78ec4. It is recommended to upgrade the affected component. The identifier VDB-213545 was assigned to this vulnerability.
osv:CVE-2022-3966
Complete source record
{
"id": "c6f21cffc85816ac824c418073558fbd45c44d04d31d02669c5f93f068e40491",
"url": "https://osv.dev/vulnerability/CVE-2022-3966",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "Ultimate Member Plugin Template class-shortcodes.php load_template pathname traversal",
"summary": "A vulnerability, which was classified as critical, has been found in Ultimate Member Plugin up to 2.5.0. This issue affects the function load_template of the file includes/core/class-shortcodes.php of the component Template Handler. The manipulation of the argument tpl leads to pathname traversal. The attack may be initiated remotely. Upgrading to version 2.5.1 is able to address this issue. The name of the patch is e1bc94c1100f02a129721ba4be5fbc44c3d78ec4. It is recommended to upgrade the affected component. The identifier VDB-213545 was assigned to this vulnerability.",
"evidence": "osv:CVE-2022-3966",
"products": [],
"severity": "medium",
"structured": {
"id": "CVE-2022-3966",
"aliases": [
"CVE-2022-3966"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/ultimatemember/ultimatemember",
"type": "GIT",
"events": [
{
"introduced": "6bdb6af868d4dfd94c1ae347e49668ebb3ee99d7"
},
{
"fixed": "e1bc94c1100f02a129721ba4be5fbc44c3d78ec4"
},
{
"fixed": "de6f90e9fa1ca9439d5ad688a8ba9d127849aa05"
}
],
"database_specific": {
"extracted_events": [
{
"range": [
{
"introduced": "2.0"
},
{
"last_affected": "2.0"
}
],
"source": "AFFECTED_FIELD",
"strategy": "StandaloneSingleVersion"
},
{
"range": [
{
"introduced": "2.1"
},
{
"last_affected": "2.1"
}
],
"source": "AFFECTED_FIELD",
"strategy": "StandaloneSingleVersion"
},
{
"range": [
{
"introduced": "2.2"
},
{
"last_affected": "2.2"
}
],
"source": "AFFECTED_FIELD",
"strategy": "StandaloneSingleVersion"
},
{
"range": [
{
"introduced": "2.3"
},
{
"last_affected": "2.3"
}
],
"source": "AFFECTED_FIELD",
"strategy": "StandaloneSingleVersion"
},
{
"range": [
{
"introduced": "2.4"
},
{
"last_affected": "2.4"
}
],
"source": "AFFECTED_FIELD",
"strategy": "StandaloneSingleVersion"
},
{
"range": [
{
"introduced": "2.5"
},
{
"last_affected": "2.5"
}
],
"source": "AFFECTED_FIELD",
"strategy": "StandaloneSingleVersion"
},
{
"range": [
{
"fixed": "e1bc94c1100f02a129721ba4be5fbc44c3d78ec4"
}
],
"source": "REFERENCES_COMMIT"
},
{
"range": [
{
"fixed": "de6f90e9fa1ca9439d5ad688a8ba9d127849aa05"
}
],
"source": "REFERENCES_TAG",
"original_tag": "2.5.1"
}
]
}
}
],
"versions": [
"2.0",
"2.1",
"2.2",
"2.3",
"2.4",
"2.5"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2022-3966.json"
}
}
],
"modified": "2026-10-28T02:30:41.824283360Z",
"provider": "osv",
"references": [
"https://github.com/ultimatemember/ultimatemember/releases/tag/2.5.1",
"https://vuldb.com/?id.213545",
"https://github.com/CVEProject/cvelistV5/tree/main/cves/2022/3xxx/CVE-2022-3966.json",
"https://nvd.nist.gov/vuln/detail/CVE-2022-3966",
"https://github.com/ultimatemember/ultimatemember/commit/e1bc94c1100f02a129721ba4be5fbc44c3d78ec4"
],
"provider_metadata": {
"cwe_ids": [
"CWE-22"
],
"cna_assigner": "VulDB",
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2022/3xxx/CVE-2022-3966.json"
}
},
"related_cves": [
{
"value": "CVE-2022-3966",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 509403,
"published_at": "2022-11-13T00:00:00+00:00"
}