Skip to content
Heist/ feed
Back to feed
HighFix available

trafficserver — security advisory

Type: advisorySources: OSVAdvisory ID: DEBIAN-CVE-2023-38522

Apache Traffic Server accepts characters that are not allowed for HTTP field names and forwards malformed requests to origin servers. This can be utilized for request smuggling and may also lead cache poisoning if the origin servers are vulnerable. This issue affects Apache Traffic Server: from 8.0.0 through 8.1.10, from 9.0.0 through 9.2.4. Users are recommended to upgrade to version 8.1.11 or 9.2.5, which fixes the issue.

Products
trafficserver
Affected versions
9.2.0+ds-2, 9.2.0+ds-2+deb12u1, 9.2.1+ds-1, 9.2.2+ds-1, 9.2.3+ds-1, 9.2.3+ds-1+deb12u1, 9.2.4+ds-0+deb12u1, 9.2.4+ds-1, 9.2.4+ds-2
Fixed versions
9.2.5+ds-0+deb12u1
CVEs
CVE-2023-38522
Confirmed fixed CVEs
Not specified
Updated in this feed
1 Nov 2026, 15:55 UTC · Revision 1

Source evidence

DEBIAN-CVE-2023-38522

core-osv · Original source

Published 26 Jul 2024, 10:15 UTC

Apache Traffic Server accepts characters that are not allowed for HTTP field names and forwards malformed requests to origin servers. This can be utilized for request smuggling and may also lead cache poisoning if the origin servers are vulnerable. This issue affects Apache Traffic Server: from 8.0.0 through 8.1.10, from 9.0.0 through 9.2.4. Users are recommended to upgrade to version 8.1.11 or 9.2.5, which fixes the issue.

osv:DEBIAN-CVE-2023-38522

trafficserver

Fixed versions: 9.2.5+ds-0+deb12u1

Complete source record
{
  "id": "3163470e5fb7d1608871f4fbec97df7644fa700d4bf8d38b9aa43080e721964d",
  "url": "https://osv.dev/vulnerability/DEBIAN-CVE-2023-38522",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "DEBIAN-CVE-2023-38522",
    "summary": "Apache Traffic Server accepts characters that are not allowed for HTTP field names and forwards malformed requests to origin servers. This can be utilized for request smuggling and may also lead cache poisoning if the origin servers are vulnerable. This issue affects Apache Traffic Server: from 8.0.0 through 8.1.10, from 9.0.0 through 9.2.4. Users are recommended to upgrade to version 8.1.11 or 9.2.5, which fixes the issue.",
    "evidence": "osv:DEBIAN-CVE-2023-38522",
    "products": [
      {
        "name": {
          "value": "trafficserver",
          "evidence": "/affected/0/package/name"
        },
        "prerequisites": [],
        "fixed_versions": [
          {
            "value": "9.2.5+ds-0+deb12u1",
            "evidence": "/affected/0/ranges"
          }
        ],
        "affected_versions": [
          {
            "value": "9.2.0+ds-2",
            "evidence": "/affected/0/versions"
          },
          {
            "value": "9.2.0+ds-2+deb12u1",
            "evidence": "/affected/0/versions"
          },
          {
            "value": "9.2.1+ds-1",
            "evidence": "/affected/0/versions"
          },
          {
            "value": "9.2.2+ds-1",
            "evidence": "/affected/0/versions"
          },
          {
            "value": "9.2.3+ds-1",
            "evidence": "/affected/0/versions"
          },
          {
            "value": "9.2.3+ds-1+deb12u1",
            "evidence": "/affected/0/versions"
          },
          {
            "value": "9.2.4+ds-0+deb12u1",
            "evidence": "/affected/0/versions"
          },
          {
            "value": "9.2.4+ds-1",
            "evidence": "/affected/0/versions"
          },
          {
            "value": "9.2.4+ds-2",
            "evidence": "/affected/0/versions"
          }
        ]
      }
    ],
    "severity": "high",
    "structured": {
      "id": "DEBIAN-CVE-2023-38522",
      "aliases": [
        "DEBIAN-CVE-2023-38522"
      ],
      "metrics": [
        {
          "type": "CVSS_V3",
          "score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N"
        }
      ],
      "affected": [
        {
          "ranges": [
            {
              "type": "ECOSYSTEM",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "9.2.5+ds-0+deb12u1"
                }
              ]
            }
          ],
          "package": {
            "name": "trafficserver",
            "purl": "pkg:deb/debian/trafficserver?arch=source&distro=bookworm",
            "ecosystem": "Debian:12"
          },
          "versions": [
            "9.2.0+ds-2",
            "9.2.0+ds-2+deb12u1",
            "9.2.1+ds-1",
            "9.2.2+ds-1",
            "9.2.3+ds-1",
            "9.2.3+ds-1+deb12u1",
            "9.2.4+ds-0+deb12u1",
            "9.2.4+ds-1",
            "9.2.4+ds-2"
          ],
          "database_specific": {
            "source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2023-38522.json"
          },
          "ecosystem_specific": {
            "urgency": "not yet assigned"
          }
        }
      ],
      "modified": "2026-10-26T18:02:30.376867545Z",
      "provider": "osv",
      "upstream": [
        "CVE-2023-38522"
      ],
      "references": [
        "https://security-tracker.debian.org/tracker/CVE-2023-38522"
      ]
    },
    "related_cves": [
      {
        "value": "CVE-2023-38522",
        "evidence": "/upstream"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/severity/0/score"
  },
  "source_id": "core-osv",
  "document_id": 456103,
  "published_at": "2024-07-26T10:15:01.923+00:00"
}