openssl — security advisory
OpenSSL before 0.9.8q, and 1.0.x before 1.0.0c, when SSL_OP_NETSCAPE_REUSE_CIPHER_CHANGE_BUG is enabled, does not properly prevent modification of the ciphersuite in the session cache, which allows remote attackers to force the downgrade to an unintended cipher via vectors involving sniffing network traffic to discover a session identifier.
- Products
- openssl
- Affected versions
- Not specified
- Fixed versions
- 0.9.8o-4
- CVEs
- CVE-2010-4180
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 31 Oct 2026, 23:19 UTC · Revision 1
Source evidence
OpenSSL before 0.9.8q, and 1.0.x before 1.0.0c, when SSL_OP_NETSCAPE_REUSE_CIPHER_CHANGE_BUG is enabled, does not properly prevent modification of the ciphersuite in the session cache, which allows remote attackers to force the downgrade to an unintended cipher via vectors involving sniffing network traffic to discover a session identifier.
osv:DEBIAN-CVE-2010-4180
openssl
Fixed versions: 0.9.8o-4
openssl
Fixed versions: 0.9.8o-4
openssl
Fixed versions: 0.9.8o-4
Complete source record
{
"id": "e4269263fb92e3c2f4d14348bd4a29cd6063b34f8d8bcefed9a79201f5ed8961",
"url": "https://osv.dev/vulnerability/DEBIAN-CVE-2010-4180",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "DEBIAN-CVE-2010-4180",
"summary": "OpenSSL before 0.9.8q, and 1.0.x before 1.0.0c, when SSL_OP_NETSCAPE_REUSE_CIPHER_CHANGE_BUG is enabled, does not properly prevent modification of the ciphersuite in the session cache, which allows remote attackers to force the downgrade to an unintended cipher via vectors involving sniffing network traffic to discover a session identifier.",
"evidence": "osv:DEBIAN-CVE-2010-4180",
"products": [
{
"name": {
"value": "openssl",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "0.9.8o-4",
"evidence": "/affected/0/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "openssl",
"evidence": "/affected/1/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "0.9.8o-4",
"evidence": "/affected/1/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "openssl",
"evidence": "/affected/2/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "0.9.8o-4",
"evidence": "/affected/2/ranges"
}
],
"affected_versions": []
}
],
"severity": "unknown",
"structured": {
"id": "DEBIAN-CVE-2010-4180",
"aliases": [
"DEBIAN-CVE-2010-4180"
],
"affected": [
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "0.9.8o-4"
}
]
}
],
"package": {
"name": "openssl",
"purl": "pkg:deb/debian/openssl?arch=source&distro=bookworm",
"ecosystem": "Debian:12"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2010-4180.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "0.9.8o-4"
}
]
}
],
"package": {
"name": "openssl",
"purl": "pkg:deb/debian/openssl?arch=source&distro=trixie",
"ecosystem": "Debian:13"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2010-4180.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "0.9.8o-4"
}
]
}
],
"package": {
"name": "openssl",
"purl": "pkg:deb/debian/openssl?arch=source&distro=forky",
"ecosystem": "Debian:14"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2010-4180.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
}
],
"modified": "2026-10-23T17:47:40.566488665Z",
"provider": "osv",
"upstream": [
"CVE-2010-4180"
],
"references": [
"https://security-tracker.debian.org/tracker/CVE-2010-4180"
]
},
"related_cves": [
{
"value": "CVE-2010-4180",
"evidence": "/upstream"
}
],
"security_relevant": true,
"severity_evidence": null
},
"source_id": "core-osv",
"document_id": 418284,
"published_at": "2010-12-06T21:05:48.687+00:00"
}