Skip to content
Heist/ feed
Back to feed
High

ModSecurity has possible DoS vulnerability in sanitiseArg action

Type: advisorySources: OSV

ModSecurity is an open source, cross platform web application firewall (WAF) engine for Apache, IIS and Nginx. Versions prior to 2.9.10 contain a denial of service vulnerability similar to GHSA-859r-vvv8-rm8r/CVE-2025-47947. The `sanitiseArg` (and `sanitizeArg` - this is the same action but an alias) is vulnerable to adding an excessive number of arguments, thereby leading to denial of service. Version 2.9.10 fixes the issue. As a workaround, avoid using rules that contain the `sanitiseArg` (or `sanitizeArg`) action.

Products
Not specified
Affected versions
Not specified
Fixed versions
Not specified
CVEs
CVE-2025-48866
Confirmed fixed CVEs
Not specified
Updated in this feed
2 Nov 2026, 18:55 UTC · Revision 1

Source evidence

ModSecurity has possible DoS vulnerability in sanitiseArg action

core-osv · Original source

Published 2 Jun 2025, 15:46 UTC

ModSecurity is an open source, cross platform web application firewall (WAF) engine for Apache, IIS and Nginx. Versions prior to 2.9.10 contain a denial of service vulnerability similar to GHSA-859r-vvv8-rm8r/CVE-2025-47947. The `sanitiseArg` (and `sanitizeArg` - this is the same action but an alias) is vulnerable to adding an excessive number of arguments, thereby leading to denial of service. Version 2.9.10 fixes the issue. As a workaround, avoid using rules that contain the `sanitiseArg` (or `sanitizeArg`) action.

osv:CVE-2025-48866
Complete source record
{
  "id": "36b57d39343e4c3557d7c2dc2ae35c942f7faef97f0bde3ca2074c748da0cc6a",
  "url": "https://osv.dev/vulnerability/CVE-2025-48866",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "ModSecurity has possible DoS vulnerability in sanitiseArg action",
    "summary": "ModSecurity is an open source, cross platform web application firewall (WAF) engine for Apache, IIS and Nginx. Versions prior to 2.9.10 contain a denial of service vulnerability similar to GHSA-859r-vvv8-rm8r/CVE-2025-47947. The `sanitiseArg` (and `sanitizeArg` - this is the same action but an alias) is vulnerable to adding an excessive number of arguments, thereby leading to denial of service. Version 2.9.10 fixes the issue. As a workaround, avoid using rules that contain the `sanitiseArg` (or `sanitizeArg`) action.",
    "evidence": "osv:CVE-2025-48866",
    "products": [],
    "severity": "high",
    "structured": {
      "id": "CVE-2025-48866",
      "aliases": [
        "BIT-modsecurity-2025-48866",
        "BIT-modsecurity2-2025-48866",
        "CVE-2025-48866"
      ],
      "metrics": [
        {
          "type": "CVSS_V3",
          "score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H"
        }
      ],
      "affected": [
        {
          "ranges": [
            {
              "repo": "https://github.com/owasp-modsecurity/modsecurity",
              "type": "GIT",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "0923377d6d618e4cf6cc56ac67ce385bb60127e9"
                },
                {
                  "fixed": "3a54ccea62d3f7151bb08cb78d60c5e90b53ca2e"
                }
              ],
              "database_specific": {
                "extracted_events": [
                  {
                    "cpe": "cpe:2.3:a:owasp:modsecurity:*:*:*:*:*:*:*:*",
                    "range": [
                      {
                        "introduced": "0"
                      },
                      {
                        "fixed": "2.9.10"
                      }
                    ],
                    "source": "CPE_RANGE"
                  },
                  {
                    "range": [
                      {
                        "fixed": "3a54ccea62d3f7151bb08cb78d60c5e90b53ca2e"
                      }
                    ],
                    "source": "REFERENCES_COMMIT"
                  }
                ]
              }
            }
          ],
          "versions": [
            "v2.9.9",
            "v2.9.7",
            "v2.9.6",
            "v2.9.5",
            "v2.9.4",
            "v2.9.3",
            "v2.9.2",
            "v2.9.1",
            "v2.9.1-rc1",
            "v2.9.0",
            "v2.9.0-rc2",
            "v2.9.0-rc1",
            "v2.7.4"
          ],
          "database_specific": {
            "source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2025-48866.json"
          }
        }
      ],
      "modified": "2026-10-28T02:30:22.598420425Z",
      "provider": "osv",
      "references": [
        "https://github.com/owasp-modsecurity/ModSecurity/wiki/Reference-Manual-(v2.x)#sanitisearg",
        "https://lists.debian.org/debian-lts-announce/2025/06/msg00009.html",
        "https://github.com/CVEProject/cvelistV5/tree/main/cves/2025/48xxx/CVE-2025-48866.json",
        "https://github.com/owasp-modsecurity/ModSecurity/security/advisories/GHSA-859r-vvv8-rm8r",
        "https://github.com/owasp-modsecurity/ModSecurity/security/advisories/GHSA-f82j-8pp7-cw2w",
        "https://nvd.nist.gov/vuln/detail/CVE-2025-48866",
        "https://github.com/owasp-modsecurity/ModSecurity/commit/3a54ccea62d3f7151bb08cb78d60c5e90b53ca2e"
      ],
      "provider_metadata": {
        "cwe_ids": [
          "CWE-1050"
        ],
        "cna_assigner": "GitHub_M",
        "osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2025/48xxx/CVE-2025-48866.json"
      }
    },
    "related_cves": [
      {
        "value": "CVE-2025-48866",
        "evidence": "/id"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/severity/0/score"
  },
  "source_id": "core-osv",
  "document_id": 488869,
  "published_at": "2025-06-02T15:46:19.909+00:00"
}