Critical
Asgaros Forum < 2.7.1 - Unauthenticated Arbitrary File Upload
Type: advisorySources: OSV
The Asgaros Forum WordPress plugin before 2.7.1 allows forum administrators, who may not be WordPress (super-)administrators, to set insecure configuration that allows unauthenticated users to upload dangerous files (e.g. .php, .phtml), potentially leading to remote code execution.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2023-5604
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 8 Nov 2026, 03:38 UTC · Revision 1
Source evidence
Asgaros Forum < 2.7.1 - Unauthenticated Arbitrary File Upload
core-osv · Original sourcePublished 27 Nov 2023, 16:22 UTC
The Asgaros Forum WordPress plugin before 2.7.1 allows forum administrators, who may not be WordPress (super-)administrators, to set insecure configuration that allows unauthenticated users to upload dangerous files (e.g. .php, .phtml), potentially leading to remote code execution.
osv:CVE-2023-5604
Complete source record
{
"id": "0f5a11f66838004789e5ba837ad5a53ba909d9eb6bed217d880e9c585ce100ee",
"url": "https://osv.dev/vulnerability/CVE-2023-5604",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "Asgaros Forum < 2.7.1 - Unauthenticated Arbitrary File Upload",
"summary": "The Asgaros Forum WordPress plugin before 2.7.1 allows forum administrators, who may not be WordPress (super-)administrators, to set insecure configuration that allows unauthenticated users to upload dangerous files (e.g. .php, .phtml), potentially leading to remote code execution.",
"evidence": "osv:CVE-2023-5604",
"products": [],
"severity": "critical",
"structured": {
"id": "CVE-2023-5604",
"aliases": [
"CVE-2023-5604"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/asgaros/asgaros-forum",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "45acc0d0cc4a9e5eed519a982a85ff2e68970be0"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:asgaros:asgaros_forum:*:*:*:*:*:wordpress:*:*",
"range": [
{
"introduced": "0"
},
{
"fixed": "2.7.1"
}
],
"source": "CPE_RANGE"
}
]
}
}
],
"versions": [
"v2.7.0",
"v2.6.0",
"v2.5.1",
"v2.5.0",
"v2.4.1",
"v2.4.0",
"v2.3.1",
"v2.3.0",
"v2.2.0",
"v2.1.0",
"v2.0.0",
"v1.15.20",
"v1.15.19",
"v1.15.18",
"v1.15.17",
"v1.15.16",
"v1.15.15",
"v1.15.14",
"v1.15.13",
"v1.15.12",
"v1.15.11",
"v1.15.10",
"v1.15.9",
"v1.15.8",
"v1.15.7",
"v1.15.6",
"v1.15.5",
"v1.15.4",
"v1.15.3",
"v1.15.2",
"v1.15.1",
"v1.15.0",
"v1.14.15",
"v1.14.14",
"v1.14.13",
"v1.14.12",
"v1.14.11",
"v1.14.10",
"v1.14.9",
"v1.14.8",
"v1.14.7",
"v1.14.6",
"v1.14.5",
"v1.14.4",
"v1.14.3",
"v1.14.2",
"v1.14.1",
"v1.14.0",
"v1.13.3",
"v1.13.2",
"v1.13.1",
"v1.13.0",
"v1.12.1",
"v1.12.0",
"v1.11.3",
"v1.11.2",
"v1.11.1",
"v1.11.0",
"v1.10.1",
"v1.10.0",
"v1.9.6",
"v1.9.5",
"v1.9.4",
"v1.9.3",
"v1.9.2",
"v1.9.1",
"v1.9.0",
"v1.8.4",
"v1.8.3",
"v1.8.2",
"v1.8.1",
"v1.8.0",
"v1.7.2",
"v1.7.1",
"v1.7.0",
"v1.6.8",
"v1.6.7",
"v1.6.6",
"v1.6.5",
"v1.6.4",
"v1.6.3",
"v1.6.2",
"v1.6.1",
"v1.6.0",
"v1.5.9",
"v1.5.8",
"v1.5.7",
"v1.5.6",
"v1.5.5",
"v1.5.4",
"v1.5.3",
"v1.5.2",
"v1.5.1",
"v1.5.0",
"v1.4.5",
"v1.4.4",
"v1.4.3",
"v1.4.2",
"v1.4.1",
"v1.4.0",
"v1.3.10",
"v1.3.9",
"v1.3.8",
"v1.3.7",
"v1.3.6",
"v1.3.5",
"v1.3.4",
"v1.3.3",
"v1.3.2",
"v1.3.1",
"v1.3.0",
"v1.2.9",
"v1.2.8",
"v1.2.7",
"v1.2.6",
"v1.2.5",
"v1.2.4",
"v1.2.3",
"v1.2.2",
"v1.2.1",
"v1.2.0",
"v1.1.6",
"v1.1.5",
"v1.1.4",
"v1.1.3",
"v1.1.2",
"v1.1.1",
"v1.1.0",
"v1.0.14",
"v1.0.13",
"v1.0.12",
"v1.0.11",
"v1.0.10",
"v1.0.9",
"v1.0.8",
"v1.0.7",
"v1.0.6",
"v1.0.5",
"v1.0.4",
"v1.0.3",
"v1.0.2",
"v1.0.1",
"v1.0.0"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2023-5604.json"
}
}
],
"modified": "2026-10-28T02:30:53.198031370Z",
"provider": "osv",
"references": [
"https://wordpress.org/plugins",
"https://github.com/CVEProject/cvelistV5/tree/main/cves/2023/5xxx/CVE-2023-5604.json",
"https://nvd.nist.gov/vuln/detail/CVE-2023-5604",
"https://wpscan.com/vulnerability/4ce69d71-87bf-4d95-90f2-63d558c78b69"
],
"provider_metadata": {
"cna_assigner": "WPScan",
"unresolved_ranges": [
{
"extracted_events": [
{
"range": [
{
"fixed": "2.7.1"
}
],
"source": "AFFECTED_FIELD",
"strategy": "StandardRange"
}
]
}
],
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2023/5xxx/CVE-2023-5604.json"
}
},
"related_cves": [
{
"value": "CVE-2023-5604",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 522280,
"published_at": "2023-11-27T16:22:00.94+00:00"
}