Skip to content
Heist/ feed
Back to feed
Medium

Missing rate limit in Authentication in bookwyrm

Type: advisorySources: OSV

BookWyrm is a social network for tracking reading. Versions prior to 0.4.5 were found to lack rate limiting on authentication views which allows brute-force attacks. This issue has been patched in version 0.4.5. Admins with existing instances will need to update their `nginx.conf` file that was created when the instance was set up. Users are advised advised to upgrade. Users unable to upgrade may update their nginx.conf files with the changes manually.

Products
Not specified
Affected versions
Not specified
Fixed versions
Not specified
CVEs
CVE-2022-35925
Confirmed fixed CVEs
Not specified
Updated in this feed
4 Nov 2026, 20:15 UTC · Revision 1

Source evidence

Missing rate limit in Authentication in bookwyrm

core-osv · Original source

Published 2 Aug 2022, 20:15 UTC

BookWyrm is a social network for tracking reading. Versions prior to 0.4.5 were found to lack rate limiting on authentication views which allows brute-force attacks. This issue has been patched in version 0.4.5. Admins with existing instances will need to update their `nginx.conf` file that was created when the instance was set up. Users are advised advised to upgrade. Users unable to upgrade may update their nginx.conf files with the changes manually.

osv:CVE-2022-35925
Complete source record
{
  "id": "527074d3c25ebf759599d527fe3a845b18696d6d8c3ee6aabd90e8b0510812b8",
  "url": "https://osv.dev/vulnerability/CVE-2022-35925",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "Missing rate limit in Authentication in bookwyrm",
    "summary": "BookWyrm is a social network for tracking reading. Versions prior to 0.4.5 were found to lack rate limiting on authentication views which allows brute-force attacks. This issue has been patched in version 0.4.5. Admins with existing instances will need to update their `nginx.conf` file that was created when the instance was set up. Users are advised advised to upgrade. Users unable to upgrade may update their nginx.conf files with the changes manually.",
    "evidence": "osv:CVE-2022-35925",
    "products": [],
    "severity": "medium",
    "structured": {
      "id": "CVE-2022-35925",
      "aliases": [
        "CVE-2022-35925",
        "GHSA-jvp3-mqv8-5rjw"
      ],
      "metrics": [
        {
          "type": "CVSS_V3",
          "score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L"
        }
      ],
      "affected": [
        {
          "ranges": [
            {
              "repo": "https://github.com/bookwyrm-social/bookwyrm",
              "type": "GIT",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "580745bee365b646de7be5b6ad13ad6818efcecc"
                }
              ],
              "database_specific": {
                "extracted_events": [
                  {
                    "range": [
                      {
                        "introduced": "0"
                      },
                      {
                        "fixed": "0.4.5"
                      }
                    ],
                    "source": "AFFECTED_FIELD",
                    "strategy": "StringRangeExpression"
                  },
                  {
                    "cpe": "cpe:2.3:a:joinbookwyrm:bookwyrm:*:*:*:*:*:*:*:*",
                    "range": [
                      {
                        "introduced": "0"
                      },
                      {
                        "fixed": "0.4.5"
                      }
                    ],
                    "source": "CPE_RANGE"
                  }
                ]
              }
            }
          ],
          "versions": [
            "v0.4.4",
            "v0.4.3",
            "v0.4.2",
            "0.4.2",
            "v0.4.1",
            "v0.4.0",
            "v0.3.4",
            "v0.3.3",
            "v0.3.0"
          ],
          "database_specific": {
            "source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2022-35925.json"
          }
        }
      ],
      "modified": "2026-10-28T02:30:39.186949686Z",
      "provider": "osv",
      "references": [
        "https://huntr.dev/bounties/ebee593d-3fd0-4985-bf5e-7e7927e08bf6/",
        "https://www.github.com/bookwyrm-social/bookwyrm/commit/7bbe42fb30a79a26115524d18b697d895563c92f",
        "https://github.com/CVEProject/cvelistV5/tree/main/cves/2022/35xxx/CVE-2022-35925.json",
        "https://github.com/bookwyrm-social/bookwyrm/security/advisories/GHSA-jvp3-mqv8-5rjw",
        "https://nvd.nist.gov/vuln/detail/CVE-2022-35925"
      ],
      "provider_metadata": {
        "cwe_ids": [
          "CWE-287"
        ],
        "cna_assigner": "GitHub_M",
        "osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2022/35xxx/CVE-2022-35925.json"
      }
    },
    "related_cves": [
      {
        "value": "CVE-2022-35925",
        "evidence": "/id"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/severity/0/score"
  },
  "source_id": "core-osv",
  "document_id": 506567,
  "published_at": "2022-08-02T20:15:15+00:00"
}