Skip to content
Heist/ feed
Back to feed
Critical

Apache HTTP Server: buffer overflow in mod_proxy_ajp via ajp_msg_check_header()

Type: advisorySources: OSV

Heap-based Buffer Overflow vulnerability in mod_proxy_ajp of Apache HTTP Server. If mod_proxy_ajp connects to a malicious AJP server this AJP server can send a malicious AJP message back to mod_proxy_ajp and cause it to write 4 attacker controlled bytes after the end of a heap based buffer. This issue affects Apache HTTP Server: through 2.4.66. Users are recommended to upgrade to version 2.4.67, which fixes the issue.

Products
Not specified
Affected versions
Not specified
Fixed versions
Not specified
CVEs
CVE-2026-28780
Confirmed fixed CVEs
Not specified
Updated in this feed
8 Nov 2026, 00:26 UTC · Revision 1

Source evidence

Apache HTTP Server: buffer overflow in mod_proxy_ajp via ajp_msg_check_header()

core-osv · Original source

Published 5 May 2026, 21:29 UTC

Heap-based Buffer Overflow vulnerability in mod_proxy_ajp of Apache HTTP Server. If mod_proxy_ajp connects to a malicious AJP server this AJP server can send a malicious AJP message back to mod_proxy_ajp and cause it to write 4 attacker controlled bytes after the end of a heap based buffer. This issue affects Apache HTTP Server: through 2.4.66. Users are recommended to upgrade to version 2.4.67, which fixes the issue.

osv:CVE-2026-28780
Complete source record
{
  "id": "ca45495d0142759318a6c47ae477e4109847b7a5ea16e3623d9d120bf7a059d3",
  "url": "https://osv.dev/vulnerability/CVE-2026-28780",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "Apache HTTP Server: buffer overflow in mod_proxy_ajp via ajp_msg_check_header()",
    "summary": "Heap-based Buffer Overflow vulnerability in mod_proxy_ajp of Apache HTTP Server. If mod_proxy_ajp connects to a malicious AJP server this AJP server can send a malicious AJP message back to mod_proxy_ajp and cause it to write 4 attacker controlled bytes after the end of a heap based buffer. This issue affects Apache HTTP Server: through 2.4.66. Users are recommended to upgrade to version 2.4.67, which fixes the issue.",
    "evidence": "osv:CVE-2026-28780",
    "products": [],
    "severity": "critical",
    "structured": {
      "id": "CVE-2026-28780",
      "aliases": [
        "BIT-apache-2026-28780",
        "CVE-2026-28780"
      ],
      "metrics": [
        {
          "type": "CVSS_V3",
          "score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H"
        }
      ],
      "affected": [
        {
          "ranges": [
            {
              "repo": "https://github.com/apache/httpd",
              "type": "GIT",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "last_affected": "e4a77ef6051b3fe22eafacbcf54855b178a0bddd"
                }
              ],
              "database_specific": {
                "extracted_events": [
                  {
                    "range": [
                      {
                        "introduced": "0"
                      },
                      {
                        "last_affected": "2.4.66"
                      }
                    ],
                    "source": "DESCRIPTION"
                  }
                ]
              }
            }
          ],
          "versions": [
            "2.4.66",
            "2.4.66-rc1-candidate"
          ],
          "database_specific": {
            "source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2026-28780.json"
          }
        }
      ],
      "modified": "2026-10-28T02:30:52.129188410Z",
      "provider": "osv",
      "references": [
        "https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-28780.json",
        "https://access.redhat.com/errata/RHSA-2026:21391",
        "https://access.redhat.com/errata/RHSA-2026:21433",
        "https://access.redhat.com/errata/RHSA-2026:22140",
        "https://access.redhat.com/errata/RHSA-2026:27200",
        "https://access.redhat.com/errata/RHSA-2026:27201",
        "https://access.redhat.com/errata/RHSA-2026:36373",
        "https://access.redhat.com/errata/RHSA-2026:36831",
        "https://access.redhat.com/errata/RHSA-2026:36846",
        "https://access.redhat.com/errata/RHSA-2026:47046",
        "https://access.redhat.com/errata/RHSA-2026:62165",
        "https://access.redhat.com/errata/RHSA-2026:66323",
        "https://access.redhat.com/errata/RHSA-2026:67152",
        "https://access.redhat.com/security/cve/CVE-2026-28780",
        "https://github.com/CVEProject/cvelistV5/tree/main/cves/2026/28xxx/CVE-2026-28780.json",
        "https://httpd.apache.org/security/vulnerabilities_24.html",
        "https://nvd.nist.gov/vuln/detail/CVE-2026-28780",
        "https://bugzilla.redhat.com/show_bug.cgi?id=2466913"
      ],
      "provider_metadata": {
        "cwe_ids": [
          "CWE-122"
        ],
        "cna_assigner": "apache",
        "unresolved_ranges": [
          {
            "extracted_events": [
              {
                "range": [
                  {
                    "last_affected": "2.4.66"
                  }
                ],
                "source": "AFFECTED_FIELD",
                "strategy": "StandardRange"
              }
            ]
          }
        ],
        "osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2026/28xxx/CVE-2026-28780.json"
      }
    },
    "related_cves": [
      {
        "value": "CVE-2026-28780",
        "evidence": "/id"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/severity/0/score"
  },
  "source_id": "core-osv",
  "document_id": 520953,
  "published_at": "2026-05-05T21:29:41.527+00:00"
}