Skip to content
Heist/ feed
Back to feed
Medium

WP SMS <= 6.5 - Authenticated (Admin+) SQL Injection to Reflected Cross-Site Scripting

Type: advisorySources: OSV

The WP SMS – Messaging & SMS Notification for WordPress, WooCommerce, GravityForms, etc plugin for WordPress is vulnerable to SQL Injection via the 'group_id' parameter in all versions up to, and including, 6.5 due to insufficient escaping on the user supplied parameter and lack of sufficient preparation on the existing SQL query. This makes it possible for authenticated attackers, with contributor-level access and above, to append additional SQL queries into already existing queries that can be used to extract sensitive information from the database. This can leveraged to achieve Reflected Cross-site Scripting.

Products
Not specified
Affected versions
Not specified
Fixed versions
Not specified
CVEs
CVE-2023-6981
Confirmed fixed CVEs
Not specified
Updated in this feed
2 Nov 2026, 23:31 UTC · Revision 1

Source evidence

WP SMS <= 6.5 - Authenticated (Admin+) SQL Injection to Reflected Cross-Site Scripting

core-osv · Original source

Published 3 Jan 2024, 05:31 UTC

The WP SMS – Messaging & SMS Notification for WordPress, WooCommerce, GravityForms, etc plugin for WordPress is vulnerable to SQL Injection via the 'group_id' parameter in all versions up to, and including, 6.5 due to insufficient escaping on the user supplied parameter and lack of sufficient preparation on the existing SQL query. This makes it possible for authenticated attackers, with contributor-level access and above, to append additional SQL queries into already existing queries that can be used to extract sensitive information from the database. This can leveraged to achieve Reflected Cross-site Scripting.

osv:CVE-2023-6981
Complete source record
{
  "id": "4644637ea1cd5854cf0af7304fced823bc92a45dd01adf3767d351b6e9d70b70",
  "url": "https://osv.dev/vulnerability/CVE-2023-6981",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "WP SMS <= 6.5 - Authenticated (Admin+) SQL Injection to Reflected Cross-Site Scripting",
    "summary": "The WP SMS – Messaging & SMS Notification for WordPress, WooCommerce, GravityForms, etc plugin for WordPress is vulnerable to SQL Injection via the 'group_id' parameter in all versions up to, and including, 6.5 due to insufficient escaping on the user supplied parameter and lack of sufficient preparation on the existing SQL query. This makes it possible for authenticated attackers, with contributor-level access and above, to append additional SQL queries into already existing queries that can be used to extract sensitive information from the database. This can leveraged to achieve Reflected Cross-site Scripting.",
    "evidence": "osv:CVE-2023-6981",
    "products": [],
    "severity": "medium",
    "structured": {
      "id": "CVE-2023-6981",
      "aliases": [
        "CVE-2023-6981"
      ],
      "metrics": [
        {
          "type": "CVSS_V3",
          "score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N"
        }
      ],
      "affected": [
        {
          "ranges": [
            {
              "repo": "https://github.com/wp-sms/wp-sms",
              "type": "GIT",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "7ad23a0596e8a1554ecfda9bfb9bae60c5598560"
                },
                {
                  "fixed": "6656de201efe67c7983102c344a546eed976a819"
                }
              ],
              "database_specific": {
                "extracted_events": [
                  {
                    "cpe": "cpe:2.3:a:veronalabs:wp_sms:*:*:*:*:free:wordpress:*:*",
                    "range": [
                      {
                        "introduced": "0"
                      },
                      {
                        "fixed": "6.5.1"
                      }
                    ],
                    "source": "CPE_RANGE"
                  },
                  {
                    "range": [
                      {
                        "fixed": "6656de201efe67c7983102c344a546eed976a819"
                      }
                    ],
                    "source": "REFERENCES_COMMIT"
                  }
                ]
              }
            }
          ],
          "versions": [
            "v6.5",
            "v6.4.2",
            "v6.4.1",
            "v6.4",
            "v6.3.4",
            "v6.3.3",
            "v6.3.2",
            "v6.3.1",
            "v6.3",
            "v6.2.4.1",
            "v6.2.4",
            "v6.2.3",
            "v6.2.2",
            "v6.2.1",
            "v6.2.0.2",
            "v6.2.0.1",
            "v6.2.0",
            "v6.1.5",
            "v6.1.4",
            "v6.1.3",
            "v6.1.2",
            "v6.1.1",
            "v6.1",
            "v6.0.4.1",
            "v6.0.4",
            "v6.0.3",
            "v6.0.2",
            "v6.0.1",
            "v6.0",
            "v5.9.1",
            "v5.9",
            "v5.8.5",
            "v5.8.4",
            "v5.8.3",
            "v5.8.2",
            "v5.8.1",
            "v5.8.0",
            "v5.7.9",
            "v5.7.8",
            "v5.7.7",
            "v5.7.6",
            "v5.7.5.1",
            "v5.7.5",
            "v5.7.4",
            "v5.7.3.1",
            "v5.7.3",
            "5.4.6",
            "5.4.5",
            "5.4.4",
            "5.4.2",
            "5.4.1",
            "5.4",
            "5.3.1",
            "5.3",
            "5.2.2",
            "5.2.1",
            "5.1.9",
            "5.1.8",
            "5.1.7",
            "5.1.6",
            "5.1.5",
            "5.1.4",
            "5.1.3",
            "5.1.2",
            "5.1.1",
            "5.1",
            "5.0",
            "4.1.1",
            "4.1.0",
            "4.0.21",
            "4.0.20",
            "4.0.19",
            "4.0.18",
            "4.0.16",
            "4.0.14",
            "4.0.12",
            "4.0.11",
            "4.0.10",
            "4.0.9",
            "4.0.8",
            "4.0.7",
            "4.0.6",
            "4.0.5",
            "4.0.4",
            "4.0.3",
            "4.0.2",
            "4.0.1",
            "4.0.0"
          ],
          "database_specific": {
            "source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2023-6981.json"
          }
        }
      ],
      "modified": "2026-10-28T02:30:24.274133056Z",
      "provider": "osv",
      "references": [
        "https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&old=3015006%40wp-sms&new=3015006%40wp-sms&sfp_email=&sfph_mail=",
        "https://www.wordfence.com/threat-intel/vulnerabilities/id/b8f53053-5150-4fba-b8d6-3d6c9df32c69?source=cve",
        "https://github.com/CVEProject/cvelistV5/tree/main/cves/2023/6xxx/CVE-2023-6981.json",
        "https://nvd.nist.gov/vuln/detail/CVE-2023-6981",
        "https://github.com/wp-sms/wp-sms/commit/6656de201efe67c7983102c344a546eed976a819"
      ],
      "provider_metadata": {
        "cwe_ids": [
          "CWE-89"
        ],
        "cna_assigner": "Wordfence",
        "osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2023/6xxx/CVE-2023-6981.json"
      }
    },
    "related_cves": [
      {
        "value": "CVE-2023-6981",
        "evidence": "/id"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/severity/0/score"
  },
  "source_id": "core-osv",
  "document_id": 490910,
  "published_at": "2024-01-03T05:31:19.434+00:00"
}