Skip to content
Heist/ feed
Back to feed
High

POST SMTP Mailer – Email log, Delivery Failure Notifications and Best Mail SMTP for WordPress <= 2.9.3 - Authenticated (Administrator+) SQL Injection

Type: advisorySources: OSV

The POST SMTP – The #1 WordPress SMTP Plugin with Advanced Email Logging and Delivery Failure Notifications plugin for WordPress is vulnerable to time-based SQL Injection via the selected parameter in all versions up to, and including, 2.9.3 due to insufficient escaping on the user supplied parameter and lack of sufficient preparation on the existing SQL query. This makes it possible for authenticated attackers with administrator access or higher to append additional SQL queries into already existing queries that can be used to extract sensitive information from the database.

Products
Not specified
Affected versions
Not specified
Fixed versions
Not specified
CVEs
CVE-2024-5207
Confirmed fixed CVEs
Not specified
Updated in this feed
2 Nov 2026, 20:29 UTC · Revision 1

Source evidence

POST SMTP Mailer – Email log, Delivery Failure Notifications and Best Mail SMTP for WordPress <= 2.9.3 - Authenticated (Administrator+) SQL Injection

core-osv · Original source

Published 30 May 2024, 05:33 UTC

The POST SMTP – The #1 WordPress SMTP Plugin with Advanced Email Logging and Delivery Failure Notifications plugin for WordPress is vulnerable to time-based SQL Injection via the selected parameter in all versions up to, and including, 2.9.3 due to insufficient escaping on the user supplied parameter and lack of sufficient preparation on the existing SQL query. This makes it possible for authenticated attackers with administrator access or higher to append additional SQL queries into already existing queries that can be used to extract sensitive information from the database.

osv:CVE-2024-5207
Complete source record
{
  "id": "7287674815ddd3478a5bce232ac121f2a1b46d2ed36ce73ee4fff9c5a6dba041",
  "url": "https://osv.dev/vulnerability/CVE-2024-5207",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "POST SMTP Mailer – Email log, Delivery Failure Notifications and Best Mail SMTP for WordPress <= 2.9.3 - Authenticated (Administrator+) SQL Injection",
    "summary": "The POST SMTP – The #1 WordPress SMTP Plugin with Advanced Email Logging and Delivery Failure Notifications plugin for WordPress is vulnerable to time-based SQL Injection via the selected parameter in all versions up to, and including, 2.9.3 due to insufficient escaping on the user supplied parameter and lack of sufficient preparation on the existing SQL query. This makes it possible for authenticated attackers with administrator access or higher to append additional SQL queries into already existing queries that can be used to extract sensitive information from the database.",
    "evidence": "osv:CVE-2024-5207",
    "products": [],
    "severity": "high",
    "structured": {
      "id": "CVE-2024-5207",
      "aliases": [
        "CVE-2024-5207"
      ],
      "metrics": [
        {
          "type": "CVSS_V3",
          "score": "CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H"
        }
      ],
      "affected": [
        {
          "ranges": [
            {
              "repo": "https://github.com/wpexpertsio/post-smtp",
              "type": "GIT",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "d9372dc5c5950beb336b25c7665d87a2389cc779"
                }
              ],
              "database_specific": {
                "extracted_events": [
                  {
                    "cpe": "cpe:2.3:a:wpexperts:post_smtp:*:*:*:*:*:wordpress:*:*",
                    "range": [
                      {
                        "introduced": "0"
                      },
                      {
                        "fixed": "2.9.4"
                      }
                    ],
                    "source": "CPE_RANGE"
                  }
                ]
              }
            }
          ],
          "versions": [
            "2.5.9-beta.1",
            "2.5.8",
            "2.5.7",
            "2.5.6",
            "2.5.5",
            "2.5.4",
            "2.5.3",
            "2.5.2",
            "2.5.1",
            "2.5.0",
            "2.5-rc.3",
            "2.5-rc.2",
            "2.5-rc.1",
            "2.5-beta.1",
            "2.4.3",
            "2.4.2-beta.2",
            "2.4.2",
            "2.4.1",
            "2.4",
            "2.4-beta.1",
            "2.3.1",
            "2.3",
            "2.2.1",
            "2.2",
            "2.2-beta.2",
            "2.1.8",
            "2.1.7",
            "2.1.6",
            "2.1.4",
            "2.1.4-rc.2",
            "2.1.4-rc.1",
            "2.1.4-beta.1",
            "2.1.2",
            "2.1.2-rc.2",
            "2.1.2-rc.1",
            "2.1.2-beta-1",
            "2.1.1.1",
            "2.1.1",
            "2.1",
            "2.1-beta.1",
            "2.0.27",
            "2.0.26",
            "2.0.25-beta.1",
            "2.0.25",
            "2.0.24",
            "2.0.23",
            "2.0.22",
            "2.0.21",
            "2.0.20",
            "2.0.19",
            "2.0.18",
            "2.0.17",
            "2.0.16",
            "2.0.15",
            "2.0.14",
            "2.0.13",
            "2.0.12",
            "2.0.11",
            "2.0.10",
            "2.0.9",
            "2.0.8",
            "2.0.7",
            "2.0.6",
            "2.0.5",
            "2.0.4",
            "2.0.3",
            "2.0.2",
            "2.0.1",
            "v1.9.8",
            "v1.9.7",
            "v1.9.6",
            "v1.9.5",
            "v1.9.4",
            "v1.9.3",
            "v.1.9.2",
            "v.1.9.1",
            "v.1.9.0"
          ],
          "database_specific": {
            "source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2024-5207.json"
          }
        }
      ],
      "modified": "2026-10-28T02:30:23.193911400Z",
      "provider": "osv",
      "references": [
        "https://plugins.trac.wordpress.org/browser/post-smtp/trunk/Postman/Postman-Email-Log/PostmanEmailQueryLog.php?rev=2974258#L262",
        "https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&new=3094453%40post-smtp%2Ftrunk&old=3090744%40post-smtp%2Ftrunk&sfp_email=&sfph_mail=",
        "https://www.wordfence.com/threat-intel/vulnerabilities/id/103db583-9399-4a45-a316-808b55fc6a6c?source=cve",
        "https://github.com/CVEProject/cvelistV5/tree/main/cves/2024/5xxx/CVE-2024-5207.json",
        "https://nvd.nist.gov/vuln/detail/CVE-2024-5207"
      ],
      "provider_metadata": {
        "cwe_ids": [
          "CWE-89"
        ],
        "cna_assigner": "Wordfence",
        "unresolved_ranges": [
          {
            "extracted_events": [
              {
                "range": [
                  {
                    "last_affected": "2.9.3"
                  }
                ],
                "source": "AFFECTED_FIELD",
                "strategy": "StandardRange"
              }
            ]
          }
        ],
        "osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2024/5xxx/CVE-2024-5207.json"
      }
    },
    "related_cves": [
      {
        "value": "CVE-2024-5207",
        "evidence": "/id"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/severity/0/score"
  },
  "source_id": "core-osv",
  "document_id": 489738,
  "published_at": "2024-05-30T05:33:15.366+00:00"
}