Skip to content
Heist/ feed
Back to feed
Critical

Security advisory

Type: advisorySources: OSVCVE: CVE-2016-3088

The Fileserver web application in Apache ActiveMQ 5.x before 5.14.0 allows remote attackers to upload and execute arbitrary files via an HTTP PUT followed by an HTTP MOVE request.

Products
Not specified
Affected versions
Not specified
Fixed versions
Not specified
CVEs
CVE-2016-3088
Confirmed fixed CVEs
Not specified
Updated in this feed
1 Nov 2026, 08:09 UTC · Revision 1

Source evidence

CVE-2016-3088

core-osv · Original source

Published 1 Jun 2016, 20:59 UTC

The Fileserver web application in Apache ActiveMQ 5.x before 5.14.0 allows remote attackers to upload and execute arbitrary files via an HTTP PUT followed by an HTTP MOVE request.

osv:CVE-2016-3088
Complete source record
{
  "id": "dd474fd47f9adc7070f2a85205b7948494d02aaae411e9c63636a2c0e4a372e9",
  "url": "https://osv.dev/vulnerability/CVE-2016-3088",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "CVE-2016-3088",
    "summary": "The Fileserver web application in Apache ActiveMQ 5.x before 5.14.0 allows remote attackers to upload and execute arbitrary files via an HTTP PUT followed by an HTTP MOVE request.",
    "evidence": "osv:CVE-2016-3088",
    "products": [],
    "severity": "critical",
    "structured": {
      "id": "CVE-2016-3088",
      "aliases": [
        "CVE-2016-3088",
        "GHSA-rxqh-fc23-gxp2"
      ],
      "metrics": [
        {
          "type": "CVSS_V3",
          "score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H"
        }
      ],
      "affected": [
        {
          "ranges": [
            {
              "repo": "https://github.com/apache/activemq",
              "type": "GIT",
              "events": [
                {
                  "introduced": "38fcc0ce0178d4a6870aa4f68e2b565c1ad0aa6f"
                },
                {
                  "fixed": "71cbc652835e8b6b9d17b7a28fc998fce4840a9b"
                }
              ],
              "database_specific": {
                "extracted_events": [
                  {
                    "cpe": "cpe:2.3:a:apache:activemq:*:*:*:*:*:*:*:*",
                    "range": [
                      {
                        "introduced": "5.0.0"
                      },
                      {
                        "fixed": "5.14.0"
                      }
                    ],
                    "source": "CPE_RANGE"
                  }
                ]
              }
            }
          ],
          "database_specific": {
            "source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2016-3088.json"
          }
        }
      ],
      "modified": "2026-10-24T10:31:03.596410436Z",
      "provider": "osv",
      "references": [
        "https://www.cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2016-3088",
        "https://lists.apache.org/thread.html/r6d03e45b81eab03580cf7f8bb51cb3e9a1b10a2cc0c6a2d3cc92ed0c%40%3Cannounce.apache.org%3E",
        "https://lists.apache.org/thread.html/f956ea38e4da2e2c1e7131e6f91e41754852f5a4861d1a14ca5ca78a%40%3Cusers.activemq.apache.org%3E",
        "https://lists.apache.org/thread.html/a859563f05fbe7c31916b3178c2697165bd9bbf5a65d1cf62aef27d2%40%3Ccommits.activemq.apache.org%3E",
        "https://www.exploit-db.com/exploits/42283/"
      ],
      "provider_metadata": {}
    },
    "related_cves": [
      {
        "value": "CVE-2016-3088",
        "evidence": "/id"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/severity/0/score"
  },
  "source_id": "core-osv",
  "document_id": 440296,
  "published_at": "2016-06-01T20:59:04.123+00:00"
}